saltbundle-libsodium/saltbundle-libsodium.spec

92 lines
2.6 KiB
RPMSpec

#
# spec file for package saltbundle-libsodium
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define _lto_cflags %{nil}
%define sover 23
%define lname %{name}
%define lib_name libsodium
Name: saltbundle-libsodium
Version: 1.0.18
Release: 0
Summary: Portable NaCl-based crypto library
License: ISC
Group: System/Libraries
URL: https://github.com/jedisct1/libsodium
Source0: libsodium-%{version}.tar.gz
Source1: libsodium-%{version}.tar.gz.sig
Source2: libsodium.keyring
Source1000: saltbundle-libsodium-rpmlintrc
BuildRequires: pkgconfig
%if "%_vendor" == "debbuild"
BuildRequires: debbuild
%endif
AutoReqProv: 0
%description
NaCl (pronounced "salt") is a new easy-to-use high-speed software library
for network communication, encryption, decryption, signatures, etc.NaCl's goal
is to provide all of the core operations needed to build higher-level cryptographic tools.
Sodium is a portable, cross-compilable, installable, packageable fork of NaCl,
with a compatible API.
%package devel
Summary: Portable NaCl-based crypto library
Group: Development/Libraries/C and C++
Requires: %{lname} = %{version}
AutoReqProv: 0
%description devel
This package contains all necessary include files and libraries needed
to compile and develop applications that use libsodium.
%prep
%setup -q -n libsodium-%{version}
%build
# Do _NOT_ change CFLAGS
# See https://github.com/jedisct1/libsodium/issues/604
%configure \
--disable-static \
--disable-silent-rules
make %{?_smp_mflags}
%install
%make_install
find %{buildroot} -type f -name "*.la" -delete -print
%check
make %{?_smp_mflags} check
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files -n %{lname}
%license LICENSE
%{_libdir}/%{lib_name}.so.%{sover}*
%files devel
%doc AUTHORS ChangeLog README.markdown THANKS
%{_includedir}/sodium.h
%{_includedir}/sodium
%{_libdir}/%{lib_name}.so
%{_libdir}/pkgconfig/%{lib_name}.pc
%changelog