saltbundlepy-asn1crypto/saltbundlepy-asn1crypto.spec

70 lines
2.1 KiB
RPMSpec

#
# spec file for package saltbundlepy-asn1crypto
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
%bcond_without test
Name: saltbundlepy-asn1crypto
Version: 1.5.1
Release: 0
Summary: ASN.1 parser and serializer for Python
License: MIT
Group: Development/Languages/Python
URL: https://github.com/wbond/asn1crypto
Source: https://github.com/wbond/asn1crypto/archive/%{version}.tar.gz
BuildRequires: %{saltbundlepy_module devel > 3.10}
BuildRequires: %{saltbundlepy_module pip}
BuildRequires: %{saltbundlepy_module wheel}
BuildRequires: saltbundlepy-rpm-macros
BuildRequires: fdupes
Requires: saltbundlepy-base
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildArch: noarch
%python_subpackages
%description
ASN.1 parser and serializer with definitions for private keys,
public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7,
PKCS#8, PKCS#12, PKCS#5, X509 and TSP
%prep
%autosetup -p1 -n asn1crypto-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pyunittest discover -v
%files %{python_files}
%license LICENSE
%{python_sitelib}/asn1crypto
%{python_sitelib}/asn1crypto-%{version}*-info
%changelog