saltbundlepy-cffi/saltbundlepy-cffi.spec

91 lines
2.7 KiB
RPMSpec

#
# spec file for package saltbundlepy-cffi
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
Name: saltbundlepy-cffi
Version: 1.15.1
Release: 0
Summary: Foreign Function Interface for Python calling C code
License: MIT
Group: Development/Languages/Python
URL: http://cffi.readthedocs.org
Source0: https://files.pythonhosted.org/packages/source/c/cffi/cffi-%{version}.tar.gz
Source1: saltbundlepy-cffi-rpmlintrc
Patch1: 8a3c2c816d789639b49d3ae867213393ed7abdff.patch
BuildRequires: %{saltbundlepy_module devel >= 3.11}
BuildRequires: %{saltbundlepy_module py}
BuildRequires: %{saltbundlepy_module pycparser}
BuildRequires: %{saltbundlepy_module pytest}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
%if 0%{?suse_version} == 1110
BuildRequires: gcc48-c++
%else
BuildRequires: gcc-c++
%endif
BuildRequires: pkgconfig
BuildRequires: saltbundlepy-rpm-macros
BuildRequires: saltbundle-libffi-devel
Requires: saltbundlepy-pycparser
%python_subpackages
%description
Foreign Function Interface for Python calling C code. The aim of this project
is to provide a convenient and reliable way of calling C code from Python.
%prep
%setup -q -n cffi-%{version}
%autopatch -p1
%build
export CFLAGS="%{optflags}"
%if 0%{?suse_version} == 1110
export CC=gcc-4.8
export CXX=g++-4.8
%endif
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%ifnarch i386
%check
%if 0%{?sle_version} == 120000 && "%{_arch}" == "aarch64"
%define pytest_extra_opts -k 'not test_struct_by_value'
%else
%define pytest_extra_opts %{nil}
%endif
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitearch}
py.test-%$python_bin_suffix -v -W ignore::UserWarning %{pytest_extra_opts} c/ testing/
}
%endif
%files %{python_files}
%license LICENSE
%doc README.md doc/source/*.rst doc/misc/*.rst
%{python_sitearch}/*
%changelog