saltbundlepy-hatch-vcs/saltbundlepy-hatch-vcs.spec

91 lines
2.5 KiB
RPMSpec

#
# spec file for package saltbundlepy-hatch-vcs
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
Name: saltbundlepy-hatch-vcs%{psuffix}
Version: 0.3.0
Release: 0
Summary: Hatch plugin for versioning with your preferred VCS
License: MIT
URL: https://github.com/ofek/hatch-vcs
Source: https://files.pythonhosted.org/packages/source/h/hatch_vcs/hatch_vcs-%{version}.tar.gz
Patch1: setuptools7x-tests.patch
BuildRequires: fdupes
BuildRequires: saltbundlepy-rpm-macros
# https://github.com/ofek/hatch-vcs/issues/8
Requires: saltbundlepy-setuptools-scm >= 6.4.0
Requires: saltbundlepy-hatchling >= 0.21.0
BuildArch: noarch
# SECTION build
BuildRequires: %{saltbundlepy_module hatchling >= 0.21.0}
BuildRequires: %{saltbundlepy_module pip}
# /SECTION
%if %{with test}
# SECTION test
%if "%_vendor" == "debbuild"
BuildRequires: %{saltbundlepy_module hatch-vcs >= %{version}-~}
%else
BuildRequires: %{saltbundlepy_module hatch-vcs = %{version}}
%endif
BuildRequires: %{saltbundlepy_module pytest}
BuildRequires: %{saltbundlepy_module setuptools-scm >= 6.4.0}
BuildRequires: git
# /SECTION
%endif
%python_subpackages
%description
This provides a plugin for Hatch that uses your preferred version control system (like Git) to determine project versions.
%prep
%autosetup -p1 -n hatch_vcs-%{version}
%build
%pyproject_wheel
%install
%if %{without test}
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%check
%if %{with test}
%pytest tests
%endif
%if %{without test}
%files %{python_files}
%license LICENSE.txt
%doc README.md
%{python_sitelib}/hatch_vcs
%{python_sitelib}/hatch_vcs-%{version}*-info
%endif
%changelog