saltbundlepy-more-itertools/saltbundlepy-more-itertools.spec

69 lines
2.1 KiB
RPMSpec

#
# spec file for package saltbundlepy-more-itertools
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
Name: saltbundlepy-more-itertools
Version: 9.1.0
Release: 0
Summary: More routines for operating on iterables, beyond itertools
License: MIT
Group: Development/Languages/Python
URL: https://github.com/erikrose/more-itertools
Source: https://files.pythonhosted.org/packages/source/m/more-itertools/more-itertools-%{version}.tar.gz
BuildRequires: %{saltbundlepy_module base >= 3.10}
BuildRequires: %{saltbundlepy_module pip}
BuildRequires: %{saltbundlepy_module flit-core}
BuildRequires: %{saltbundlepy_module wheel}
BuildRequires: fdupes
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-base
BuildArch: noarch
%python_subpackages
%description
Additional building blocks, recipes, and routines for working with
Python iterables.
%prep
%setup -q -n more-itertools-%{version}
chmod -x more_itertools/more.py
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pyunittest -v
%files %{python_files}
%doc README.rst
%license LICENSE
%{python_sitelib}/more_itertools/
%{python_sitelib}/more_itertools-%{version}*-info/
%changelog