saltbundlepy-pynacl/saltbundlepy-pynacl.spec

72 lines
2.2 KiB
RPMSpec

#
# spec file for package saltbundlepy-pynacl
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
Name: saltbundlepy-pynacl
Version: 1.5.0
Release: 0
Summary: Python binding to the Networking and Cryptography (NaCl) library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://github.com/pyca/pynacl/
Source: https://pypi.org/packages/source/P/PyNaCl/PyNaCl-%{version}.tar.gz
BuildRequires: %{saltbundlepy_module base >= 3.10}
BuildRequires: %{saltbundlepy_module cffi}
BuildRequires: %{saltbundlepy_module devel}
BuildRequires: %{saltbundlepy_module pycparser}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: %{saltbundlepy_module wheel}
BuildRequires: fdupes
BuildRequires: pkgconfig
BuildRequires: saltbundle-libsodium-devel
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundle-libsodium
Requires: saltbundlepy-cffi
AutoReqProv: 0
%python_subpackages
%description
PyNaCl is a Python binding to the `Networking and Cryptography library`_,
a crypto library with the stated goal of improving usability, security and
speed.
%prep
%setup -q -n PyNaCl-%{version}
rm -Rf src/libsodium
%build
export SODIUM_INSTALL="system"
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}/%{$python_sitearch}
%files %{python_files}
%license LICENSE
%doc README.rst
%{python_sitearch}/*
%changelog