saltbundlepy-pyopenssl/saltbundlepy-pyopenssl.spec

98 lines
3.4 KiB
RPMSpec

#
# spec file for package saltbundlepy-pyopenssl
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
Name: saltbundlepy-pyopenssl
Version: 23.2.0
Release: 0
Summary: Python wrapper module around the OpenSSL library
License: Apache-2.0
Group: Development/Languages/Python
URL: https://github.com/pyca/pyopenssl
Source: https://files.pythonhosted.org/packages/source/p/pyOpenSSL/pyOpenSSL-%{version}.tar.gz
# PATCH-FIX-UPSTREAM skip-networked-test.patch gh#pyca/pyopenssl#68 mcepl@suse.com
# Mark tests requiring network access
Patch0: skip-networked-test.patch
# Fix problem with old versions of OpenSSL
Patch1: revert_switch_to_new_utils_deprecation.patch
# Fix missing ASN1_STRING_get0_data definition in old OpenSSL versions
Patch2: fix-missing-ASN1_STRING_get0_data-in-old-openssl.patch
# Fix missing X509_CRL_set1_lastUpdate and X509_CRL_set1_nextUpdate
# in old OpenSSL versions
Patch3: fix-missing-X509_CRL_set1_lastUpdate-_nextUpdate.patch
BuildRequires: %{saltbundlepy_module base >= 3.10}
BuildRequires: %{saltbundlepy_module cffi}
BuildRequires: %{saltbundlepy_module cryptography >= 2.3.0}
%if %{with tests}
BuildRequires: %{saltbundlepy_module flaky}
BuildRequires: %{saltbundlepy_module pretend}
BuildRequires: %{saltbundlepy_module pytest >= 3.0.1}
%endif
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: %{saltbundlepy_module six}
BuildRequires: ca-certificates-mozilla
BuildRequires: fdupes
BuildRequires: openssl
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-cffi
Requires: saltbundlepy-cryptography >= 2.3.0
Requires: saltbundlepy-six >= 1.5.2
BuildArch: noarch
%python_subpackages
%description
pyOpenSSL is a set of Python bindings for OpenSSL. It includes some low-level
cryptography APIs but is primarily focused on providing an API for using the
TLS protocol from Python.
pyOpenSSL is now a pure-Python project with a dependency on a new project,
cryptography (<https://github.com/pyca/cryptography>), which provides (among
other things) a cffi-based interface to OpenSSL.
%prep
%autosetup -p1 -n pyOpenSSL-%{version}
%build
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%if %{with tests}
%check
export LC_ALL=en_US.UTF-8
%{python_expand export PYTHONPATH=%{buildroot}%{$python_sitelib}
py.test-%{$python_bin_suffix} -m "not network"
}
%endif
%files %{python_files}
%license LICENSE
%doc *.rst
%{python_sitelib}/OpenSSL/
%{python_sitelib}/pyOpenSSL-%{version}*-info
%changelog