saltbundlepy-pyzmq/saltbundlepy-pyzmq.spec

134 lines
4.2 KiB
RPMSpec

#
# spec file for package saltbundlepy-pyzmq
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
%global __brp_check_rpaths %{nil}
%bcond_with tests
Name: saltbundlepy-pyzmq
Version: 24.0.1
Release: 0
Summary: Python bindings for 0MQ
License: BSD-3-Clause AND LGPL-3.0-or-later
URL: https://github.com/zeromq/pyzmq
Source: https://files.pythonhosted.org/packages/source/p/pyzmq/pyzmq-%{version}.tar.gz
# For test markers
Source1: https://raw.githubusercontent.com/zeromq/pyzmq/v%{version}/pytest.ini
Source100: saltbundlepy-pyzmq-rpmlintrc
BuildRequires: %{saltbundlepy_module cython}
BuildRequires: %{saltbundlepy_module devel >= 3.10}
BuildRequires: %{saltbundlepy_module packaging}
BuildRequires: %{saltbundlepy_module setuptools}
BuildRequires: fdupes
BuildRequires: saltbundle-zeromq-devel
BuildRequires: saltbundlepy-rpm-macros
# SECTION Test requirements
%if %{with tests}
BuildRequires: %{saltbundlepy_module gevent}
BuildRequires: %{saltbundlepy_module paramiko}
BuildRequires: %{saltbundlepy_module pytest-timeout}
BuildRequires: %{saltbundlepy_module pytest}
BuildRequires: %{saltbundlepy_module simplejson}
BuildRequires: %{saltbundlepy_module tornado}
BuildRequires: %{saltbundlepy_module numpy if (%python-base without python36-base)}
%endif
# /SECTION
Requires: saltbundle-libzmq
Requires: saltbundlepy-cffi
Requires: saltbundlepy-py
AutoReqProv: 0
%python_subpackages
%description
PyZMQ is a lightweight and super-fast messaging library built on top of
the ZeroMQ library (http://www.zeromq.org).
%package devel
Summary: Development files for %{name}
Requires: %{name} = %{version}
Requires: saltbundle-zeromq-devel
Requires: saltbundlepy-base
Requires: saltbundlepy-devel
%description devel
Development libraries and headers needed to build software using %{name}.
%prep
%autosetup -n pyzmq-%{version} -p1
cp %{SOURCE1} ./
# Fix non-executable script rpmlint warning:
find examples zmq -name "*.py" -exec sed -i "s|#\!\/usr\/bin\/env python||" {} \;
chmod -x examples/pubsub/topics_pub.py examples/pubsub/topics_sub.py
# See https://github.com/zeromq/pyzmq/blob/master/setup.cfg.template
echo '
[global]
skip_check_zmq = False
zmq_prefix = %{_prefix}
no_libzmq_extension = True
'>> setup.cfg
%build
export CFLAGS="%{optflags}"
%python_build
%install
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitearch}
%if %{with tests}
%check
export LANG=en_US.UTF-8
# This test wants to build a custom cython extension, but does
# not have the source files installed into the buildroot
SKIPPED_TESTS+=" or test_cython"
# unreliable socket handling in obs environment
SKIPPED_TESTS+=" or test_log"
%if 0%{?suse_version} < 1550
# tries to open a network connection on older distributions
SKIPPED_TESTS+=" or test_null or test_int_sockopts"
%endif
# temporarily disable to build with OpenSSL 3.0 bsc#1205042
SKIPPED_TESTS+=" or test_on_recv_basic"
mkdir cleantest
pushd cleantest
%pytest_arch --pyargs zmq -k "not (${SKIPPED_TESTS:4})" --timeout 1200
popd
%endif
%files %{python_files}
%license COPYING.BSD COPYING.LESSER
%doc AUTHORS.md README.md examples
%{python_sitearch}/zmq
%{python_sitearch}/pyzmq-%{version}-py*.egg-info
%exclude %{python_sitearch}/zmq/utils/*.h
%exclude %{python_sitearch}/zmq/backend/cffi/_cdefs.h
%files %{python_files devel}
%{python_sitearch}/zmq/utils/*.h
%{python_sitearch}/zmq/backend/cffi/_cdefs.h
%changelog