saltbundlepy-setuptools-scm/saltbundlepy-setuptools-scm.spec

104 lines
3.1 KiB
RPMSpec

#
# spec file for package saltbundlepy-setuptools-scm
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!saltbundlepy_module:%define saltbundlepy_module() saltbundlepy-%{**}}
%define pythons saltbundlepy
# Disable python bytecompile for all distros
# It's called explicitly in the spec
%global __brp_python_bytecompile %{nil}
%global flavor @BUILD_FLAVOR@%{nil}
%if "%{flavor}" == "test"
%define psuffix -test
%bcond_without test
%else
%define psuffix %{nil}
%bcond_with test
%endif
Name: saltbundlepy-setuptools-scm%{psuffix}
Version: 7.1.0
Release: 0
Summary: Python setuptools handler for SCM tags
License: MIT
URL: https://github.com/pypa/setuptools_scm
Source: https://files.pythonhosted.org/packages/source/s/setuptools_scm/setuptools_scm-%{version}.tar.gz
BuildRequires: %{saltbundlepy_module base >= 3.10}
BuildRequires: %{saltbundlepy_module packaging >= 20.0}
BuildRequires: %{saltbundlepy_module pip}
BuildRequires: %{saltbundlepy_module setuptools >= 45}
BuildRequires: %{saltbundlepy_module typing-extensions}
BuildRequires: %{saltbundlepy_module wheel}
BuildRequires: fdupes
BuildRequires: saltbundlepy-rpm-macros
Requires: saltbundlepy-packaging >= 20.0
Requires: saltbundlepy-setuptools >= 45
Requires: saltbundlepy-typing-extensions
%if 0%{?python_version_nodots} < 311
Requires: saltbundlepy-tomli >= 1
%endif
BuildArch: noarch
%if %{with test}
# Testing requirements
BuildRequires: %{saltbundlepy_module pytest}
BuildRequires: %{saltbundlepy_module setuptools-scm = %{version}}
BuildRequires: %{saltbundlepy_module virtualenv > 20}
BuildRequires: git-core
BuildRequires: mercurial
%endif
%if 0%{?suse_version} || 0%{?fedora_version} >= 24
Recommends: git-core
%endif
%python_subpackages
%description
The setuptools_scm package handles managing one's Python package versions
in SCM metadata. It also handles file finders for the supperted SCMs.
%prep
%setup -q -n setuptools_scm-%{version}
%build
%python_build
%install
%if !%{with test}
%python_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%endif
%if %{with test}
%check
# pip download needs network
donttest="test_pip_download"
# tested file not installed into sitelib. Yes the test is named that way.
donttest+=" or test_git_archhival_from_unfiltered"
%pytest -k "not ($donttest)"
%endif
%if !%{with test}
%files %{python_files}
%license LICENSE
%doc README.rst CHANGELOG.rst
%{python_sitelib}/setuptools_scm
%{python_sitelib}/setuptools_scm-%{version}*-info
%endif
%changelog