MozillaFirefox-branding-SLE/MozillaFirefox-branding-SLE.spec

137 lines
3.8 KiB
RPMSpec

#
# spec file for package MozillaFirefox-branding-SLE
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define major 128
%define major_plus %( echo $((%{major}+1)) )
BuildRequires: MozillaFirefox
BuildRequires: unzip
BuildRequires: zip
%if 0%{?suse_version} > 1200 && 0%{?suse_version} < 1600
BuildRequires: gconf2-devel
%endif
Name: MozillaFirefox-branding-SLE
Version: %{major}
Release: 0
Summary: SLED branding of MozillaFirefox
License: BSD-3-Clause
Group: Productivity/Networking/Web/Browsers
Source: COPYING
Source3: firefox-SLE.js
Source4: firefox.schemas
Source5: distribution.ini.in
Source6: all-SLE.js
Source8: README.SUSE
PreReq: MozillaFirefox >= %{major}
PreReq: MozillaFirefox < %{major_plus}
Supplements: packageand(MozillaFirefox:branding-SLE)
Provides: MozillaFirefox-branding = %{version}
Conflicts: otherproviders(MozillaFirefox-branding)
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%define homepage https://www.suse.com/
%define progdir %{_libdir}/firefox
%if 0%{?suse_version} == 1315
%define sle_version 12
%endif
%define progdir %{_prefix}/%_lib/firefox
%define libgssapi libgssapi_krb5.so.2
%define gnome_confdir %{_sysconfdir}
%define gnome_dir %{_prefix}
%if 0%{?suse_version} < 1600
%gconf_schemas_prereq
%if 0%{?suse_version} > 1100
Requires(pre): /usr/bin/gconftool-2 coreutils
%else
PreReq: gconf2 coreutils
%endif
%endif
%description
This package provides SLED Look and Feel for MozillaFirefox.
Authors:
--------
Petr Cerny <pcerny@suse.com>
%prep
cp %{SOURCE0} %{SOURCE8} .
sed -i 's,@HOMEPAGEURL@,%{homepage},' %{SOURCE4} %{SOURCE5}
%build
%install
install -d %{buildroot}%{progdir}
install -d %{buildroot}%{progdir}/browser
# custom bookmarks
install -d %{buildroot}%{progdir}/browser/defaults/profile
# apply SUSE defaults
# all applications
install -d %{buildroot}%{progdir}/defaults/pref
install -m0644 %{SOURCE6} %{buildroot}%{progdir}/defaults/pref/
# firefox
install -d %{buildroot}%{progdir}/browser/defaults/preferences
install -m0644 %{SOURCE3} %{buildroot}%{progdir}/browser/defaults/preferences/firefox-SLE.js
sed -i -e 's,@GSSAPI@,%{libgssapi},g' %{buildroot}%{progdir}/browser/defaults/preferences/firefox-SLE.js
# distribution.ini
install -d %{buildroot}%{progdir}/distribution
sed -e 's,%%VERSION%%,%{sle_version},g' \
%{SOURCE5} > distribution.ini
install -d %{buildroot}%{progdir}/distribution/
install -m 0644 distribution.ini %{buildroot}%{progdir}/distribution/
%if 0%{?suse_version} < 1600
# SCHEMA file
mkdir -p %{buildroot}%{gnome_confdir}/gconf/schemas
install -m 644 %{SOURCE4} \
%{buildroot}%{gnome_confdir}/gconf/schemas/
%find_gconf_schemas
%endif
%clean
rm -rf %{buildroot}
%if 0%{?suse_version} < 1600
%pre -f %{name}.schemas_pre
%preun -f %{name}.schemas_preun
%posttrans -f %{name}.schemas_posttrans
%endif
%if 0%{?suse_version} < 1600
%files -f %{name}.schemas_list
%else
%files
%endif
%defattr(-,root,root)
%doc README.SUSE
%license COPYING
%{progdir}/defaults/pref/
%{progdir}/browser/
%{progdir}/browser/defaults/
%{progdir}/browser/defaults/preferences/
%{progdir}/browser/defaults/profile/
%{progdir}/distribution/
%changelog