perl-Sub-Uplevel/perl-Sub-Uplevel.spec

61 lines
1.8 KiB
RPMSpec

#
# spec file for package perl-Sub-Uplevel
#
# Copyright (c) 2018 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define cpan_name Sub-Uplevel
Name: perl-Sub-Uplevel
Version: 0.2800
Release: 0
Summary: Apparently run a function in a higher stack frame
License: GPL-1.0-or-later OR Artistic-1.0
Group: Development/Libraries/Perl
Url: https://metacpan.org/release/%{cpan_name}
Source: https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/%{cpan_name}-%{version}.tar.gz
BuildRequires: perl
BuildRequires: perl-macros
BuildRequires: perl(Carp)
BuildRequires: perl(Module::Build)
BuildRequires: perl(Test::More) >= 0.47
BuildArch: noarch
%{perl_requires}
%description
Like Tcl's uplevel() function, but not quite so dangerous. The idea is
just to fool caller(). All the really naughty bits of Tcl's uplevel()
are avoided.
%prep
%setup -q -n %{cpan_name}-%{version}
%build
%check
make %{?_smp_mflags} test
%install
perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags} -Wall"
make %{?_smp_mflags}
%perl_make_install
%perl_process_packlist
%perl_gen_filelist
%files -f %{name}.files
%license LICENSE
%doc Changes examples README xt
%changelog