python-partd/python-partd.spec

75 lines
2.0 KiB
RPMSpec

#
# spec file for package python-partd
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: python-partd
Version: 1.4.1
Release: 0
Summary: Appendable key-value storage
License: BSD-3-Clause
Group: Development/Languages/Python
URL: https://github.com/mrocklin/partd/
Source: https://files.pythonhosted.org/packages/source/p/partd/partd-%{version}.tar.gz
BuildRequires: %{python_module locket}
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module toolz}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-locket
Requires: python-toolz
Recommends: python-blosc
Recommends: python-numpy >= 1.9.0
Recommends: python-pandas
Recommends: python-pyzmq
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module pytest}
# /SECTION
%python_subpackages
%description
Key-value byte store with appendable values
Partd stores key-value pairs.
Values are raw bytes.
We append on old values.
Partd excels at shuffling operations.
%prep
%setup -q -n partd-%{version}
%build
%pyproject_wheel
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc README.rst
%license LICENSE.txt
%{python_sitelib}/partd
%{python_sitelib}/partd-%{version}.dist-info
%changelog