python-persistent/python-persistent.spec

85 lines
2.9 KiB
RPMSpec

#
# spec file for package python-persistent
#
# Copyright (c) 2023 SUSE LLC
# Copyright (c) 2013-2023 LISA GmbH, Bingen, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
Name: python-persistent
Version: 5.0
Release: 0
Summary: Translucent persistent objects
License: ZPL-2.1
URL: https://github.com/zopefoundation/persistent
Source: https://files.pythonhosted.org/packages/source/p/persistent/persistent-%{version}.tar.gz
BuildRequires: %{python_module cffi}
BuildRequires: %{python_module devel}
BuildRequires: %{python_module manuel}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module zope.interface}
BuildRequires: %{python_module zope.testrunner}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-cffi
Requires: python-zope.interface
%python_subpackages
%description
This package contains a generic persistence implementation for Python. It forms
the core protocol for making objects interact "transparently" with a database
such as the ZODB.
%package devel
Summary: Translucent persistent objects
Requires: %{name} = %{version}
Requires: python-devel
%description devel
This package contains the files needed for binding the %{name} C module.
%prep
%setup -q -n persistent-%{version}
rm -rf persistent.egg-info
# this two tests fail persistently (pun intended): disable them here allows to build with 15.4 as well
sed -i 's|test__p_repr_exception|tst__p_repr_exception|' src/persistent/tests/test_persistence.py
sed -i 's|test__p_repr_in_instance_ignored|tst__p_repr_in_instance_ignored|' src/persistent/tests/test_persistence.py
%build
%python_build
%install
%python_install
# don't bother with development files
%{python_expand rm %{buildroot}%{$python_sitearch}/persistent/*.c
%fdupes %{buildroot}%{$python_sitearch}
}
%check
%pyunittest_arch -v src/persistent/tests/*.py
%files %{python_files}
%license LICENSE.txt
%doc CHANGES.rst COPYRIGHT.txt README.rst
%exclude %{python_sitearch}/persistent/*.h
%{python_sitearch}/*
%files %{python_files devel}
%dir %{python_sysconfig_path include}/persistent
%{python_sysconfig_path include}/persistent/*.h
%{python_sitearch}/persistent/*.h
%changelog