1
0
forked from pool/osc
osc-fork/PKGBUILD
Dirk Mueller 7ce9edb4de Accepting request 1088780 from home:dmach:branches:openSUSE:Tools
- 1.1.4
  - Command-line:
    - Change 'review list' command to display open requests (state: new, review, declined)
    - Fix running osc in an AppImage by switching to the correct working directory
    - Handle ProtocolError exception
  - Library:
    - Add 'req_states' parameter to osc.core.get_review_list()
  - Connection:
    - Fix grabber to work with old urllib3 versions that do not contain URLSchemeUnknown exception

OBS-URL: https://build.opensuse.org/request/show/1088780
OBS-URL: https://build.opensuse.org/package/show/openSUSE:Tools/osc?expand=0&rev=402
2023-05-25 11:13:22 +00:00

24 lines
599 B
Bash

pkgname=osc
pkgver=1.1.4
pkgrel=0
pkgdesc="Command-line client for the Open Build Service"
arch=('x86_64')
url="https://www.github.com/openSUSE/osc"
license=('GPL-2.0+' 'GPL-2.0')
groups=('base-devel')
depends=('python-cryptography' 'python-urllib3')
makedepends=('python>=3.6' 'python-cryptography' 'python-setuptools' 'python-urllib3')
source=(osc-${pkgver}.tar.gz)
md5sums=('SKIP')
build() {
cd "${srcdir}"/osc-${pkgver}
python setup.py build
}
package() {
msg "Installing osc ..."
cd "${srcdir}"/osc-${pkgver}
python setup.py install --root="${pkgdir}/" --optimize=1 --prefix=/usr
}