erlang-oauth/erlang-oauth.spec

51 lines
1.6 KiB
RPMSpec

#
# spec file for package erlang-oauth
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: erlang-oauth
Version: 0.0.0+git.1293882491.2b796ea
%define mod_ver %(echo "%{version}" | cut -d "+" -f1)
Release: 0
License: MIT
Summary: Erlang OAuth implementation
Url: http://github.com/opscode/erlang-oauth/
Group: Development/Libraries/Other
Source: erlang-oauth-%{version}.tar.gz
BuildRequires: erlang-rebar
Requires: erlang
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
An Erlang OAuth implementation.
%prep
%setup -n erlang-oauth-%{version}
%build
%rebar compile escriptize
%install
for dir in ebin ; do
install -d %{buildroot}%{erlang_libdir}/oauth-%{mod_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/oauth-%{mod_ver}/${dir}/
done
%files
%defattr(-,root,root)
%dir %{erlang_libdir}/oauth-%{mod_ver}
%{erlang_libdir}/oauth-%{mod_ver}/ebin