erlang-parse_trans/erlang-parse_trans.spec

64 lines
2.0 KiB
RPMSpec

#
# spec file for package erlang-parse_trans
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define app_name parse_trans
Name: erlang-%{app_name}
Version: 2.9.2+git20151031.4fadce8
Release: 0
%define app_ver %(echo "%{version}" | cut -d "+" -f1)
Summary: Parse transform utilities for Erlang
License: ErlPL-1.1
Group: Development/Libraries/Other
Url: https://github.com/uwiger/parse_trans
Source: %{app_name}-%{version}.tar.bz2
Requires: erlang
BuildRequires: erlang
BuildRequires: erlang-edown
BuildRequires: erlang-rebar
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Parse transform utilities for Erlang
%prep
%setup -q -n %{app_name}-%{version}
%build
%rebar_set_vsn_cache %{app_ver}
%rebar compile
%install
for dir in ebin include ; do
mkdir -p %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}
cp -r ${dir}/* %{buildroot}%{erlang_libdir}/%{app_name}-%{app_ver}/${dir}/
done
%check
%files
%defattr(-,root,root)
%doc examples doc README.md
%dir %{erlang_libdir}/%{app_name}-%{app_ver}
%dir %{erlang_libdir}/%{app_name}-%{app_ver}/ebin
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/%{app_name}.app
%{erlang_libdir}/%{app_name}-%{app_ver}/ebin/*.beam
%dir %{erlang_libdir}/%{app_name}-%{app_ver}/include
%{erlang_libdir}/%{app_name}-%{app_ver}/include/*.hrl
%changelog