1
0
python-oci-sdk/python-oci-sdk.spec
John Paul Adrian Glaubitz 564e0ba97a - Update to version 2.145.0
* Support for Customer Onboarding Success(COS) in the Java Management service
  * Support for filtering performance tuning analysis results in the Java Management service
  * Support for improved plugin filtering in the Java Management service
  * Support for operating system distribution information in the Java Management service
  * Fixed an issue in RPv2.1 to read private key from a file
  * put_object failures for 412 status code have been fixed. This might be a breaking change
    for customers who have defined a custom exception handler for 412 status code (#622)
- from version 2.144.1
  * Support for backups and recovery enhancements in autonomous databases in the Database service
  * Support for IPv6 addresses on system launch in the Database service
  * Support for enterprise edition GPU infrastructure in the Stack Monitoring service
  * Support for monitoring templates in the Stack Monitoring service
  * Support for IPv6 cluster creation in the Kubernetes Engine service
  * Support for automatic and spoken punctuations in realtime in the AI Speech service
  * Support for additional connection types for Databricks, Google PubSub and Microsoft
    Fabric in the GoldenGate service
- from version 2.144.0
  * Support for Cohere Embed v3 in the Generative AI Inference service
  * Support for Llama 3.2 tools in the Generative AI Inference service
  * Support for nginx discovery and monitoring in the Stack Monitoring service
  * Support for Oracle JVM runtime discovery and monitoring in the Stack Monitoring service
  * Support for JBoss discovery and monitoring in the Stack Monitoring service
  * Support for Service Managed Container(SMC) endpoints on list service operation
    in the Data Science service
  * Support for schedulers in the Data Science service
  * Support for DB system database and access modes in the HeatWave service
  * Support for DB system read endpoints in the HeatWave service
  * Support for sensitive types for data discovery in the Data Safe service
  * Support for referential relation APIs in the Data Safe service
  * The models `CreateAuditPolicyDetails` and `CreateAuditProfileDetails`
    were removed in the Data Safe service
- from version 2.143.1
  * Support for external MySQL database management in the Database Management service
  * Support for fetching highly available metrics for managed databases in the Database
    Management service
  * Support for Exadata Infrastructure on Exadata Cloud@Customer in the Database service
  * Support for disaster recovery for cloud native applications running on OKE clusters
    in the Disaster Recovery service
  * Support for subscription assignment at creation of the child tenancies in the
    Organizations service
  * Support for additional actionable insights content-types for news reports in
    the Operations Insights service
  * Support for MySQL Heatwave database systems in the Operations Insights service
- from version 2.143.0
  * Support for Bring Your Own ASN (BYOASN) in the Networking service
  * Support for Data Guard transaction processing in the Database service
  * Support for permanently disconnecting peer autonomous databases from
    its primary database in the Database service
  * Support for databases with external Hardware
  * Security Module (HSM) in the Database service
    * Support for active and standby purist modes in the Network Load Balancer service
    * Support for configurable TCP reset in the Network Load Balancer service
  * Fixed 413 error for put operation of very large object in object storage service
- from version 2.142.0
  * Support for attaching route tables to VNICs and private IPs in the Networking service
  * Support for Cross Cluster Search(CCS) for an opensearch cluster in the OpenSearch service
  * Support for patch-level updates of the autonomous databases after provisioning
    in the Database service
  * put_object failures for 412 status code have been fixed. This might be a breaking change
    for customers who have defined a custom exception handler for 412 status code (#622)
- from version 2.141.1
  * Fixed Github Issue (#728) for RPv1.1
- from version 2.141.0
  * Support for backup retention locks on autonomous database create and update
    operations in the Database service
  * Support for multi-modality flags in data source in the Generative AI service
  * Support for knowledge base statistics in the Generative AI service
  * Support for document id, title and page numbers in citations in the Generative AI service
  * Support for creating and updating Amazon Web Services (AWS) asset-sources,
    EC2 and Elastic Block Store (EBS) assets in the Cloud Bridge service
  * Support for listing Amazon Web Services (AWS) regions available for discovery
    and migrations in the Cloud Bridge service
  * Support for stored video analysis in the AI Vision service
  * Support for HTTP or REST endpoint-based metric extensions in the OCI Monitoring service
  * Support for metric extension filter in the list metric extensions
    operation in the OCI Monitoring service
  * Support for creating and updating private endpoints for model deployments
    in the Data Science service
  * Support for OCI Identity user integration in the Big Data service
  * Support for user principal session tokens in the Big Data service
  * Support for historical cluster versions in the Big Data service
  * Support for new SKUs for digital assets editions in the Blockchain Platform service
  * Support for Zero ETL pipelines in the GoldenGate service
  * Removed fallback to the deprecated Instance Metadata service (IMDS) V1 endpoint
  * `INSTANCE_METADATA_URL_CERTIFICATE_RETRIEVER_RETRY_STRATEGY` was modified to do 8
    retry attempts and exponential backoff with Jitter between attempts, instead of 3
    fixed interval retries
  * Parameter `compartment_id` in operation `list_metric_extensions` was removed from
    the `StackMonitoringClient` in the OCI Monitoring service
- from version 2.140.0
  * Support for Bring Your Own Key (BYOK) in the Database service
  * Support for refreshing disaster recovery plans in the Disaster Recovery service
  * Support for private access to service instances in the Visual Builder service
  * Support for exadata fleet update and rollback maintenance cycle in the Fleet
    Application Management service
  * Support for Bring Your Own License (BYOL) for windows virtual machines in the
    Compute service
  * Support for cascading deletion of applications and runs in the Data Flow service
  * Support for on-demand translation and auto language detection during file translation
    in the AI Language service
  * Support for alias for endpoints in custom model flow and custom anonymization in the
    AI Language service
  * Models `IdcsInfoDetails` and `AttachmentDetails` were removed from the Visual Builder service
  * Parameters `idcs_info` and `attachments` were removed from the model `VbInstance`
    in the Visual Builder service
2025-02-21 12:21:13 +01:00

110 lines
3.7 KiB
RPMSpec

#
# spec file for package python-oci-sdk
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%bcond_without python2
%{?sle15_python_module_pythons}
Name: python-oci-sdk
Version: 2.145.0
Release: 0
Summary: Oracle Cloud Infrastructure Python SDK
License: Apache-2.0 OR UPL-1.0
Group: Development/Languages/Python
URL: https://github.com/oracle/oci-python-sdk
Source: %{url}/archive/v%{version}.tar.gz#/oci-python-sdk-%{version}.tar.gz
Source99: python-oci-sdk.rpmlintrc
Patch0: ops_relax-python-depends.patch
# PATCH-FIX-OPENSUSE pytest-740.patch gh#oracle/oci-python-sdk#566
Patch1: pytest-740.patch
BuildRequires: %{python_module pip}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-certifi
Requires: python-circuitbreaker >= 1.3.1
Requires: python-cryptography >= 3.2.1
Requires: python-pyOpenSSL >= 17.5.0
Requires: python-python-dateutil >= 2.5.3
Requires: python-pytz >= 2016.10
# SECTION devendored packages
Requires: python-PyJWT
Requires: python-httpsig_cffi
Requires: python-requests
Requires: python-six
Requires: python-sseclient
Requires: python-urllib3 < 2
# /SECTION
BuildArch: noarch
# SECTION test requirements
BuildRequires: %{python_module PyJWT}
BuildRequires: %{python_module certifi}
BuildRequires: %{python_module circuitbreaker >= 1.3.1}
BuildRequires: %{python_module cryptography >= 3.2.1}
BuildRequires: %{python_module httpsig_cffi}
BuildRequires: %{python_module pyOpenSSL >= 17.5.0}
BuildRequires: %{python_module pytest > 4.1.0}
BuildRequires: %{python_module python-dateutil >= 2.5.3}
BuildRequires: %{python_module pytz >= 2016.10}
BuildRequires: %{python_module requests}
BuildRequires: %{python_module six}
BuildRequires: %{python_module sseclient}
BuildRequires: %{python_module urllib3 < 2}
BuildRequires: %{python_module vcrpy >= 2.0.1}
%if %{with python2}
BuildRequires: python-configparser >= 4.0.2
%endif
# /SECTION
%ifpython2
Requires: python-configparser >= 4.0.2
%endif
# The PyPI name is just oci
Provides: python-oci = %{version}-%{release}
%python_subpackages
%description
Python SDK for Oracle Cloud Infrastructure. Python 2.7+ and 3.5+ are supported.
%prep
%autosetup -p1 -n oci-python-sdk-%{version}
# Remove vendored packages
rm -rf src/oci/_vendor/
# Fix includes
find . -name "*.py" -exec sed -i 's/from oci._vendor //' \{\} +
sed -i 's/from \._vendor //' src/oci/*.py
sed -i 's/ oci._vendor.jwt as//' src/oci/auth/*.py
sed -i 's/oci\._vendor\.//' src/oci/*.py src/oci/auth/*.py src/oci/auth/signers/*.py src/oci/retry/*.py src/oci/object_storage/transfer/internal/*.py tests/*.py
sed -i 's/from . import vcr_mods//' tests/test_config_container.py
%build
%pyproject_wheel
%check
%pytest tests/unit tests/integ -s -rs
%install
%pyproject_install
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%files %{python_files}
%doc CHANGELOG.rst README.rst
%license LICENSE.txt
%{python_sitelib}/oci
%{python_sitelib}/oci-%{version}*-info
%changelog