wabt/wabt.spec

120 lines
3.7 KiB
RPMSpec

#
# spec file for package wabt
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: wabt
Version: 1.0.36
Release: 0
Summary: WebAssembly Binary Toolkit
License: Apache-2.0
# FIXME: use correct group or remove it, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group: Development/Tools
URL: https://github.com/WebAssembly/wabt
Source0: %{name}-%{version}.tar.xz
Source99: wabt-rpmlintrc
BuildRequires: bison
BuildRequires: cmake
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: python3-devel
%description
A suite of tools for WebAssembly. These tools are intended for use in (or for
development of) toolchains or other systems that want to manipulate WebAssembly
files. Unlike the WebAssembly spec interpreter (which is written to be as
simple, declarative and "speccy" as possible), they are written in C/C++ and
designed for easier integration into other systems. Unlike Binaryen these tools
do not aim to provide an optimization platform or a higher-level compiler
target; instead they aim for full fidelity and compliance with the spec (e.g.
1:1 round-trips with no changes to instructions).
%package devel
Summary: Development packages for %{name}
Group: Development/Libraries/C and C++
%description devel
Development headers from WABT for wasm-rt
%prep
%setup -q
%build
%cmake -DBUILD_TESTS=OFF
%cmake_build
%install
%cmake_install
%files
%license LICENSE
%doc README.md Contributing.md
%{_bindir}/spectest-interp
%{_bindir}/wasm2c
%{_bindir}/wasm2wat
%{_bindir}/wasm-decompile
%{_bindir}/wasm-interp
%{_bindir}/wasm-objdump
%{_bindir}/wasm-stats
%{_bindir}/wasm-strip
%{_bindir}/wasm-validate
%{_bindir}/wast2json
%{_bindir}/wat2wasm
%{_bindir}/wat-desugar
%{_mandir}/man1/spectest-interp.1%{?ext_man}
%{_mandir}/man1/wasm2c.1%{?ext_man}
%{_mandir}/man1/wasm2wat.1%{?ext_man}
%{_mandir}/man1/wasm-decompile.1%{?ext_man}
%{_mandir}/man1/wasm-interp.1%{?ext_man}
%{_mandir}/man1/wasm-objdump.1%{?ext_man}
%{_mandir}/man1/wasm-stats.1%{?ext_man}
%{_mandir}/man1/wasm-strip.1%{?ext_man}
%{_mandir}/man1/wasm-validate.1%{?ext_man}
%{_mandir}/man1/wast2json.1%{?ext_man}
%{_mandir}/man1/wat2wasm.1%{?ext_man}
%{_mandir}/man1/wat-desugar.1%{?ext_man}
%dir %{_datadir}/wabt
%files devel
%{_includedir}/wasm-rt.h
%{_includedir}/wabt/*.h
%{_libdir}/libwasm-rt-impl.a
%{_includedir}/wasm-rt-exceptions.h
%{_includedir}/wabt/feature.def
%{_includedir}/wabt/interp/binary-reader-interp.h
%{_includedir}/wabt/interp/interp-inl.h
%{_includedir}/wabt/interp/interp-math.h
%{_includedir}/wabt/interp/interp-util.h
%{_includedir}/wabt/interp/interp-wasi.h
%{_includedir}/wabt/interp/interp.h
%{_includedir}/wabt/interp/istream.h
%{_includedir}/wabt/opcode.def
%{_includedir}/wabt/token.def
%{_libdir}/cmake/wabt/wabt-config-version.cmake
%{_libdir}/cmake/wabt/wabt-config.cmake
%{_libdir}/cmake/wabt/wabt-targets-relwithdebinfo.cmake
%{_libdir}/cmake/wabt/wabt-targets.cmake
%{_libdir}/libwabt.a
%dir %{_includedir}/wabt
%dir %{_includedir}/wabt/interp
%dir %{_libdir}/cmake/wabt
%{_datadir}/wabt/wasm2c/*
%dir %{_datadir}/wabt/wasm2c
%changelog