wasm3/wasm3.spec

53 lines
1.5 KiB
RPMSpec

#
# spec file for package wasm3
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: wasm3
Version: 0.5.0
Release: 0
Summary: A high performance WebAssembly interpreter written in C
License: MIT
Group: Development/Languages/Other
URL: https://github.com/wasm3/wasm3
Source: https://github.com/wasm3/wasm3/archive/v%{version}/%{name}-%{version}.tar.gz
BuildRequires: cmake >= 3.11
BuildRequires: gcc-c++
%description
A high performance WebAssembly interpreter written in C
- 8x faster than other known wasm interpreters
- 4-5x slower than state of the art wasm JIT engines
- 12x slower than native execution
%prep
%setup -q
%build
# Tries to download source file and build libuvwasi. For now simple argument needed.
%cmake -DBUILD_WASI=simple
%cmake_build
%install
install -Dm755 build/wasm3 %{buildroot}%{_bindir}/wasm3
%files
%license LICENSE
%doc README.md
%{_bindir}/wasm3
%changelog