1
0
forked from pool/libtracefs
libtracefs/libtracefs.spec
Jan Engelhardt 19fc3df9c5 Accepting request 1093516 from home:jones_tony:trace-cmd
- Add explicit thread dependency for older versions of meson (i.e SLE-15-SP5)
  New patch: add-explicit-meson-thread-dependency.patch

- Update to version 1.7.0
  * Add initial support for meson
  * Add tracefs_kprobe_destroy() to index man page
  * State that tracefs_dynevent_create() is needed for tracefs_kprobe_alloc()
  * Add missing prototypes in top level man page
  * Add tracefs_kprobe_destory() API
  * Add helper function to destroy dynamic event
  * Add tracefs_time_conversion() API
  * Add tracefs_find_cid_pid() API
  * Fix crashing of synth test when synths exist
  * Do not use synth for test_synth element
  * Clarify the tracefs_synth_create() man page
  * Do not allow tracefs_synth_set_instance() on created synth
  * Documentation for tracefs_synth_set_instance
  * New API to set synthetic event instance
  * Do not segfault in tests if synthetic events are not configured
  * Add tracefs_instance_tracers() API
  * Do not use hwlat tracer and fdb_delete event for test
  * Add stacktrace to tracefs_sql()
  * Unit test for tracefs_instance_reset()
  * Documentation for tracefs_instance_reset()	
  * New API to reset ftrace instance 
- Drop patch 0001-libtracefs-Add-initial-support-for-meson.patch (upstream)

OBS-URL: https://build.opensuse.org/request/show/1093516
OBS-URL: https://build.opensuse.org/package/show/devel:libraries:c_c++/libtracefs?expand=0&rev=31
2023-06-17 11:52:46 +00:00

104 lines
2.7 KiB
RPMSpec

#
# spec file for package libtracefs
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: libtracefs
%define lname libtracefs1
Version: 1.7.0
Release: 0
Summary: Linux kernel trace file system library
License: LGPL-2.1-only
Group: Development/Libraries/C and C++
URL: https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/
Source: https://git.kernel.org/pub/scm/libs/libtrace/libtracefs.git/snapshot/%name-%version.tar.gz
BuildRequires: asciidoc
BuildRequires: bison
BuildRequires: fdupes
BuildRequires: flex
BuildRequires: meson
BuildRequires: pkg-config
BuildRequires: source-highlight
BuildRequires: xmlto
BuildRequires: xz
BuildRequires: pkgconfig(libtraceevent) >= 1.3
Patch1: add-explicit-meson-thread-dependency.patch
%description
This library provides C APIs to access the kernel trace file system.
%package -n %lname
Summary: Linux kernel trace file system library
Group: System/Libraries
%description -n %lname
This library provides C APIs to access the kernel trace file system.
%package tools
Summary: Tools for libtracefs
Group: Development/Libraries/C and C++
Requires: %lname = %version
%description tools
This library provides C APIs to access the kernel trace file system.
This subpackage contains tools.
%package devel
Summary: Development files for libtracefs
Group: Development/Libraries/C and C++
Requires: %lname = %version
%description devel
This library provides C APIs to access the kernel trace file system.
This subpackage contains the header files.
%prep
%autosetup -p1
%build
%meson \
--default-library=shared \
-Dhtmldir="%_docdir/%name"
%meson_build
%meson_build docs
%install
%meson_install
%fdupes %buildroot/%_prefix
%post -n %lname -p /sbin/ldconfig
%postun -n %lname -p /sbin/ldconfig
%files -n %lname
%_libdir/libtracefs.so.1*
%license LICENSES/LGPL-2.1
%files tools
%_bindir/sqlhist
%_mandir/man1/*
%files devel
%_includedir/*
%_libdir/libtracefs.so
%_libdir/pkgconfig/*.pc
%_mandir/man3/*
%_docdir/%name/
%changelog