12
0
lua-resty-mysql/lua-resty-mysql.spec
Matej Cepl 395a1955ec Accepting request 1171863 from home:13ilya
Even after creating the perl-Test-Nginx package, the tests still don't run.
You can run the pm file from the t directory as I did before, but it doesn't run the tests, it just does NOT return errors at the end of initialization.

The make file specifies the following

OPENRESTY_PREFIX=/usr/local/openresty
....
test: all
	PATH=$(OPENRESTY_PREFIX)/nginx/sbin:$$PATH prove -I../test-nginx/lib -r t

That is, I can NOT even override OPENRESTY_PREFIX, which is hardcoded and I have no idea where to get the test-nginx directory from.

Apparently these tests are for internal testing only.
If upstream writes how to run the tests properly, I'll add them, but it's better not to run them at all than to create the appearance of testing!

In any case, tests for noarch with empty %build section are not necessary.
I test them in a real environment with nginx-module-lua and I have lua-resty libraries working.

OBS-URL: https://build.opensuse.org/request/show/1171863
OBS-URL: https://build.opensuse.org/package/show/devel:languages:lua/lua-resty-mysql?expand=0&rev=1
2024-05-10 15:32:21 +00:00

48 lines
1.4 KiB
RPMSpec

#
# spec file for package lua-resty-mysql
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lua_version 5.1
Name: lua-resty-mysql
Version: 0.27
Release: 0
Summary: Lua MySQL client driver for ngx_lua based on the cosocket API
License: BSD-2-Clause
URL: https://github.com/openresty/lua-resty-mysql
Source0: https://github.com/openresty/%{name}/archive/refs/tags/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: lua-macros
BuildArch: noarch
%description
This Lua library is a MySQL client driver for the ngx_lua nginx module.
%prep
%autosetup -p1
%build
%install
%make_install LUA_LIB_DIR=%{lua_noarchdir}
%files
%defattr(0644,root,root,-)
%doc README.markdown
%dir %{lua_noarchdir}
%{lua_noarchdir}/resty
%changelog