Update changelog

This commit is contained in:
Matej Cepl 2022-09-14 12:09:19 +02:00
parent 071988ced8
commit 1d4f878c27
Signed by: mcepl
GPG Key ID: 79205802880BC9D8
2 changed files with 8 additions and 36 deletions

View File

@ -1,36 +0,0 @@
---
CMakeLists.txt | 2 +-
src/nvim/ex_cmds.lua | 2 +-
src/nvim/generators/gen_ex_cmds.lua | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -547,7 +547,7 @@ endforeach()
# Find Lua interpreter
include(LuaHelpers)
-set(LUA_DEPENDENCIES lpeg mpack bit)
+set(LUA_DEPENDENCIES lpeg mpack bit32)
if(NOT LUA_PRG)
foreach(CURRENT_LUA_PRG luajit lua5.1 lua5.2 lua)
unset(_CHECK_LUA_PRG CACHE)
--- a/src/nvim/ex_cmds.lua
+++ b/src/nvim/ex_cmds.lua
@@ -1,4 +1,4 @@
-local bit = require 'bit'
+local bit = require 'bit32'
local module = {}
--- a/src/nvim/generators/gen_ex_cmds.lua
+++ b/src/nvim/generators/gen_ex_cmds.lua
@@ -22,7 +22,7 @@ local defsfname = autodir .. '/ex_cmds_d
local enumfile = io.open(enumfname, 'w')
local defsfile = io.open(defsfname, 'w')
-local bit = require 'bit'
+local bit = require 'bit32'
local ex_cmds = require('ex_cmds')
local defs = ex_cmds.cmds
local flags = ex_cmds.flags

View File

@ -1,3 +1,11 @@
-------------------------------------------------------------------
Wed Sep 14 10:07:44 UTC 2022 - Matej Cepl <mcepl@suse.com>
- Convert to git driven build (https://gitea.opensuse.org/mcepl/neovim-master-pkg.git).
- Remove unnecessary patches (added to the build branch)
- 20131-hunspell.patch
- neovim-0.1.7-bitop.patch
------------------------------------------------------------------- -------------------------------------------------------------------
Sun Sep 11 20:15:46 UTC 2022 - mcepl@cepl.eu Sun Sep 11 20:15:46 UTC 2022 - mcepl@cepl.eu