Before git conversion

This commit is contained in:
Matej Cepl 2022-09-14 10:19:13 +02:00
commit 29e8b1da32
Signed by: mcepl
GPG Key ID: 79205802880BC9D8
14 changed files with 15986 additions and 0 deletions

5
.gitignore vendored Normal file
View File

@ -0,0 +1,5 @@
.osc
build.specials.obscpio
series
*.obscpio
neovim/

5165
20131-hunspell.patch Normal file

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,39 @@
From 59f4bd435c6754f475dfb61bb6c881ce914b17e6 Mon Sep 17 00:00:00 2001
From: James McCoy <jamessan@jamessan.com>
Date: Wed, 29 Nov 2017 10:07:12 -0500
Subject: [PATCH] unittest: Ignore _Float128 types in ffi
When building with certain GCC versions, a _Float128 type is present
when setting up the ffi for unit tests.
./test/unit/helpers.lua:256: declaration specifier expected near '_Float128' at line 396
/usr/bin/luajit: /usr/share/lua/5.1/busted/runner.lua:99: attempt to concatenate local 'message' (a table value)
stack traceback:
/usr/share/lua/5.1/busted/runner.lua:99: in function 'fn'
/usr/share/lua/5.1/mediator.lua:103: in function 'publish'
/usr/share/lua/5.1/busted/modules/helper_loader.lua:21: in function 'helperLoader'
/usr/share/lua/5.1/busted/runner.lua:147: in function </usr/share/lua/5.1/busted/runner.lua:11>
/usr/bin/busted:3: in main chunk
[C]: at 0x004044a0
CMake Error at /<<PKGBUILDDIR>>/cmake/RunTests.cmake:53 (message):
Running unit tests failed with error: 1.
Since this is being pulled in by a dependency, not directly used by
nvim, just ignore the type.
Closes #7423
---
test/unit/helpers.lua | 1 +
1 file changed, 1 insertion(+)
--- a/test/unit/helpers.lua
+++ b/test/unit/helpers.lua
@@ -136,6 +136,7 @@ local function filter_complex_blocks(bod
if not (string.find(line, "(^)", 1, true) ~= nil
or string.find(line, "_ISwupper", 1, true)
or string.find(line, "_Float")
+ or string.find(line, "_Float128")
or string.find(line, "msgpack_zone_push_finalizer")
or string.find(line, "msgpack_unpacker_reserve_buffer")
or string.find(line, "UUID_NULL") -- static const uuid_t UUID_NULL = {...}

16
_service Normal file
View File

@ -0,0 +1,16 @@
<services>
<service name="obs_scm">
<param name="versionprefix">0.8.0~git</param>
<param name="url">https://github.com/neovim/neovim</param>
<param name="scm">git</param>
<param name="exclude">.git*</param>
<param name="changesgenerate">enable</param>
<param name="changesauthor">mcepl@cepl.eu</param>
</service>
<service mode="buildtime" name="tar" />
<service name="recompress" mode="buildtime">
<param name="compression">xz</param>
<param name="file">*.tar</param>
</service>
<service name="set_version" mode="buildtime"/>
</services>

6
_servicedata Normal file
View File

@ -0,0 +1,6 @@
<servicedata>
<service name="tar_scm">
<param name="url">https://github.com/neovim/neovim</param>
<param name="changesrevision">f98cff9575e75a050d2bde01ad950c0c72bcfc3e</param>
</service>
</servicedata>

4
lj-busted.sh Executable file
View File

@ -0,0 +1,4 @@
#!/bin/sh
set -xeu
/usr/bin/luajit /usr/bin/busted "$@"

36
neovim-0.1.7-bitop.patch Normal file
View File

@ -0,0 +1,36 @@
---
CMakeLists.txt | 2 +-
src/nvim/ex_cmds.lua | 2 +-
src/nvim/generators/gen_ex_cmds.lua | 2 +-
3 files changed, 3 insertions(+), 3 deletions(-)
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -547,7 +547,7 @@ endforeach()
# Find Lua interpreter
include(LuaHelpers)
-set(LUA_DEPENDENCIES lpeg mpack bit)
+set(LUA_DEPENDENCIES lpeg mpack bit32)
if(NOT LUA_PRG)
foreach(CURRENT_LUA_PRG luajit lua5.1 lua5.2 lua)
unset(_CHECK_LUA_PRG CACHE)
--- a/src/nvim/ex_cmds.lua
+++ b/src/nvim/ex_cmds.lua
@@ -1,4 +1,4 @@
-local bit = require 'bit'
+local bit = require 'bit32'
local module = {}
--- a/src/nvim/generators/gen_ex_cmds.lua
+++ b/src/nvim/generators/gen_ex_cmds.lua
@@ -22,7 +22,7 @@ local defsfname = autodir .. '/ex_cmds_d
local enumfile = io.open(enumfname, 'w')
local defsfile = io.open(defsfname, 'w')
-local bit = require 'bit'
+local bit = require 'bit32'
local ex_cmds = require('ex_cmds')
local defs = ex_cmds.cmds
local flags = ex_cmds.flags

0
neovim-rpmlintrc Normal file
View File

10335
neovim.changes Normal file

File diff suppressed because it is too large Load Diff

4
neovim.obsinfo Normal file
View File

@ -0,0 +1,4 @@
name: neovim
version: 0.8.0~git.1662905274.f98cff957
mtime: 1662905274
commit: f98cff9575e75a050d2bde01ad950c0c72bcfc3e

279
neovim.spec Normal file
View File

@ -0,0 +1,279 @@
#
# spec file for package neovim
#
# Copyright (c) 2021 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python3_pkgversion:%define python3_pkgversion 3}
%if 0%{?rhel}
%define __cmake cmake3
BuildRequires: cmake3
%else
BuildRequires: cmake
%endif
%if 0%{?rhel} || 0%{?fedora}
%define vimplugin_dir %{_datadir}/vim/vimfiles
%else
%define vimplugin_dir %{_datadir}/vim/site
%endif
%if 0%{?fedora}
%define lua_archdir %{lua_libdir}
%define lua_noarchdir %{lua_pkgdir}
%define lua_incdir %{_includedir}/lua-%{lua_version}
BuildRequires: libnsl2-devel
Requires: python3-neovim
%bcond_with luajit
%endif
# Luajit not available on all platforms
%ifarch %{arm} %{ix86} x86_64 aarch64
%bcond_without luajit
%else
%bcond_with luajit
%endif
Name: neovim
Version: 0.8.0~git.1662905274.f98cff957
Release: 0
Summary: Vim-fork focused on extensibility and agility
License: Apache-2.0 AND Vim
Group: Productivity/Text/Editors
URL: https://neovim.io/
Source0: %{name}-%{version}.tar.xz
Source1: sysinit.vim
Source2: spec-template
Source3: suse-spec-template
# Our packaged busted script has a shebang pointing to regular Lua interepreter,
# we need /usr/bin/luajit. Fake it.
Source10: lj-busted.sh
Source99: neovim-rpmlintrc
# PATCH-FIX-OPENSUSE neovim-0.1.7-bitop.patch mcepl@cepl.eu build with old Lua with external bit module
Patch1: neovim-0.1.7-bitop.patch
# PATCH-FIX-UPSTREAM 7657-run-tests-aarch64.patch gh#neovim/neovim#7423 mcepl@suse.com
# fix running tests on aarch64
Patch3: 7423-run-tests-aarch64.patch
# PATCH-FEATURE-UPSTREAM 20131-hunspell.patch gh#vim/vim#4916 mcepl@suse.com
# use hunspell as the spellchecking backend
Patch4: 20131-hunspell.patch
BuildRequires: desktop-file-utils
BuildRequires: fdupes
BuildRequires: filesystem
BuildRequires: gcc-c++
BuildRequires: gettext
BuildRequires: git-core
BuildRequires: gperf
BuildRequires: hicolor-icon-theme
BuildRequires: libtermkey-devel
BuildRequires: libtool
BuildRequires: libuv-devel
BuildRequires: libvterm-devel >= 0.1
BuildRequires: make
%if 0%{?suse_version} > 1550
BuildRequires: msgpack-c-devel
%else
BuildRequires: msgpack-devel
%endif
BuildRequires: pkgconfig
BuildRequires: python-rpm-macros
BuildRequires: tree-sitter-devel >= 0.20.2
BuildRequires: unibilium-devel
BuildRequires: unzip
BuildRequires: utf8proc-devel
## TESTING PATCH 4
BuildRequires: hunspell-devel
Requires: gperf
Requires: libvterm0 >= 0.1
Requires: xdg-utils
%if 0%{?suse_version}
Recommends: wl-clipboard
Recommends: xclip
Recommends: xsel
%endif
%if 0%{?suse_version}
BuildRequires: libnsl-devel
BuildRequires: lua-macros
BuildRequires: lua51-LPeg
BuildRequires: lua51-bit32
BuildRequires: lua51-luarocks
BuildRequires: lua51-luv
BuildRequires: libluv-devel
BuildRequires: lua51-mpack
%if %{with luajit}
BuildRequires: luajit-devel
%else
BuildRequires: lua51-devel
%endif
Requires: lua51-bit32
Requires: lua51-luv
Recommends: python3-neovim
%if 0%{?suse_version} < 1330
Requires(post): gtk3-tools
Requires(postun): gtk3-tools
%endif
%endif
%if 0%{?suse_version} > 1500
# # Modern *SUSE … tests are enabled
# For tests
BuildRequires: lua51-busted
BuildRequires: hostname
# end of test requirements
%endif
%if 0%{?rhel} || 0%{?fedora}
BuildRequires: lua-bit32
BuildRequires: lua-devel
BuildRequires: lua-lpeg
BuildRequires: lua-luv-devel
BuildRequires: lua-mpack
BuildRequires: luarocks
BuildRequires: python2-six
Requires: lua-luv
%endif
%if 0%{?rhel}
BuildRequires: lua-bit32
BuildRequires: lua-macros
BuildRequires: luajit-devel
Requires: lua-bit32
Requires: python34-neovim
%endif
%description
Neovim is a refactor - and sometimes redactor - in the tradition of
Vim, which itself derives from Stevie. It is not a rewrite, but a
continuation and extension of Vim. Many rewrites, clones, emulators
and imitators exist; some are very clever, but none are Vim. Neovim
strives to be a superset of Vim, notwithstanding some intentionally
removed misfeatures; excepting those few and carefully-considered
excisions, Neovim is Vim. It is built for users who want the good
parts of Vim, without compromise, and more.
%lang_package
%define vimplugin_dir %{_datadir}/vim/site
%prep
%autosetup -p1
install -p -m 0755 %{SOURCE10} .
# # Remove __DATE__ and __TIME__.
# BUILD_TIME=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{H}:%{M}')
# BUILD_DATE=$(LC_ALL=C date -ur %{_sourcedir}/%{name}.changes +'%{b} %{d} %{Y}')
# sed -i "s/__TIME__/\"$BUILD_TIME\"/" $(grep -rl '__TIME__')
# sed -i "s/__DATE__/\"$BUILD_DATE\"/" $(grep -rl '__DATE__')
%build
# set vars to make build reproducible in spite of config/CMakeLists.txt
HOSTNAME=OBS
USERNAME=OBS
mkdir -p build
pushd build
export CFLAGS="%{optflags} -fcommon"
export CXXFLAGS="%{optflags} -fcommon"
%{__cmake} .. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DPREFER_LUA=%{?with_luajit:OFF}%{!?with_luajit:ON} \
-DLUA_PRG=%{_bindir}/%{?with_luajit:luajit}%{!?with_luajit:lua} \
-DBUSTED_PRG="$(readlink -f ../lj-busted.sh)" \
-DUSE_BUNDLED=OFF -DLUAJIT_USE_BUNDLED=ON \
-DCMAKE_SKIP_RPATH=ON -DCMAKE_VERBOSE_MAKEFILE=ON \
-DCMAKE_COLOR_MAKEFILE=OFF \
-DCMAKE_C_FLAGS_RELWITHDEBINFO="$opts" \
-DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
-DLIBLUV_INCLUDE_DIR:PATH=%{lua_incdir} \
# -DLIBLUV_LIBRARY=%{lua_archdir}/luv.so
%make_build
popd
%install
%{?!cmake_install:%define cmake_install DESTDIR=%{buildroot} make install -C build}
%cmake_install
# system-wide configuration file
install -D -m 644 -p %{SOURCE1} %{buildroot}%{_sysconfdir}/nvim/sysinit.vim
ln -sf %{_sysconfdir}/nvim/sysinit.vim %{buildroot}%{_datadir}/nvim/sysinit.vim
%if 0%{?suse_version}
install -p -m 644 %{SOURCE3} %{buildroot}%{_datadir}/nvim/template.spec
%else
install -p -m 644 %{SOURCE2} %{buildroot}%{_datadir}/nvim/template.spec
%endif
desktop-file-install --dir=%{buildroot}%{_datadir}/applications \
runtime/nvim.desktop
install -d -m0755 %{buildroot}%{_datadir}/pixmaps
install -m0644 runtime/nvim.png %{buildroot}%{_datadir}/pixmaps/nvim.png
# Fix exec bits
find %{buildroot}%{_datadir} \( -name \*.bat -o -name \*.awk \) \
-print -exec chmod -x '{}' \;
# vim/site directories for plugins shared with vim
mkdir -p %{buildroot}%{vimplugin_dir}/{after,after/syntax,autoload,colors,doc,ftdetect,plugin,syntax}
%fdupes %{buildroot}%{_datadir}/
%find_lang nvim
# We have to have rpath
# https://en.opensuse.org/openSUSE:Packaging_checks
export NO_BRP_CHECK_RPATH=true
%check
# Tests fail on aarch64 gh#neovim/neovim#18176
%ifnarch aarch64
# set vars to make build reproducible in spite of config/CMakeLists.txt
HOSTNAME=OBS
USERNAME=OBS
pushd build
%make_build BUSTED_PRG=$(readlink -f ../lj-busted.sh) unittest
popd
%endif
%if 0%{?suse_version} && 0%{?suse_version} < 1330
%post
%desktop_database_post
%icon_theme_cache_post
%endif
%if 0%{?suse_version} && 0%{?suse_version} < 1330
%postun
%desktop_database_postun
%icon_theme_cache_postun
%endif
%files -f nvim.lang
%doc BACKERS.md CONTRIBUTING.md README.md
%docdir %{_mandir}
%license LICENSE.txt
%{_bindir}/nvim
%{_mandir}/man*/nvim.*
%dir %{_datadir}/nvim
%{_datadir}/nvim/sysinit.vim
%{_datadir}/nvim/template.spec
%{_datadir}/nvim/runtime/
%{_datadir}/applications/*
%{_datadir}/pixmaps/*
%{_datadir}/icons/*
%dir %{_sysconfdir}/nvim
%config(noreplace) %{_sysconfdir}/nvim/sysinit.vim
%dir %{_datadir}/vim
%dir %{vimplugin_dir}
%dir %{vimplugin_dir}/after
%dir %{vimplugin_dir}/after/*
%dir %{vimplugin_dir}/autoload
%dir %{vimplugin_dir}/colors
%dir %{vimplugin_dir}/doc
%dir %{vimplugin_dir}/ftdetect
%dir %{vimplugin_dir}/plugin
%dir %{vimplugin_dir}/syntax
%changelog

37
spec-template Normal file
View File

@ -0,0 +1,37 @@
Name:
Version:
Release: 1%{?dist}
Summary:
License:
URL:
Source0:
BuildRequires:
Requires:
%description
%prep
%autosetup
%build
%configure
%make_build
%install
%make_install
%check
%files
%license
%doc
%changelog

50
suse-spec-template Normal file
View File

@ -0,0 +1,50 @@
#
# spec file for package specRPM_CREATION_NAME
#
# Copyright (c) specCURRENT_YEAR SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: specRPM_CREATION_NAME
Version:
Release: 0
Summary:
# FIXME: Select a correct license from https://github.com/openSUSE/spec-cleaner#spdx-licenses
License:
# FIXME: use correct group, see "https://en.opensuse.org/openSUSE:Package_group_guidelines"
Group:
Url:
Source:
BuildRequires:
%description
%prep
%setup -q
%build
%configure
%make_build
%install
%make_install
%post
%postun
%files
%license COPYING
%doc ChangeLog README
%changelog

10
sysinit.vim Normal file
View File

@ -0,0 +1,10 @@
" In order for neovim to use installed plugins shared with vim
set runtimepath+=/usr/share/vim/site
augroup Fedora
autocmd!
" RPM spec file template
autocmd BufNewFile *.spec silent! 0read /usr/share/nvim/template.spec
augroup END
" vim: et ts=2 sw=2