Convert to git driven repository.

This commit is contained in:
Matej Cepl 2022-09-14 10:25:55 +02:00
parent 29e8b1da32
commit 7b3af2a2e1
Signed by: mcepl
GPG Key ID: 79205802880BC9D8
6 changed files with 5 additions and 5237 deletions

File diff suppressed because it is too large Load Diff

View File

@ -1,39 +0,0 @@
From 59f4bd435c6754f475dfb61bb6c881ce914b17e6 Mon Sep 17 00:00:00 2001
From: James McCoy <jamessan@jamessan.com>
Date: Wed, 29 Nov 2017 10:07:12 -0500
Subject: [PATCH] unittest: Ignore _Float128 types in ffi
When building with certain GCC versions, a _Float128 type is present
when setting up the ffi for unit tests.
./test/unit/helpers.lua:256: declaration specifier expected near '_Float128' at line 396
/usr/bin/luajit: /usr/share/lua/5.1/busted/runner.lua:99: attempt to concatenate local 'message' (a table value)
stack traceback:
/usr/share/lua/5.1/busted/runner.lua:99: in function 'fn'
/usr/share/lua/5.1/mediator.lua:103: in function 'publish'
/usr/share/lua/5.1/busted/modules/helper_loader.lua:21: in function 'helperLoader'
/usr/share/lua/5.1/busted/runner.lua:147: in function </usr/share/lua/5.1/busted/runner.lua:11>
/usr/bin/busted:3: in main chunk
[C]: at 0x004044a0
CMake Error at /<<PKGBUILDDIR>>/cmake/RunTests.cmake:53 (message):
Running unit tests failed with error: 1.
Since this is being pulled in by a dependency, not directly used by
nvim, just ignore the type.
Closes #7423
---
test/unit/helpers.lua | 1 +
1 file changed, 1 insertion(+)
--- a/test/unit/helpers.lua
+++ b/test/unit/helpers.lua
@@ -136,6 +136,7 @@ local function filter_complex_blocks(bod
if not (string.find(line, "(^)", 1, true) ~= nil
or string.find(line, "_ISwupper", 1, true)
or string.find(line, "_Float")
+ or string.find(line, "_Float128")
or string.find(line, "msgpack_zone_push_finalizer")
or string.find(line, "msgpack_unpacker_reserve_buffer")
or string.find(line, "UUID_NULL") -- static const uuid_t UUID_NULL = {...}

View File

@ -1,16 +0,0 @@
<services>
<service name="obs_scm">
<param name="versionprefix">0.8.0~git</param>
<param name="url">https://github.com/neovim/neovim</param>
<param name="scm">git</param>
<param name="exclude">.git*</param>
<param name="changesgenerate">enable</param>
<param name="changesauthor">mcepl@cepl.eu</param>
</service>
<service mode="buildtime" name="tar" />
<service name="recompress" mode="buildtime">
<param name="compression">xz</param>
<param name="file">*.tar</param>
</service>
<service name="set_version" mode="buildtime"/>
</services>

View File

@ -1,6 +0,0 @@
<servicedata>
<service name="tar_scm">
<param name="url">https://github.com/neovim/neovim</param>
<param name="changesrevision">f98cff9575e75a050d2bde01ad950c0c72bcfc3e</param>
</service>
</servicedata>

View File

@ -1,4 +0,0 @@
name: neovim
version: 0.8.0~git.1662905274.f98cff957
mtime: 1662905274
commit: f98cff9575e75a050d2bde01ad950c0c72bcfc3e

View File

@ -48,7 +48,7 @@ Summary: Vim-fork focused on extensibility and agility
License: Apache-2.0 AND Vim
Group: Productivity/Text/Editors
URL: https://neovim.io/
Source0: %{name}-%{version}.tar.xz
#!RemoteAssetUrl: git+https://github.com/mcepl/neovim.git#devel
Source1: sysinit.vim
Source2: spec-template
Source3: suse-spec-template
@ -56,11 +56,6 @@ Source3: suse-spec-template
# we need /usr/bin/luajit. Fake it.
Source10: lj-busted.sh
Source99: neovim-rpmlintrc
# PATCH-FIX-OPENSUSE neovim-0.1.7-bitop.patch mcepl@cepl.eu build with old Lua with external bit module
Patch1: neovim-0.1.7-bitop.patch
# PATCH-FIX-UPSTREAM 7657-run-tests-aarch64.patch gh#neovim/neovim#7423 mcepl@suse.com
# fix running tests on aarch64
Patch3: 7423-run-tests-aarch64.patch
# PATCH-FEATURE-UPSTREAM 20131-hunspell.patch gh#vim/vim#4916 mcepl@suse.com
# use hunspell as the spellchecking backend
Patch4: 20131-hunspell.patch
@ -160,7 +155,10 @@ parts of Vim, without compromise, and more.
%define vimplugin_dir %{_datadir}/vim/site
%prep
%autosetup -p1
%setup -q -n neovim -c -T
( cd %{_sourcedir}/neovim && git checkout -f devel )
cp -a %{_sourcedir}/neovim/* .
install -p -m 0755 %{SOURCE10} .