diff --git a/neovim.changes b/neovim.changes index e0c6cdb..c7d262c 100644 --- a/neovim.changes +++ b/neovim.changes @@ -1,3 +1,237 @@ +------------------------------------------------------------------- +Thu Jul 20 09:24:25 UTC 2023 - Matej Cepl + +- Upgrade to 0.9.1+git.1689836628.63b340855: + - feat(lsp): implement textDocument/diagnostic + - docs(lua): clarify fs.find() documentation #24394 + - feat(decoration_provider): log errors as error messages + - feat(lsp): handle multiple clients in omnifunc + - test(startup_spec): add a test for #18315 + - docs(lua): more improvements + - build(scripts): allow a git ref for lsp_types #24377 + - refactor(lua2dox): overhaul + - fix(fs.lua): normalize slash truncation + - Merge pull request #24363 from lewis6991/docs/luatypes + - feat(lsp)!: rename vim.lsp.get_active_clients to get_clients + - fix: doc errors + - fix: luacheck + - refactor(gen_vimdoc): put defgroup handling in a function + - docs(lua): change *lua-foo* -> *vim.foo* + - docs(lua): move function docs to lua files + - fix(terminal): don't send unknown special keys to terminal + - feat(options)!: remove compatible behaviours for vim 5.0 and + earlier + - docs: handle whitespace in emmycomments + - docs(lua): do not render self args + - refactor: rename _meta.lua to _options.lua + - test(fs): vim.loop was renamed to vim.uv + - fix(inccommand): block errors when parsing command line again + - test(fs): get tmpdir robustly #23021 + - fix(clipboard): ignore exit caused by signal #23378 + - docs(term.txt): reorder paragraphs about TUI input + - fix(lsp): markdown code fence should allow space before info + string #24364 + - feat(api)!: change return type of nvim_win_text_height to + Dict + - feat(tui): support Super and Meta modifiers + - feat(lsp): map K to hover by default #24331 + - build(makefile): remove a phony target uninstall + - fix(lsp): remove unknown LSP protocol property + - fix(runtime): respect 'fileignorecase' when sourcing + - fix(runtime): respect 'rtp' order for all runtime files + - docs(lua): adds links to related keymap functions to + keymap.set + - perf(rtp): reduce rtp scans + - build(deps): bump luajit to HEAD - 8635cbabf + - fix(ui): cursor pos with left gravity inline virt_text at eol + - test(extmarks): add test for virt_text_win_col with cpo+=n + - feat(lsp): add method filter to get_active_clients + - perf(extmarks): don't handle inline virt_text if there is + none + - fix(mouse): copy the line before syntax matching + - fix(tutor): don't use concealed text in expected lines #24316 + - fix(drawline): fix missing Visual hl on double-width fold + char + - perf(extmarks): avoid unnecessary marktree traversal with + folds + - feat(api): add nvim_win_text_height + - vim-patch:9.0.1673: cannot produce a status 418 or 503 + message + - fix(lint): lint warnings #24226 + - fix(completion): don't add backslashes to runtime pattern + - fix(defaults): visual star (*) on text with "?" + - fix(docs): match DocSearch style with site theme + - fix(defaults): visual hash (#) on text with "?" + - Merge #24295 from justinmk/doc2 + - docs: gather @notes items into one section + - docs: "Return (multiple)" heading + - docs: MAINTAIN.md, nvim_get_mark + - test(tui): add test for overriding argv[0] + - fix(lsp): don't use hl_mode = combine for inlay hints #24276 + - fix(extmarks): fix wrong highlight after "combine" virt_text + - fix(startup): run embedded Nvim with real path + - feat(lua): allow vim.wo to be double indexed + - docs: CONTRIBUTING.md updates + - fix(treesitter): update folds in all relevant windows + - fix(folds): fix missing virt_lines above when fold is hidden + - fix(drawline): inline virt_text hl_mode inside syntax/extmark + hl + - Merge #21677 fix(defaults): visual star (*,#) is fragile + - refactor(defaults): use vim.region for visual star (*,#) + - fix(defaults): visual mode star (*,#) is fragile + - docs(luaref): remove parentheses from tags for typedefs + - fix(vim.system): close check handle + - fix(column): fix wrong cursor with 'statuscolumn' and cpo+=n + - refactor(plines.c): update outdated comments + - fix(ui): delay win_viewport until screen update #24182 + - Merge pull request #23228 from seandewar/cmdwin-jail + - fix(runtime): don't set gx mapping if already mapped + - fix(plines): don't return very large height on very long line + - fix(api): disallow some more functions during textlock + - fix(api): use text_locked() to check textlock + - Merge #23401 vim.ui.open: "gx" without netrw + - fix(edit): fix K_EVENT interfering with 'digraph' + - fix(vim.ui.open): return (don't show) error message + - fix(gx): visual selection, expand env vars + - feat(vim.ui): vim.ui.open, "gx" without netrw + - fix(api): allow negative column arguments for + nvim_buf_set_text + - fix(lsp): revert change to buf.clear_references() #24238 + - feat(l10n): update Turkish translations #24246 + - perf(ui-ext): approximate scroll_delta when scrolling too + much + - fix(ui-ext): "scroll_delta" handle topfill and skipcol + - fix(api, lua): make blank lines in a message work properly + - fix(plines): handle inline virtual text after last char + - docs(gen_help_html): accept "~/" in file/dir params #24240 + - Merge pull request #23167 from dundargoc/refactor/long + - refactor: remove long + - Merge pull request #23891 from rickyz/grid_line_flags + - perf(treesitter): cache fold query + - build(deps): bump luv to 1.45.0-0 + - build(nix): fix markdown parser #24225 + - test: check for ASAN properly + - vim-patch:9.0.1672: tabline highlight wrong after truncated + double width label + - fix(startup)!: "nvim -l" message does not end with newline + #24215 + - Merge pull request #24219 from clason/ts-hoon + - fix(api): nvim_parse_cmd error message in pcall() #23297 + - feat(version): unverbose ":version", ":verbose version" + #24195 + - fix(lsp): lint warnings, default offset_encoding #24046 + - feat(treesitter): add bash parser and queries + - feat(treesitter): add python parser and queries + - feat(treesitter): bundle markdown parser and queries + - build(deps): bump libuv to v1.46.0 + - fix(startup): don't truncate when printing with -l + - refactor: fix clang/PVS warnings + - fix(lsp): fix attempt to call non existent function + - Merge pull request #24147 from clason/fix/ftplugin + - feat(lsp): move inlay_hint() to vim.lsp + - test(lua/runtime_spec): add test for ftplugin ordering + - docs(luaref): fix tags for constants + - fix(statusline): fill for double-width char after moving + items + - feat(defaults): set g:netrw_use_errorwindow = 0 #24179 + - fix(lsp): inlay_hint nil reference error #24202 + - refactor: remove some casts to char * + - fix(column): handle unprintable chars in 'statuscolumn' + - test(statusline): add test with control characters + - vim-patch:9.0.1671: Termdebug: error with more than 99 + breakpoints + - fix(column): use maxwidth to allocate/fill 'statuscolumn' + click defs #24190 + - fix(api): nvim_cmd{cmd="win_getid"} parsed as :winsize #24181 + - vim-patch:9.0.1670: resetting local option to global value is + inconsistent + - fix(treesitter): handle empty region when logging + - fix(treesitter): make foldexpr work without highlighting + - fix(docs): ignore_invalid #24174 + - docs(diagnostic): return value of get() #24144 + - vim-patch:9.0.1668: PEM files are not recognized + - Merge pull request #24170 from zeertzjq/vim-9.0.1664 + - vim-patch:9.0.1667: regression test doesn't fail when fix is + reverted + - vim-patch:9.0.1664: divide by zero when scrolling with + 'smoothscroll' set + - vim-patch:9.0.1632: not all cabal config files are recognized + - Merge #24153 from justinmk/doc + - fix(startup): "nvim -l foo.lua" may not set arg0 #24161 + - fix(docs): vimdoc syntax errors + - build(deps): tree-sitter-vimdoc v2.0.1 + - docs: fix misparsed headings + - fix(treesitter): update lua parser and queries + - fix(charset): fix wrong display of 0xffff + - Merge pull request #24154 from zeertzjq/vim-9.0.1665 + - vim-patch:9.0.1665: empty CmdlineEnter autocommand causes + errors in Ex mode + - vim-patch:8.2.3833: error from term_start() not caught by + try/catch + - fix(docs): too much whitespace around
 blocks #24151
+  - Merge #24116 from justinmk/doc
+  - docs: autocmds, misc
+  - fix(docs): vimdoc syntax errors
+  - fix(ftplugin): respect runtimepath ordering
+  - vim-patch:9.0.1663: Termdebug on MS-Windows: some file names
+    are not recognized
+  - vim-patch:9.0.1661: BUCK files are not recognized
+  - test(extmarks): add a test for #23848
+  - vim-patch:9.0.1659: Termdebug: default highlight cleared if
+    changing colorscheme
+  - Merge pull request #24082 from smjonas/fix_24064
+  - fix(extmarks): fix heap buffer overflow caused by inline
+    virtual text
+  - fix(lsp): error in reset_timer on second detach #24117
+  - ci: introduce CI_LINT option
+  - fix(filetype): correctly detect bash-fc-{id} files as "sh"
+  - vim-patch:9.0.1644: not all filetype file name matches are
+    tested
+  - build(luarc.json): disable luadoc-miss-see-name #24108
+  - fix(lsp): reapplying already-applied hints #24114
+  - fix(cmdline): don't redraw 'tabline' in Ex mode
+  - feat(lsp): opt-in to dynamicRegistration for inlay hints
+  - vim-patch:9.0.1645: zserio files are not recognized
+  - feat(extmarks): support hl_mode "combine" for inline
+    virt_text
+  - feat(lsp): soft deprecate vim.lsp.for_each_buffer_client
+  - fix(messages): use "Vimscript" instead of "VimL" #24111
+  - test: spellcheck :help (vimdoc) files #24109
+  - fix(extmarks): hide inline virt_text properly with
+    'smoothscroll'
+  - fix(extmarks): empty inline virt_text interfering with
+    DiffText
+  - Merge #24087 from justinmk/doc
+  - perf(lsp): remove grouping logic from lsp.status
+  - feat(gen_help_html): ignore pi_netrw.txt errors
+  - feat(gen_help_html): non-default vimdoc.so parser
+  - fix(docs): vimdoc syntax errors
+  - docs: lsp, vim_diff
+  - Merge pull request #24098 from zeertzjq/fix-extmark
+  - fix: tostring(vim.version()) fails if build is NIL #24097
+  - fix(api): wrong nvim_buf_set_extmark error for invalid
+    hl_mode
+  - fix(extmarks): empty inline virt_text interfering with Visual
+    highlight
+  - feat(man): respect 'wrapmargin' when wrapping man pages
+  - Merge #24086 LSP ctx.version, report full Nvim version
+  - docs(lsp): mention ctx.version
+  - fix(folds): don't show search or match highlighting on fold
+  - refactor(lsp): report full Nvim version string in clientInfo
+  - fix(vim.json)!: remove global options, "null", "array_mt"
+    #24070
+  - fix(lsp): add spacing for inlay hints separately #24079
+  - fix(lsp): define LspInlayHint highlight group #24073
+  - fix(lsp): always return boolean in lsp.buf_client_attach
+  - Merge pull request #24069 from famiu/refactor/options/varp
+  - fix(lsp): check if inlay hints are enabled for a buffer
+    before disabling
+  - refactor(lsp): extract common execute command functionality
+  - refactor(option): use `void *` for pointer to option value
+  - docs(lsp): LspInlayHint highlight group #24071
+  - fix(lsp): duplicate on_detach, on_reload callbacks #24067
+  - fix(ui): propagate line wrapping state on grid_line events
+
 -------------------------------------------------------------------
 Fri Apr  7 12:06:17 UTC 2023 - Matej Cepl 
 
diff --git a/neovim.spec b/neovim.spec
index 3a87a27..891623d 100644
--- a/neovim.spec
+++ b/neovim.spec
@@ -45,7 +45,7 @@ Requires:       python3-neovim
 %bcond_with luajit
 %endif
 Name:           neovim
-Version:        0.9.1+git.1687241214.ca5de9306
+Version:        0.9.1+git.1689836628.63b340855
 Release:        0
 Summary:        Vim-fork focused on extensibility and agility
 License:        Apache-2.0 AND Vim