9e33504496
* New Features/Enhancements - In-game movies now play for users using TH Data directly from a .ISO file - Custom campaign creators can now optionally use the original level advance movie when progressing through the campaign - The Map Editor has received some love including new features, fixes, and jukebox controls - Long windows now behave properly in the game if they get intersected by an adjacent wall - You can now control the Jukebox from the Main Menu by going to Options > Jukebox - External (non-TH) XMI files are now supported by the Jukebox - The adviser now tells you the cost of replacing your machine if you cannot currently afford it - More cheats! - [Experimental] Right mouse panning can now be used instead of using the middle mouse button. Enable it in the configuration file - [Experimental] We’re closer to fully implementing falling actions! Get a sneak peek and get the chance to push people over by enabling it in the configuration file/debug menu * Changes - The demo movie will no longer play and cause jumpscares at the main menu if the CorsixTH window is not in focus - Game speeds are now more closely aligned with the original game - Improvements to handling of win/lose conditions, and the progress report - Staff tiredness levels are now taken from the level config file based on difficulty level of the main campaign - You can no longer win a level if you still have outstanding loans - Emergencies will now be announced once patients actually begin arriving instead of at the start - Errors with music playback will now attempt to provide more helpful information in the console - Level briefings now show before the in-game tutorial - The first patient of a level will now arrive faster after opening the hospital - The information dialog box is now more closely aligned with the original game - The tip of the day window should no longer be obscured in the main menu - The load/save windows now have better labelling - Unavailable languages are shown as disabled until you select a Unicode font - Support is added to auto-detect a Theme Hospital install via GOG Galaxy * Translations - Ukranian translation added. - Dutch, Italian, Russian, Spanish, French and Brazilian-Portuguese translation has been updated. - Some unused language strings have been cleaned up - Custom campaign and level creators can now optionally add translated strings for campaign description, level briefing, and winning text * Bug Fixes - Swing (double) doors will no longer crash your game if you built rooms that used them while paused - Fixed a bug for NVIDIA users who didn’t like graphical corruption when playing fullscreen at non-native resolutions - Games should no longer crash irrecoverably because you have a 4k monitor - The game will now exit to the main menu cleanly if a problem occurred trying to load a new level or map - Staff who have left the hospital can no longer ask for a raise - Fixed a bug where some staff may have no initial before surname - Patients can no longer litter outdoors - Patients waiting for a player decision no longer lose their mood icon on vomit/pee - Fixed a bug where an unreachable reception desk could cause a crash - The Computer and Atom Analyser now make button sounds as originally intended - The mark for vaccination action now makes a sound as originally intended - Fixed a rare bug where edges of map tiles for parcels could cause unintended behaviour when purchasing plots - Active cheats will now persist across saves - Audio settings have better safeguards against no audio enabled/no background music - Movies will no longer attempt to play audio when global audio is off - Config values using brackets (such as a custom music directory) will now work properly - Custom campaigns menu now will use a scrollbar for long campaign descriptions - Continue Game now properly targets files explicitly ending in the .sav format - Tooltips for language menu now align with list items. Please note we are aware of an issue where some languages don't show a tooltip - Fixed an instance where information boxes could load pink from older savegames - Implemented a more permanent fix for the money bar being drawn incorrectly in some CJK and Cyrllic languages - Fixed a crash on exit that could occur in some systems - Mouse panning behaviour has been made more responsive and accurate * Packager Notes - Minimum CMake version is now bumped to 3.14 - CMake presets are now available for some common build scenarios - Dependencies can now be obtained automatically using vcpkg on Linux and MacOS. - If update checks are enabled you now require libcurl at build and run time (update checks can be disabled using the WITH_UPDATE_CHECK CMake option). - Luasec and luasocket are no longer used OBS-URL: https://build.opensuse.org/package/show/games/CorsixTH?expand=0&rev=36
80 lines
2.6 KiB
RPMSpec
80 lines
2.6 KiB
RPMSpec
#
|
|
# spec file for package CorsixTH
|
|
#
|
|
# Copyright (c) 2024 SUSE LLC
|
|
#
|
|
# All modifications and additions to the file contributed by third parties
|
|
# remain the property of their copyright owners, unless otherwise agreed
|
|
# upon. The license for this file, and modifications and additions to the
|
|
# file, is the same license as for the pristine package itself (unless the
|
|
# license for the pristine package is not an Open Source License, in which
|
|
# case the license is the MIT License). An "Open Source License" is a
|
|
# license that conforms to the Open Source Definition (Version 1.9)
|
|
# published by the Open Source Initiative.
|
|
|
|
# Please submit bugfixes or comments via https://bugs.opensuse.org/
|
|
#
|
|
|
|
|
|
Name: CorsixTH
|
|
Version: 0.68.0
|
|
Release: 0
|
|
Summary: Theme Hospital clone
|
|
License: MIT
|
|
Group: Amusements/Games/Strategy/Other
|
|
URL: http://corsixth.com
|
|
Source: https://github.com/CorsixTH/CorsixTH/archive/v%{version}/%{name}-%{version}.tar.gz
|
|
BuildRequires: cmake
|
|
BuildRequires: fdupes
|
|
BuildRequires: gcc-c++
|
|
BuildRequires: hicolor-icon-theme
|
|
BuildRequires: pkgconfig
|
|
BuildRequires: update-desktop-files
|
|
BuildRequires: wxWidgets-devel
|
|
BuildRequires: pkgconfig(SDL2_mixer)
|
|
BuildRequires: pkgconfig(freetype2)
|
|
BuildRequires: pkgconfig(libavcodec)
|
|
BuildRequires: pkgconfig(libavdevice)
|
|
BuildRequires: pkgconfig(libavformat)
|
|
BuildRequires: pkgconfig(libavutil)
|
|
BuildRequires: pkgconfig(libpostproc)
|
|
BuildRequires: pkgconfig(libswresample)
|
|
BuildRequires: pkgconfig(libswscale)
|
|
BuildRequires: pkgconfig(lua)
|
|
BuildRequires: pkgconfig(sdl2)
|
|
Requires: lua-lpeg
|
|
Requires: lua-luafilesystem
|
|
Recommends: timidity
|
|
|
|
%description
|
|
This project aims to reimplement the game engine of Theme Hospital, and be
|
|
able to load the original game data files. This means that you will need a
|
|
purchased copy of Theme Hospital, or a copy of the demo, in order to use
|
|
CorsixTH. After most of the original engine has been reimplemented in open
|
|
source code, the project will serve as a base from which extensions and
|
|
improvements to the original game can be made.
|
|
|
|
%prep
|
|
%setup -q
|
|
|
|
%build
|
|
%cmake -DWITH_UPDATE_CHECK=OFF
|
|
%cmake_build
|
|
|
|
%install
|
|
%cmake_install
|
|
rm -f %{buildroot}/%{_datadir}/corsix-{th,TH}/LICENSE.txt
|
|
%fdupes %{buildroot}/%{_datadir}
|
|
|
|
%files
|
|
%license LICENSE.txt
|
|
%doc README.txt
|
|
%{_bindir}/corsix-th
|
|
%{_datadir}/corsix-th
|
|
%{_datadir}/icons/hicolor/scalable/apps/corsix-th.svg
|
|
%{_datadir}/metainfo/com.corsixth.corsixth.metainfo.xml
|
|
%{_datadir}/applications/com.corsixth.corsixth.desktop
|
|
%{_mandir}/man6/corsix-th.6%{?ext_man}
|
|
|
|
%changelog
|