e59310eeda
* $bsu_specfiles may come from subdirs * GNUmakefile: .built target asks for $(.DEFAULT_GOAL) * drop (erroneous) group from PKGBUILD.in - Use pretty url OBS-URL: https://build.opensuse.org/package/show/devel:tools:scm/bs-update?expand=0&rev=5
33 lines
538 B
Bash
33 lines
538 B
Bash
# Maintainer: Roman Neuhauser <roman+bs-update@sigpipe.cz>
|
|
pkgname=bs-update
|
|
pkgver=0.18
|
|
pkgrel=1
|
|
epoch=
|
|
pkgdesc="Automate maintenance of packages in a Build Service"
|
|
arch=(any)
|
|
url="http://github.com/roman-neuhauser/bs-update"
|
|
license=(MIT)
|
|
groups=(lib)
|
|
depends=(gzip osc sed tar wget zsh)
|
|
makedepends=(zsh)
|
|
checkdepends=()
|
|
source=($pkgname-$pkgver.tar.gz)
|
|
sha256sums=(SKIP)
|
|
|
|
build() {
|
|
_make
|
|
}
|
|
|
|
check() {
|
|
_make check
|
|
}
|
|
|
|
package() {
|
|
_make install DESTDIR="$pkgdir" PREFIX=/usr
|
|
}
|
|
|
|
_make() {
|
|
cd "$srcdir/$pkgname-$pkgver"
|
|
make "$@"
|
|
}
|