calindori/calindori.spec

92 lines
3.1 KiB
RPMSpec

#
# spec file for package calindori
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define kf6_version 6.6.0
%define qt6_version 6.6.0
%bcond_without released
Name: calindori
Version: 24.12.3
Release: 0
Summary: Kirigami-based calendar application
License: GPL-3.0-or-later
URL: https://apps.kde.org/calindori
Source0: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz
%if %{with released}
Source1: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz.sig
Source2: applications.keyring
%endif
BuildRequires: kf6-extra-cmake-modules >= %{kf6_version}
BuildRequires: cmake(KF6CalendarCore) >= %{kf6_version}
BuildRequires: cmake(KF6Config) >= %{kf6_version}
BuildRequires: cmake(KF6CoreAddons) >= %{kf6_version}
BuildRequires: cmake(KF6DBusAddons) >= %{kf6_version}
BuildRequires: cmake(KF6I18n) >= %{kf6_version}
BuildRequires: cmake(KF6Kirigami) >= %{kf6_version}
BuildRequires: cmake(KF6Notifications) >= %{kf6_version}
BuildRequires: cmake(KF6People) >= %{kf6_version}
BuildRequires: cmake(Qt6Core) >= %{qt6_version}
BuildRequires: cmake(Qt6DBus) >= %{qt6_version}
BuildRequires: cmake(Qt6Gui) >= %{qt6_version}
BuildRequires: cmake(Qt6Network) >= %{qt6_version}
BuildRequires: cmake(Qt6Qml) >= %{qt6_version}
BuildRequires: cmake(Qt6Quick) >= %{qt6_version}
BuildRequires: cmake(Qt6QuickControls2) >= %{qt6_version}
BuildRequires: cmake(Qt6Svg) >= %{qt6_version}
Requires: kf6-kirigami-imports >= %{kf6_version}
Requires: kf6-kpeople-imports >= %{kf6_version}
Requires: kirigami-addons6
Requires: qt6-declarative-imports >= %{qt6_version}
%description
Calindori is a touch friendly calendar application.
It has been designed for mobile devices but it can also run on desktop environments.
Users of Calindori are able to check previous and future dates and manage tasks and events.
%lang_package
%prep
%autosetup -p1
%build
%cmake_kf6 -DBUILD_WITH_QT6:BOOL=TRUE
%kf6_build
%install
%kf6_install
%find_lang %{name} --all-name
%files
%doc README.md
%license LICENSES/*
%{_datadir}/dbus-1/services/org.kde.calindac.service
%{_kf6_applicationsdir}/org.kde.calindori.desktop
%{_kf6_appstreamdir}/org.kde.calindori.appdata.xml
%{_kf6_bindir}/calindac
%{_kf6_bindir}/calindori
%{_kf6_configdir}/autostart/org.kde.calindac.desktop
%{_kf6_iconsdir}/hicolor/scalable/apps/calindori.svg
%{_kf6_notificationsdir}/calindac.notifyrc
%files lang -f %{name}.lang
%changelog