cflow/cflow.spec
Martin Pluskal 33a0ebf1f6 Accepting request 943855 from home:dirkmueller:Factory
- update to 1.7:
  * Multiple start functions are allowed
  * New option --target=FUNCTION
  * New output format: dot
  The '-f dot' (or '--format=dot') option instructs cflow to output
  graph as a description in DOT language, suitable as input to graphviz
  programs.
  * Bugfixes:
  ** CVE-2019-16165
  ** CVE-2019-16166
  ** Fix parsing of K&R style function declarations
  ** Improve parsing of typecasts
  ** Fix recursive call detection

OBS-URL: https://build.opensuse.org/request/show/943855
OBS-URL: https://build.opensuse.org/package/show/devel:tools/cflow?expand=0&rev=11
2022-01-05 10:59:42 +00:00

69 lines
2.0 KiB
RPMSpec

#
# spec file for package cflow
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: cflow
Version: 1.7
Release: 0
Summary: Tool to generate flowcharts for C sources
License: GPL-3.0-or-later
Group: Development/Tools/Other
URL: https://www.gnu.org/software/cflow
Source0: https://ftp.gnu.org/gnu/cflow/cflow-%{version}.tar.xz
Source1: https://ftp.gnu.org/gnu/cflow/cflow-%{version}.tar.xz.sig
Source2: %{name}.keyring
BuildRequires: flex
Requires(post): %{install_info_prereq}
Requires(preun):%{install_info_prereq}
%description
GNU cflow analyzes a collection of C source files and prints a graph, charting
control flow within the program. GNU cflow is able to produce both direct and
inverted flowgraphs for C sources. Optionally a cross-reference listing can be
generated. Two output formats are implemented: POSIX and GNU (extended). Input
files can optionally be preprocessed before analyzing.
%prep
%setup -q
%build
%configure \
--disable-silent-rules
%make_build
%check
%make_build check
%install
%make_install
%find_lang %{name}
%post
%install_info --info-dir=%{_infodir} %{_infodir}/%{name}.info%{ext_info}
%preun
%install_info_delete --info-dir=%{_infodir} %{_infodir}/%{name}.info%{ext_info}
%files -f %{name}.lang
%license COPYING
%doc NEWS README AUTHORS
%{_bindir}/%{name}
%{_infodir}/%{name}.info%{?ext_info}
%{_mandir}/man1/%{name}.1%{?ext_man}
%changelog