cmake/cmake-gui.spec
Martin Pluskal 44863da994 Accepting request 531765 from home:riafarov:branches:devel:tools:building
- Update to version 3.9.4:
  * No changes specific to CMake-GUI

- update to 3.9.4:
  * FindBoost: Finish reverting "Simplify search in lists" for 3.9
- includes changes from 3.9.3:
  * VS: Do not consider MAP_IMPORTED_CONFIG_ on non-imported targets
  bootstrap: Fix running multiple times in-source
  * vim: Remove default setting of expandtab
  * FindBoost: Add support for Boost 1.65.0 and 1.65.1 to CMake 3.9
  * CTest: fix crash if source file for coverage cannot be found
  * Autogen: Backport autogen target dependency as file dependency fix
  * Autogen: Tests: Backport tests for _autogen target dependencies

old: devel:tools:building/cmake
new: home:riafarov:branches:devel:tools:building/cmake rev None
Index: cmake-gui.changes
===================================================================
--- cmake-gui.changes (revision 299)
+++ cmake-gui.changes (revision 2)
@@ -1,4 +1,10 @@
 -------------------------------------------------------------------
+Thu Oct  5 14:13:19 UTC 2017 - riafarov@suse.com
+
+- Update to version 3.9.4:
+  * No changes specific to CMake-GUI
+
+-------------------------------------------------------------------
 Sun Sep 10 09:07:13 UTC 2017 - astieger@suse.com

 - gmake-gui 3.9.2
@@ -437,7 +443,7 @@

 - Update to 3.2.3
       Makefile: Workaround mingw32-make trailing backslash trouble (#15546)
-      Makefile: Fix compilation after parent commit was backported
+      Makefile: Fix compilation after parent commit was backported
       InstallRequiredSystemLibraries: Update for VS 2015 (#15552)
       Fix assertion failure on unmatched foreach in function (#15572)
       ctest_build: Fix regression in GNU make error message matching
@@ -599,7 +605,7 @@
        "gcov" results for submission to CDash.
    * CPack:
      * The "CPackRPM" module learned options to set per-component
-       descriptions and summaries. See the
+       descriptions and summaries. See the
        "CPACK_RPM_<component>_PACKAGE_DESCRIPTION" and
        "CPACK_RPM_<component>_PACKAGE_SUMMARY" variables.
      * The "CPackRPM" module learned options to specify requirements
Index: cmake-gui.spec
===================================================================
--- cmake-gui.spec (revision 299)
+++ cmake-gui.spec (revision 2)
@@ -18,7 +18,7 @@

 %define shortversion 3.9
 Name:           cmake-gui
-Version:        3.9.2
+Version:        3.9.4
 Release:        0
 Summary:        CMake graphical user interface
 License:        BSD-3-Clause
Index: cmake.changes
===================================================================
--- cmake.changes (revision 299)
+++ cmake.changes (revision 2)
@@ -1,4 +1,18 @@
 -------------------------------------------------------------------
+Thu Oct  5 14:10:07 UTC 2017 - riafarov@suse.com
+
+- update to 3.9.4:
+  * FindBoost: Finish reverting "Simplify search in lists" for 3.9
+- includes changes from 3.9.3:
+  * VS: Do not consider MAP_IMPORTED_CONFIG_ on non-imported targets
+  bootstrap: Fix running multiple times in-source
+  * vim: Remove default setting of expandtab
+  * FindBoost: Add support for Boost 1.65.0 and 1.65.1 to CMake 3.9
+  * CTest: fix crash if source file for coverage cannot be found
+  * Autogen: Backport autogen target dependency as file dependency fix
+  * Autogen: Tests: Backport tests for _autogen target dependencies
+
+-------------------------------------------------------------------
 Sun Sep 10 09:07:13 UTC 2017 - astieger@suse.com

 - cmake 3.9.2:
@@ -130,7 +144,7 @@

 - update to CMake 3.7.1
   * FindBISON: Do not rebuild every time when not VERBOSE
-  * libarchive: Add headers to adapt between OpenSSL 1.1 and
+  * libarchive: Add headers to adapt between OpenSSL 1.1 and
     older versions
   * libarchive: Add support for building with OpenSSL 1.1
   * server-mode: Prevent possible crash when watching directories
@@ -413,7 +427,7 @@
 -------------------------------------------------------------------
 Fri Nov 13 09:24:08 UTC 2015 - mpluskal@suse.com

-- Revert removal of CMAKE_INSTALL_LIBDIR declaration from the
+- Revert removal of CMAKE_INSTALL_LIBDIR declaration from the
   macros.

 -------------------------------------------------------------------
@@ -456,7 +470,7 @@
 -------------------------------------------------------------------
 Fri Aug 28 20:48:10 UTC 2015 - tittiatcoke@gmail.com

-- Resolve the error when cmake_minimum_required() is not set
+- Resolve the error when cmake_minimum_required() is not set
    * cmake-3.3.1-FindPkgConfig_remove_variable_dereference.patch

 -------------------------------------------------------------------
@@ -680,7 +694,7 @@

 - Update to 3.2.3
       Makefile: Workaround mingw32-make trailing backslash trouble (#15546)
-      Makefile: Fix compilation after parent commit was backported
+      Makefile: Fix compilation after parent commit was backported
       InstallRequiredSystemLibraries: Update for VS 2015 (#15552)
       Fix assertion failure on unmatched foreach in function (#15572)
       ctest_build: Fix regression in GNU make error message matching
@@ -894,7 +908,7 @@
        "gcov" results for submission to CDash.
    * CPack:
      * The "CPackRPM" module learned options to set per-component
-       descriptions and summaries. See the
+       descriptions and summaries. See the
        "CPACK_RPM_<component>_PACKAGE_DESCRIPTION" and
        "CPACK_RPM_<component>_PACKAGE_SUMMARY" variables.
      * The "CPackRPM" module learned options to specify requirements
@@ -1241,7 +1255,7 @@
    * ExternalProject: Avoid infinite loop on file download
      hash mismatch
    * CMP0047: Fix CMAKE_COMPILER_IS_GNU(CC|CXX) in OLD behavior
-   * CMP0022: Fix version documented to support
+   * CMP0022: Fix version documented to support
      LINK_PUBLIC/LINK_PRIVATE
    * cmListFileLexer: Fix lexing of single '[' character (#15092)
    * Fix finding binutils when cross-compiling with Clang
@@ -1269,7 +1283,7 @@
      instead pass wanted flags directly
    * Pass -Wl,--as-needed -Wl,--no-undefined to linker, to avoid
      unneeded libs, and to disallow undefined symbols
-   * Add a %make_jobs macro with verbose argument
+   * Add a %make_jobs macro with verbose argument
    * Simplify %cmake_install invocation

 -------------------------------------------------------------------
@@ -1425,7 +1439,7 @@
 -------------------------------------------------------------------
 Tue Feb 18 00:30:04 UTC 2014 - dvaleev@suse.com

-- Add ppc64le to FindJNI
+- Add ppc64le to FindJNI

 - added patches:
   * cmake-jni-ppc64le.patch
@@ -1463,7 +1477,7 @@
 -------------------------------------------------------------------
 Wed Nov  6 12:42:56 UTC 2013 - boris@steki.net

-- updated cmake.macros to include installation path for cmake modules
+- updated cmake.macros to include installation path for cmake modules

 -------------------------------------------------------------------
 Tue Oct  8 16:35:02 UTC 2013 - hrvoje.senjan@gmail.com
@@ -2723,4 +2737,3 @@
 Wed Feb 15 11:43:31 CET 2006 - dmueller@suse.de

 - Initial package (2.3 CVS snapshot 20060210)
-
Index: cmake.spec
===================================================================
--- cmake.spec (revision 299)
+++ cmake.spec (revision 2)
@@ -18,7 +18,7 @@

 %define shortversion 3.9
 Name:           cmake
-Version:        3.9.2
+Version:        3.9.4
 Release:        0
 Summary:        Cross-platform, open-source make system
 License:        BSD-3-Clause
Index: cmake-3.9.4-SHA-256.txt
===================================================================
--- cmake-3.9.4-SHA-256.txt (added)
+++ cmake-3.9.4-SHA-256.txt (revision 2)
@@ -0,0 +1,11 @@
+3459d09ae268697eb5fa0af268ac5da2b05285a6d860be521c1107805259c978  cmake-3.9.4-Darwin-x86_64.dmg
+4d1356623e4e83c497d44b4601e24e39dd5c6a9594a2b042a9107319254fac0d  cmake-3.9.4-Darwin-x86_64.tar.gz
+51866666b0db1a8b80f2c2942c2d3f7b91e23eca96885495c5aeef77ecd24426  cmake-3.9.4-Linux-x86_64.sh
+6d8573377fc7fca86ed1952b76f62880e2159a3de6508761dd0d619a8e96551b  cmake-3.9.4-Linux-x86_64.tar.gz
+6c7efc84f52f569933ae35a739f850198ee1b2d6464ee58ac325f80ea42a2399  cmake-3.9.4-win32-x86.msi
+8214df1ff51f9a6a1f0e27f9bd18f402b1749c5b645fbf6e401bcb00047171cd  cmake-3.9.4-win32-x86.zip
+1c5c6f32e5ce4b2f202f9c50fd7fc60c9b7bd29ddf375a75bc63d58066090e2a  cmake-3.9.4-win64-x64.msi
+63b74a0685b2dd1c5d76428fd915539db6353dd8804aed5683a533ee1a08196d  cmake-3.9.4-win64-x64.zip
+afc7fbb33c6947781568b76fce81fbdf91c1144b673fa42a273dd823207ce8e0  cmake-3.9.4.tar.Z
+b5d86f12ae0072db520fdbdad67405f799eb728b610ed66043c20a92b4906ca1  cmake-3.9.4.tar.gz
+e19c36de1cabc242e78cbf93782b70904e192c6288db6a3d6606423ff944a674  cmake-3.9.4.zip
Index: cmake-3.9.4-SHA-256.txt.asc
===================================================================
--- cmake-3.9.4-SHA-256.txt.asc (added)
+++ cmake-3.9.4-SHA-256.txt.asc (revision 2)
@@ -0,0 +1,16 @@
+-----BEGIN PGP SIGNATURE-----
+
+iQIzBAABCgAdFiEExsJlMku+vcNQtRPQLSzvEDSSFoQFAlnU29sACgkQLSzvEDSS
+FoTq3A//Q/7A0ZBjXrndXmsjdXLPNLQwAZkZ+rmlwuOFCwc/dpf0n1m/iS9D8SC4
+7li8ykT7+EzOVPcDDrH+t55bDYeASXdlq+ROi+46Cy6xrcamOLNm/c69e11HUdqe
+pKS1VolqR7NDkt0IQxtRyfFgGq6yQ4x+NGCaGa5dOSMB90LRx7PEqL5URNzgPvau
+qmmuujTqVhgb4ayq9vhtRRh9blFGewvpoh5Gk6v8FCIGX7O4B2rh5JL04E0fJ879
+z31XH8oT4RdNmczJ00C7i+aXJNnhAgZDzdCaH8UyKQICOxF3LbzRsC+++XFPyLJQ
+Wy3x9zAGQaDanakFmiZq4QWHA7ZPFVaxbqmMtJp4zeOXOeMeLXtSbfaamS2iD0Sv
+MWXMIpZ6xW9LA8exckmCisdifZtm554CA4Qkj2a3tB+3HsZ+/ykSnHthPYaW6ZXl
+71CH7YbgCV19HzJWVE7kklil2aJRzgXjno1oSYiDOxtWcf8CqapEuEhQ2QXn8ljl
+etIIWOEAAC8DlRZV6TjV8kaaPa11/K9+L/Oa8wEkngGFY/e3TGMurc4sWDqLAa+T
+4IMIk/DvNEO3rxkYgEECC+vZ4SuXrNxG5hXdJaRRdf4HTKLQ/Fce9ZSZmEdL/DFM
+9nUqEIopWZOd2RyqSUlB3qO2OPoisAz24Lb2t+aiPj+DCMDjJo0=
+=t114
+-----END PGP SIGNATURE-----
Index: cmake-3.9.4.tar.gz
===================================================================
Binary file cmake-3.9.4.tar.gz (revision 2) added
Index: cmake-3.9.2-SHA-256.txt
===================================================================
--- cmake-3.9.2-SHA-256.txt (revision 299)
+++ cmake-3.9.2-SHA-256.txt (deleted)
@@ -1,11 +0,0 @@
-25ab549ae0da64ec52a69008f57b91bb5a6cb5ececd64991786cf68928a2ba81  cmake-3.9.2-Darwin-x86_64.dmg
-6caf847878159f8bf050ab4fb6cb5c036729891f60c7a8b7b4320cb0d80d4816  cmake-3.9.2-Darwin-x86_64.tar.gz
-9465779a1ed94ad999347b68f4d37c1b09d844a357d5e83406b72255a3720d9d  cmake-3.9.2-Linux-x86_64.sh
-f4e1e848e21c3fba134fbddd793860ba9a17c35d0aeaa3bd83149a6ec1bf9fbb  cmake-3.9.2-Linux-x86_64.tar.gz
-35caf798c32fe0da1df2ae0b9fa865afa006537ab82fa5389da4d76798881037  cmake-3.9.2-win32-x86.msi
-9fe68d50f065666cb2861f53751390f15c6363c440e86a07677689378bb8329f  cmake-3.9.2-win32-x86.zip
-fdf145b877bea1d1fdac338b582404c48bf371c0b0d001f4c6ec29c018f1caf5  cmake-3.9.2-win64-x64.msi
-0f47e6ae0ca1291103af5e9a01524868f7e6690ebd0b9b6906bee526acfedcbc  cmake-3.9.2-win64-x64.zip
-64deeae37378b2047526d93f7845133296b1e359bb47be56b02ba3baf3dd1a41  cmake-3.9.2.tar.Z
-954a5801a456ee48e76f01107c9a4961677dd0f3e115275bbd18410dc22ba3c1  cmake-3.9.2.tar.gz
-5b3c6ee9c466dc205facfc446836f9e28fa91cda3c43b1825348bd2f1b20f18d  cmake-3.9.2.zip
Index: cmake-3.9.2-SHA-256.txt.asc
===================================================================
--- cmake-3.9.2-SHA-256.txt.asc (revision 299)
+++ cmake-3.9.2-SHA-256.txt.asc (deleted)
@@ -1,16 +0,0 @@
------BEGIN PGP SIGNATURE-----
-
-iQIzBAABCAAdFiEExsJlMku+vcNQtRPQLSzvEDSSFoQFAlmxfdkACgkQLSzvEDSS
-FoRUwQ//RPYGbJaeV84RZTgDJgau97a7mFa3kXFpLiXAuIW8c+TlL641U5v3bE7G
-IqFdds2CzbO3cFKBZeY96eYQXF6WZL35zlUtisew2p3598WGduddt9GfYjT27kDB
-ViVEBsBGeItF2ddp0noXJXU/pabwDSxKncKsqYFCutNa1CLgXmIZakKVsR+dawaF
-qECQBXwM9WH9tLfbMzShlithg5GVY6bTH9QgRrmD4qKA99bU4gFXpAWRh2+8RBeu
-nxIkv2cieOVv7H28e1IQPSYQCpO6AzBnm8AplKMQ8WNe+W64Cw9o7rkh4jQ48Pai
-IDMfy+wkQQFtypvU3R2B04p2jUe1Xrzg+0q8CtDap09y2dNmNUG22TIG4RodHfFn
-9eHqCbSUbkL/pisTj4PhvEePfUAYxVY5U6uVnPt50TBr6Ncd0YbwOv8cIqdFPt/W
-8gXek+8CssrL9yQHAEYkItrunJjbDh3X4bjYLzmi2iqeI5/EXxmwXWTvYiWfT6pO
-Pz4q35GwdgQJRMi5kk3FtTbG35rbWo1gTofWH7gm42eiheK2SRTKhcm9xncvsaVq
-fEM8pDCgcplJ3rt2b7aS/CJSehc7KkdGdkZnRc6AqezveOBBdBAFItUKLWlabrfr
-UHhR9k1qGXjz0zM2yMmrGUsAmpuWFQNX/QdTW5j8whgVOtgQ7y8=
-=gki5
------END PGP SIGNATURE-----
Index: cmake-3.9.2.tar.gz
===================================================================
Binary file cmake-3.9.2.tar.gz (revision 299) deleted

OBS-URL: https://build.opensuse.org/request/show/531765
OBS-URL: https://build.opensuse.org/package/show/devel:tools:building/cmake?expand=0&rev=300
2017-10-05 14:36:30 +00:00

131 lines
4.3 KiB
RPMSpec

#
# spec file for package cmake-gui
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
%define shortversion 3.9
Name: cmake-gui
Version: 3.9.4
Release: 0
Summary: CMake graphical user interface
License: BSD-3-Clause
Group: Development/Tools/Building
Url: http://www.cmake.org/
Source0: http://www.cmake.org/files/v%{shortversion}/cmake-%{version}.tar.gz
Source5: http://www.cmake.org/files/v%{shortversion}/cmake-%{version}-SHA-256.txt
Source6: http://www.cmake.org/files/v%{shortversion}/cmake-%{version}-SHA-256.txt.asc
Source7: cmake.keyring
# PATCH-FIX-UPSTREAM form.patch -- set the correct include path for the ncurses includes
Patch4: form.patch
# PATCH-FIX-UPSTREAM system-libs.patch -- allow choosing between bundled and system jsoncpp & form libs
Patch5: system-libs.patch
BuildRequires: curl-devel
BuildRequires: fdupes
BuildRequires: gcc-c++
BuildRequires: libarchive-devel >= 3.0.2
BuildRequires: libexpat-devel
BuildRequires: openssl-devel
BuildRequires: rhash-devel
# use libuv package for Leap and Tumbleweed
%if (0%{?suse_version} > 1320 || (0%{?suse_version} == 1315 && 0%{?is_opensuse}))
BuildRequires: libuv-devel
%define use_system_uvlib ON
# otherwise use libuv part of CMake tarball
%else
%define use_system_uvlib OFF
%endif
# this is commented as it would create dependancy cycle between jsoncpp and cmake
#if 0%{?suse_version} > 1320
#BuildRequires: pkgconfig(jsoncpp)
#endif
BuildRequires: pkgconfig
BuildRequires: python-sphinx
BuildRequires: update-desktop-files
BuildRequires: zlib-devel
BuildRequires: pkgconfig(Qt5Widgets)
BuildRequires: pkgconfig(bzip2)
BuildRequires: pkgconfig(liblzma)
Requires: cmake
Recommends: cmake-man
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
This is a Graphical User Interface for CMake, a cross-platform,
open-source build system.
%package -n cmake-man
Summary: Cross-platform, open-source make system - manual pages
Group: Development/Tools/Building
%description -n cmake-man
Manual pages for cmake, Cross-platform, open-source make system
%prep
# The publisher doesn't sign the source tarball, but a signatures file containing multiple hashes.
# Verify hashes in that file against source tarball.
echo "`grep cmake-%{version}.tar.gz %{SOURCE5} | grep -Eo '^[0-9a-f]+'` %{SOURCE0}" | sha256sum -c
%setup -q -n cmake-%{version}
%patch4 -p1
%patch5 -p1
%build
export CFLAGS="%{optflags}"
export CXXFLAGS="%{optflags}"
# This is not autotools configure
./configure \
--prefix=%{_prefix} \
--datadir=/share/cmake \
--docdir=/share/doc/packages/cmake \
--mandir=/share/man \
--sphinx-man \
--system-libs \
--no-system-jsoncpp \
--parallel=0%{jobs} \
--verbose \
--qt-gui \
-- \
-DCMAKE_USE_SYSTEM_LIBRARY_LIBUV=%{use_system_uvlib}
make VERBOSE=1 %{?_smp_mflags}
%install
make %{?_smp_mflags} DESTDIR=%{buildroot} install
mkdir -p %{buildroot}%{_libdir}/cmake
%suse_update_desktop_file -r %{name} CMake Development IDE Tools Qt
# delete files that belong to the 'cmake' package
rm -rf %{buildroot}%{_bindir}/{cpack,cmake,ctest}
rm -rf %{buildroot}%{_datadir}/cmake
rm -rf %{buildroot}%{_datadir}/aclocal/cmake.m4
rm -rf %{buildroot}%{_docdir}/cmake
%files
%defattr(-,root,root)
%{_bindir}/cmake-gui
%{_datadir}/applications/%{name}.desktop
%{_datadir}/mime/packages/cmakecache.xml
%dir %{_datadir}/icons/hicolor
%dir %{_datadir}/icons/hicolor/*
%dir %{_datadir}/icons/hicolor/*/*
%{_datadir}/icons/hicolor/128x128/apps/CMakeSetup.png
%{_datadir}/icons/hicolor/32x32/apps/CMakeSetup.png
%files -n cmake-man
%defattr(-,root,root)
%{_mandir}/man7/*
%{_mandir}/man1/*
%changelog