easy-rsa/easy-rsa.spec
Richard Rahl 7d701a48df - update to 3.2.2:
* Remove redundant file: index.txt.attr
  * sign-req: Allow custom X509 Types
  * Add LibreSSL version 4 to supported SSL Libraries
  * Revoke remove private inline
  * Easyrsa disable inline
  * easyrsa-tools.lib: renew SAN, remove excess word 'Address'
  * easyrsa-tls.lib: renew, make sed regex for 'IP Address' greedy
  * Show expire allow zero days
  * easyrsa-tools.lib: New command 'renew ca'
  * Improve CRL expiration details
  * Tools move to easyrsa3
  * vars.example: Remove $EASYRSA_PKI
  * Introduce new command revoke-issued
  * Bugfix renew ca and renew
  * Always use locate_support_files() after secure_session()
  * revoke: Make check for conflicting files less intrusive
  * Forbid a self-signed certificate from being expired/renewed/revoked
  * V321 minor final
  * op-test.sh: Disable download ossl3 and shellcheck binaries
  * Revert: Do not remove index.txt.attr
  * Fold easyrsa-tools.lib into easyrsa

OBS-URL: https://build.opensuse.org/package/show/network:vpn/easy-rsa?expand=0&rev=48
2025-02-01 14:56:35 +00:00

59 lines
2.1 KiB
RPMSpec

#
# spec file for package easy-rsa
#
# Copyright (c) 2025 SUSE LLC
# Copyright (c) 2015 Stefan Jakobs.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define pname EasyRSA
Name: easy-rsa
Version: 3.2.2
Release: 0
Summary: CLI utility to build and manage a PKI CA
License: GPL-2.0-or-later
URL: https://github.com/OpenVPN/easy-rsa
Source: %{url}/releases/download/v%{version}/%{pname}-%{version}.tgz
Source1: %{url}/releases/download/v%{version}/%{pname}-%{version}.tgz.sig
Source2: https://keyserver.ubuntu.com/pks/lookup?op=get&search=0x6f4056821152f03b6b24f2fcf8489f839d7367f3#/%{name}.keyring
Patch100: suse-packaging.patch
BuildArch: noarch
%description
easy-rsa is a CLI utility to build and manage a Public Key Infrastructure
(PKI). Once the Certificate Authority (CA) is created, you can request and sign
certificates, including sub-CAs, and create Certificate Revokation Lists (CRL).
%prep
%autosetup -p1 -n %{pname}-%{version}
%build
%install
install -dm0755 %{buildroot}/%{_sysconfdir}/%{name}/
install -dm0755 %{buildroot}/%{_sysconfdir}/%{name}/x509-types
install -Dm0644 vars.example %{buildroot}/%{_sysconfdir}/%{name}/
install -Dm0644 openssl-easyrsa.cnf %{buildroot}/%{_sysconfdir}/%{name}/
install -Dm0644 x509-types/* %{buildroot}/%{_sysconfdir}/%{name}/x509-types/
install -Dm0755 easyrsa %{buildroot}/%{_bindir}/easyrsa
%files
%doc ChangeLog README.md README.quickstart.md
%doc doc/*
%license COPYING.md gpl-2.0.txt
%{_bindir}/easyrsa
%config(noreplace) %{_sysconfdir}/%{name}
%changelog