element-web/element-web.spec
Dominik Heidler 2ed9d0421c - Version 1.11.90
##  Features
  * Docker: run as non-root (https://github.com/element-hq/element-web/pull/28849). Contributed by @richvdh.
  * Docker: allow configuration of HTTP listen port via env var (https://github.com/element-hq/element-web/pull/28840). Contributed by @richvdh.
  * Update matrix-wysiwyg to consume WASM asset (https://github.com/element-hq/element-web/pull/28838). Contributed by @t3chguy.
  * OIDC settings tweaks (https://github.com/element-hq/element-web/pull/28787). Contributed by @t3chguy.
  * Delabs native OIDC support (https://github.com/element-hq/element-web/pull/28615). Contributed by @t3chguy.
  * Move room header info button to right-most position (https://github.com/element-hq/element-web/pull/28754). Contributed by @t3chguy.
  * Enable key backup by default (https://github.com/element-hq/element-web/pull/28691). Contributed by @dbkr.
  ## 🐛 Bug Fixes
  * Fix building the automations mermaid diagram (https://github.com/element-hq/element-web/pull/28881). Contributed by @dbkr.
  * Playwright: wait for the network listener on the postgres db (https://github.com/element-hq/element-web/pull/28808). Contributed by @dbkr.
Version 1.11.89
  * No changes
  ## 🐛 Bug Fixes
  * Upgrade matrix-sdk-crypto-wasm to 1.11.0 (https://github.com/matrix-org/matrix-js-sdk/pull/4593)
  * Fix url preview display (https://github.com/element-hq/element-web/pull/28766).

OBS-URL: https://build.opensuse.org/package/show/devel:languages:nodejs/element-web?expand=0&rev=92
2025-01-15 14:02:09 +00:00

90 lines
3.0 KiB
RPMSpec

#
# spec file for package element-web
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: element-web
Version: 1.11.90
Release: 0
Summary: A glossy Matrix collaboration client - web files
License: AGPL-3.0-only or GPL-3.0-only
Group: Productivity/Networking/Talk/Clients
URL: https://github.com/vector-im/element-web
Source0: https://github.com/vector-im/element-web/archive/v%{version}.tar.gz#/element-web-%{version}.tar.gz
Source1: npm-packages-offline-cache.tar.gz
Source2: jitsi_external_api.min.js
Source3: prepare.sh
Patch0: fix-webpack-oom.patch
BuildRequires: fdupes
BuildRequires: nodejs-packaging
BuildRequires: yarn
BuildRequires: rust
BuildRequires: cargo
BuildArch: noarch
%description
A glossy Matrix collaboration client - web files
%prep
%autosetup -n element-web-%{version} -a1 -p1
%build
echo 'yarn-offline-mirror "./npm-packages-offline-cache"' > .yarnrc
ls -l ./npm-packages-offline-cache | head
# fix some strange dependency
#cp npm-packages-offline-cache/matrix-analytics-events-0.0.1.tgz \
# npm-packages-offline-cache/@matrix-analytics-events-0.0.1.tgz
#ls -l ./npm-packages-offline-cache/*matrix-analytics-events*
#sed -i -e 's| matrix-analytics-events "github:matrix-org/matrix-analytics-events.git#[^"]*"| matrix-analytics-events "^0.0.1"|' yarn.lock
#sed -i -e 's|"matrix-analytics-events@github:matrix-org/matrix-analytics-events#[^"]*"|matrix-analytics-events@^0.0.1|' yarn.lock
export SENTRYCLI_SKIP_DOWNLOAD=1
yarn install --offline --pure-lockfile
mkdir -p webapp
cp %{SOURCE2} ./webapp/jitsi_external_api.min.js
echo > scripts/build-jitsi.ts
DIST_VERSION=%{version} ./scripts/package.sh
pushd dist || exit 1
tar xf element-%{version}.tar.gz
popd
cp -v LICENSE* dist/element-%{version}/
%install
install -d -m 0755 %{buildroot}%{_datadir}/webapps/element
cp -av dist/element-%{version}/* "%{buildroot}%{_datadir}/webapps/element/"
install -d -m 0755 %{buildroot}%{_sysconfdir}/webapps/element/
install -m 0644 config.sample.json "%{buildroot}%{_sysconfdir}/webapps/element/config.sample.json"
%fdupes %{buildroot}%{_datadir}/webapps/element/
%files
%license LICENSE-AGPL-3.0 LICENSE-GPL-3.0
%dir %{_datadir}/webapps
%{_datadir}/webapps/element
%dir %{_sysconfdir}/webapps
%dir %{_sysconfdir}/webapps/element
%config %{_sysconfdir}/webapps/element/config.sample.json
%changelog