fastfetch/fastfetch.spec
Gordon Leung 842322f772 - Excluded flashfetch binary
- update to 2.33.0
  Changes:
   * Introduce a new CMake flag `-DBUILD_FLASHFETCH=OFF` to disable building flashfetch binaries
     - Package managers are encouraged to enable it.
  Bugfixes:
   * Fix interconnect type detection (gh#fastfetch-cli/fastfetch#1453, PhysicalDisk) 
     - Regression of v2.28
   * Don't report `proot` as terminal (Terminal, Android)
   * Remove a debug output (DiskIO, OpenBSD)
   * Fix media detection for some players (gh#fastfetch-cli/fastfetch#1461, Media) 
     - Regression of v2.32
  Features:
   * Use `$POWERSHELL_VERSION` as PowerShell version if available (Shell) 
     - Fetching Windows PowerShell version can be very slow. Add `$env:POWERSHELL_VERSION = $PSVersionTable.PSVersion.ToString()` in $PROFILE before running fastfetch to improve the performance of Shell module
   * Add support for ubuntu-based armbian detection (gh#fastfetch-cli/fastfetch#1447)
   * Improve performance of Bluetooth detection (Bluetooth) 
     - We no longer report disconnected bluetooth devices in `--format json` when `--bluetooth-show-disconnected` isn't specified
   * Support brightness level detection for builtin displays (Brightness, OpenBSD / NetBSD) 
     - Requires root permission on OpenBSD
   * Support battery level detection (Battery, OpenBSD / NetBSD)
   * Support CPU temperature detection in NetBSD (CPU, NetBSD)
   * Hard code path of `libvulkan.so` for Android 
     - So that users don't need to install the vulkan-loader wrapper of termux
  Logo:
   * Add NurOS
   * Add GoralixOS

OBS-URL: https://build.opensuse.org/package/show/utilities/fastfetch?expand=0&rev=125
2024-12-26 14:07:38 +00:00

137 lines
3.8 KiB
RPMSpec

#
# spec file for package fastfetch
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
Name: fastfetch
Version: 2.33.0
Release: 0
Summary: Neofetch-like tool written mostly in C
License: MIT
URL: https://github.com/fastfetch-cli/fastfetch
Source: https://github.com/fastfetch-cli/fastfetch/archive/refs/tags/%{version}.tar.gz#/%{name}-%{version}.tar.gz
BuildRequires: Mesa-devel
BuildRequires: cmake
BuildRequires: gcc
BuildRequires: gcc-c++
BuildRequires: opencl-headers
BuildRequires: vulkan-headers
# For some reason these don't build on Leap
%if 0%{?suse_version} > 1600
%ifarch %{ix86} x86_64
BuildRequires: pkgconfig(DirectX-Headers)
%endif
%endif
BuildRequires: pkgconfig(ImageMagick)
BuildRequires: pkgconfig(chafa)
BuildRequires: pkgconfig(dbus-1)
BuildRequires: pkgconfig(dconf)
BuildRequires: pkgconfig(ddcutil)
BuildRequires: pkgconfig(libelf)
BuildRequires: pkgconfig(libpulse)
BuildRequires: pkgconfig(libxfconf-0)
BuildRequires: pkgconfig(ocl-icd)
BuildRequires: pkgconfig(rpm)
BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(vulkan)
BuildRequires: pkgconfig(wayland-client)
BuildRequires: pkgconfig(xcb)
BuildRequires: pkgconfig(xrandr)
BuildRequires: pkgconfig(zlib)
Recommends: ImageMagick
Recommends: Mesa
Recommends: chafa
Recommends: dbus-1
Recommends: dconf
Recommends: glib2-tools
Recommends: pciutils
Recommends: rpm
Recommends: sqlite3
Recommends: vulkan-tools
Recommends: xfconf
Recommends: xrandr
Recommends: zlib
%description
Fastfetch is a neofetch-like tool for fetching system information and
displaying them in a pretty way. It is written mainly in C, with performance and
customizability in mind. Currently Linux, Android, FreeBSD,
MacOS and Windows 7+ are supported.
%package fish-completion
Summary: Fish Completion for %{name}
Supplements: (%{name} and fish)
Requires: fastfetch
Requires: fish
BuildArch: noarch
%description fish-completion
Fish command-line completion support for %{name}.
%package bash-completion
Summary: Bash Completion for %{name}
Supplements: (%{name} and bash-completion)
Requires: bash-completion
Requires: fastfetch
BuildArch: noarch
%description bash-completion
Bash command-line completion support for %{name}.
%package zsh-completion
Summary: Zsh Completion for %{name}
Supplements: (%{name} and zsh)
Requires: fastfetch
Requires: zsh
BuildArch: noarch
%description zsh-completion
Zsh command-line completion support for %{name}.
%prep
%autosetup
%build
%cmake -DBUILD_FLASHFETCH:BOOL=FALSE
%cmake_build
%install
%cmake_install
%files
%license LICENSE
%doc README.md CHANGELOG.md
%{_bindir}/%{name}
%{_mandir}/man1/%{name}.1%{?ext_man}
%{_datadir}/%{name}/
%files bash-completion
%dir %{_datadir}/bash-completion
%dir %{_datadir}/bash-completion/completions
%{_datadir}/bash-completion/completions/fastfetch
%files fish-completion
%dir %{_datadir}/fish
%dir %{_datadir}/fish/vendor_completions.d
%{_datadir}/fish/vendor_completions.d/fastfetch.fish
%files zsh-completion
%dir %{_datadir}/zsh
%dir %{_datadir}/zsh/site-functions
%{_datadir}/zsh/site-functions/_fastfetch
%changelog