flac/flac.spec
Takashi Iwai d5c026278a - Update to version 1.5.0
General
  * Multithreaded encoding is now possible in libFLAC and through
    the flac command line tool.
  * The GFDL license file is updated to version 1.3.
  * The markdown tool documentation is now also converted to HTML,
    for bundling with systems that do not read manpages.
  * Decoding of chained Ogg FLAC files is now possible.
  * Is is now possible in libFLAC, libFLAC++ and metaflac to write
    to a new file when changing metadata, instead of needing to
    verwrite an existing file.
  flac
  * Testing mode (flac -t) now parses all metadata blocks and warns
    the user when ID3v1 metadata is detected.
  * A warning is displayed when frame numbers do not increase
    correctly throughout a file.
  * The explain option (-H or --explain) is now removed, use the
    manpage or html tool documentation instead.
  * Built-in help and tool documentation are improved.
  * When re-encoding a FLAC file from an existing FLAC file, a
    check is added that the MD5 sums of both files are the same.
  libFLAC and libFLAC++
  * The library interfaces have been extended.
    See the porting guide (part of the API documentation).
  * An error is sent when a frame is missing
  * The algorithm of the 'loose mid side' option has changed.
    Instead of checking every few frames which option is best and
    keeping that for the next few frames, a fast heuristic is now
    used. This was necessary to enable multithreading
  * Most level 0 metadata interface functions now also work with

OBS-URL: https://build.opensuse.org/package/show/multimedia:libs/flac?expand=0&rev=73
2025-02-12 10:23:06 +00:00

136 lines
3.9 KiB
RPMSpec

#
# spec file for package flac
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define sover 14
%define sover_plus 11
Name: flac
Version: 1.5.0
Release: 0
Summary: Free Lossless Audio Codec
License: BSD-3-Clause AND GPL-2.0-or-later AND GFDL-1.2-only
Group: Productivity/Multimedia/Sound/Utilities
URL: https://xiph.org/flac/
#Git-Web: https://github.com/xiph/flac
#Git-Clone: https://github.com/xiph/flac.git
#Changelog: https://xiph.org/flac/changelog.html
Source: https://github.com/xiph/flac/releases/download/%{version}/%{name}-%{version}.tar.xz
Source2: baselibs.conf
BuildRequires: autoconf >= 2.60
BuildRequires: automake >= 1.11
BuildRequires: c++_compiler
BuildRequires: c_compiler
BuildRequires: libtool
BuildRequires: pkgconfig
BuildRequires: xz
BuildRequires: pkgconfig(ogg)
Obsoletes: %{name}-doc
%{?suse_build_hwcaps_libs}
%description
FLAC is an audio coding format for lossless compression of digital
audio, and is also the name of the reference software package that
includes a codec implementation. Digital audio compressed by FLAC's
algorithm can typically be reduced to between 50 and 70 percent of
its original size, and decompresses to an identical copy of the
original audio data.
%package -n libFLAC%{sover}
Summary: Free Lossless Audio Codec Library
Group: System/Libraries
Obsoletes: libflac < %{version}
Provides: libflac = %{version}
%description -n libFLAC%{sover}
FLAC is an audio coding format for lossless compression of digital
audio, and is also the name of the reference software package that
includes a codec implementation.
This package contains the C API library for FLAC.
%package -n libFLAC++%{sover_plus}
Summary: Free Lossless Audio Codec Library
Group: System/Libraries
%description -n libFLAC++%{sover_plus}
FLAC is an audio coding format for lossless compression of digital
audio, and is also the name of the reference software package that
includes a codec implementation.
This package contains the C++ API library for FLAC.
%package devel
Summary: FLAC Library Development Package
Group: Development/Libraries/C and C++
Requires: glibc-devel
Requires: libFLAC%{sover} = %{version}
Requires: libFLAC++%{sover_plus} = %{version}
Requires: libstdc++-devel
%description devel
This package contains the files needed to compile programs that use
the FLAC library.
%prep
%autosetup -p1
%build
autoreconf -fvi
%configure \
--disable-silent-rules \
--disable-thorough-tests \
--disable-static \
--disable-rpath
%make_build
%install
%make_install docdir="%{_docdir}/%{name}"
find %{buildroot} -type f -name "*.la" -delete -print
# wrongy installed docs
rm -rf %{buildroot}%{_datadir}/doc/%{name}-%{version}/
%check
make check %{?_smp_mflags}
%ldconfig_scriptlets -n libFLAC%{sover}
%ldconfig_scriptlets -n libFLAC++%{sover_plus}
%files
%doc README.md
%{_bindir}/*
%{_mandir}/man*/*
%files -n libFLAC%{sover}
%license COPYING*
%{_libdir}/libFLAC.so.%{sover}*
%files -n libFLAC++%{sover_plus}
%license COPYING*
%{_libdir}/libFLAC++.so.%{sover_plus}*
%files devel
%{_libdir}/lib*.so
%{_includedir}/*
%{_libdir}/pkgconfig/*.pc
%{_datadir}/aclocal/*.m4
%{_docdir}/%{name}/
%exclude %{_docdir}/%{name}/README.md
%changelog