glow/glow.spec
Andreas Schneider 064be561bd Accepting request 1092891 from home:uncomfyhalomacro:branches:utilities
- Add fix-gitignore-bypass.patch.
  * This patch will fix where setting `--all` to see hidden files
    does not work for gitignore-ed files.

OBS-URL: https://build.opensuse.org/request/show/1092891
OBS-URL: https://build.opensuse.org/package/show/utilities/glow?expand=0&rev=12
2023-06-14 09:57:34 +00:00

80 lines
2.3 KiB
RPMSpec

#
# spec file for package glow
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{go_nostrip}
# Disable LTO flags to stop builds failing on some architectures
%global _lto_cflags %nil
Name: glow
Version: 1.5.1
Release: 0
Summary: Render markdown on the CLI
#
License: MIT
#
Group: System/Console
URL: https://github.com/charmbracelet/glow
#
Source0: https://github.com/charmbracelet/glow/archive/v%{version}/%{name}-%{version}.tar.gz
# `osc service disabledrun`
Source1: vendor.tar.zst
#
Source2: README.suse-maint.md
#
Patch1: fix-for-go-117.patch
Patch2: https://patch-diff.githubusercontent.com/raw/charmbracelet/glow/pull/504.patch#/fix-gitignore-bypass.patch
BuildRequires: golang-packaging
BuildRequires: zstd
BuildRequires: golang(API) >= 1.17
%description
Glow is a terminal based markdown reader designed from the ground up to bring
out the beauty—and power—of the CLI.
Use it to discover markdown files, read documentation directly on the command
line and stash markdown files to your own private collection so you can read
them anywhere. Glow will find local markdown files in subdirectories or a local
Git repository.
%prep
%autosetup -p1 -a1
%build
%ifarch ppc64
BUILDMOD=""
%else
BUILDMOD="-buildmode=pie"
%endif
export CGO_CFLAGS="%{optflags}"
export CGO_CXXFLAGS="%{optflags}"
export CGO_CPPFLAGS="%{optflags}"
go build -v -x -mod=vendor $BUILDMOD -a -ldflags "-s -X main.Version=%{version}"
%install
install -Dm755 %{name} %{buildroot}%{_bindir}/%{name}
%check
./glow --version
%files
%defattr(-,root,root,-)
%doc README.md
%license LICENSE
%{_bindir}/glow
%changelog