- add gnutls-fix.patch
GnuTLS built against guile 2.0 is breaking any HTTPS connection, this upstream patch solves it OBS-URL: https://build.opensuse.org/package/show/devel:languages:misc/guix?expand=0&rev=17
This commit is contained in:
parent
8e2636fc70
commit
e785f90881
31
gnutls-fix.patch
Normal file
31
gnutls-fix.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 7f04197fef905790fd392f8d686d00ae95a0d04c Mon Sep 17 00:00:00 2001
|
||||
From: Eric Bavier <bavier@cray.com>
|
||||
Date: Mon, 4 Dec 2017 10:33:31 -0600
|
||||
Subject: utils: Fix cond-expand for Guile 2.0.
|
||||
|
||||
* guix/build/download.scm (tls-wrap): Use 'guile-2.2' feature instead.
|
||||
---
|
||||
guix/build/download.scm | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/guix/build/download.scm b/guix/build/download.scm
|
||||
index 4490d22..609a100 100644
|
||||
--- a/guix/build/download.scm
|
||||
+++ b/guix/build/download.scm
|
||||
@@ -308,10 +308,10 @@ host name without trailing dot."
|
||||
(register-tls-record-port record port)
|
||||
|
||||
;; Write HTTP requests line by line rather than byte by byte:
|
||||
- ;; <https://bugs.gnu.org/22966>. This is not possible on Guile 2.0.
|
||||
+ ;; <https://bugs.gnu.org/22966>. This is possible with Guile >= 2.2.
|
||||
(cond-expand
|
||||
- (guile-2.0 #f)
|
||||
- (else (setvbuf record 'line)))
|
||||
+ (guile-2.2 (setvbuf record 'line))
|
||||
+ (else #f))
|
||||
|
||||
record)))
|
||||
|
||||
--
|
||||
cgit v1.0-41-gc330
|
||||
|
@ -1,3 +1,10 @@
|
||||
-------------------------------------------------------------------
|
||||
Mon May 28 13:29:04 UTC 2018 - sleep_walker@opensuse.org
|
||||
|
||||
- add gnutls-fix.patch
|
||||
GnuTLS built against guile 2.0 is breaking any HTTPS connection,
|
||||
this upstream patch solves it
|
||||
|
||||
-------------------------------------------------------------------
|
||||
Sat Mar 31 07:28:50 UTC 2018 - kasimir_@outlook.de
|
||||
|
||||
|
@ -45,6 +45,8 @@ Source11: armhf-linux-guile-2.0.11.tar.xz.sig
|
||||
Source12: aarch64-linux-guile-2.0.14.tar.xz
|
||||
Source13: aarch64-linux-guile-2.0.14.tar.xz.sig
|
||||
Source20: run_guix_daemon.sh
|
||||
# PATCH-FIX-UPSTREAM -- HTTPS is not working correctly for GnuTLS built against Guile 2.0 -- sleep_walker@opensuse.org
|
||||
Patch0: https://git.savannah.gnu.org/cgit/guix.git/patch/?id=7f04197fef905790fd392f8d686d00ae95a0d04c#./gnutls-fix.patch
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: gnutls-guile
|
||||
BuildRequires: guile-charting
|
||||
@ -74,6 +76,7 @@ Purely functional package manager and a distribution thereof.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
# install service file to _unitdir
|
||||
sed -i 's@\$(libdir)/systemd/system@%{_unitdir}@' Makefile.in
|
||||
mkdir -p gnu/packages/bootstrap/{i686,x86_64,mips64el,armhf}-linux
|
||||
|
Loading…
x
Reference in New Issue
Block a user