c971c4b9db
bump version to 0.15 We needed to add some patches because the release tarball misses them. I'll remove them at next release. I did extensive testing on Tumbleweed and Leap 15.0 which can be found here: https://etherpad.opensuse.org/p/guix-0.15 There is still some stuff which doesn't work as expected, but only small things. No showstoppers. I'll improve them peu a peu :) OBS-URL: https://build.opensuse.org/request/show/622310 OBS-URL: https://build.opensuse.org/package/show/devel:languages:misc/guix?expand=0&rev=22
33 lines
876 B
Diff
33 lines
876 B
Diff
Description: Use the markdown library provided by the libmarkdown2 package.
|
|
Author: Alessandro Ghedini <al3xbio@gmail.com>
|
|
Origin: vendor
|
|
Forwarded: not-needed
|
|
Last-Update: 2012-01-01
|
|
|
|
--- a/Makefile.PL
|
|
+++ b/Makefile.PL
|
|
@@ -57,12 +57,6 @@
|
|
|
|
|
|
|
|
-sub MY::postamble {
|
|
- return sprintf('
|
|
-$(MYEXTLIB):
|
|
- %s
|
|
-', qq{( cd $extdir; CC='cc -fPIC' sh configure.sh; make )\n});
|
|
-}
|
|
|
|
WriteMakefile(
|
|
NAME => 'Text::Markdown::Discount',
|
|
@@ -71,8 +65,6 @@
|
|
($] >= 5.005 ?
|
|
(ABSTRACT_FROM => 'lib/Text/Markdown/Discount.pm',
|
|
AUTHOR => 'Masayoshi Sekimura <sekimura@cpan.org>') : ()),
|
|
- LIBS => '-L' . $extdir,
|
|
- INC => '-I. -I' . $extdir,
|
|
- MYEXTLIB => $myextlib,
|
|
- clean => { FILES => $clean_files },
|
|
+ LIBS => '-lmarkdown',
|
|
+ INC => '-I.',
|
|
);
|