inkscape/inkscape.spec

328 lines
9.9 KiB
RPMSpec

#
# spec file for package inkscape (Version 0.46)
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: inkscape
BuildRequires: boost-devel cairomm docbook-toys fdupes gcc-c++ gtkmm24-devel intltool libglade2-devel libgnomeprintui-devel libgnomeui-devel liblcms-devel libpoppler-glib-devel libwnck-devel libxslt-devel loudmouth-devel perl python-devel python-gtk-devel sgml-skel update-desktop-files
License: GPL v2 only; LGPL v2.1 only
Group: Productivity/Graphics/Vector Editors
Requires: cairomm ghostscript-fonts-std python-gtk python-numeric pstoedit libwmf gzip skencil /usr/bin/gs
AutoReqProv: on
Summary: Inkscape Vector Illustration Program
Version: 0.46
Release: 34
Provides: sodipodi
Obsoletes: sodipodi
PreReq: /bin/rm /bin/ln /bin/sh /usr/bin/perl
Recommends: pyxml
Source: %{name}-%{version}.tar.bz2
Source1: gc6.4.tar.bz2
Patch: %{name}-boehm-gc.patch
Patch4: %{name}-swigfix.patch
Patch7: %{name}-bug-189159.patch
Patch8: %{name}-configure.patch
Patch10: gc6.4.patch
Patch13: %{name}-polyutil-newpoly.patch
Patch14: %{name}-buffer-overrun.patch
# PATCH-FIX-UPSTREAM inkscape-warnings.patch
Patch15: inkscape-warnings.patch
# PATCH-FIX-UPSTREAM inkscape-gtk-clist.patch maw@novell.com -- https://bugs.launchpad.net/inkscape/+bug/238223
Patch16: inkscape-gtk-clist.patch
Url: http://www.inkscape.org/
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Requires: %{name}-lang = %{version}
Recommends: python-lxml
%description
Inkscape is a vector illustration program for the GNOME desktop.
Authors:
--------
Alexander Clausen
John Bintz
Arpad Biro
Daniel Borgmann
Hans Breuer
Bulia Byak
Chema Celorio
Johan Ceuppens
Zbigniew Chyla
John Cliff
Kees Cook
Robert Crosbie
Jon Cruz
Danilo Egan
Frank Felfe
Fred
Ted Gould
Bryce Harrington
Carl Hetherington
Nathan Hurst
Thomas Ingham
Bob Jamison
Lauris Kaplinski
Lynn Kerby
Petr Kovar
Raph Levien
Vitaly Lipatov
Dmitry G. Mastrukov
Michael Meeks
Federico Mena
MenTaLguY
Peter Moulder
Yukihiro Nakai
Christian Neumair
Mitsuru Oka
Jon Phillips
Christian Schaller
Tom von Schwerdtner
Pat Suwalski
Adib Taraben
Daniel Yacob
Masatake Yamato
%lang_package
%prep
%setup -q -b 1
%patch
%patch4
%patch7
%patch8
%patch13
%patch14 -p1
%patch15 -p0
%patch16 -p0
pushd ../gc*
%patch10
popd
patch <<EOF
--- configure.ac
+++ configure.ac
@@ -612,1 +612,1 @@
-AC_DEFINE_UNQUOTED([INKSCAPE_LIBDIR], "\${prefix}/lib",
+AC_DEFINE_UNQUOTED([INKSCAPE_LIBDIR], "\${prefix}/%_lib",
EOF
# Change sr@latin to sr@Latn
rename sr@latin sr@Latn po/sr@latin.*
sed -i "/^ALL_LINGUAS/s/ sr@latin / sr@Latn /" configure.ac
chmod -x README.ca.txt
%build
pushd ../gc*
autoreconf -f -i
export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
%configure\
--libdir=%{_prefix}/lib\
--disable-shared
make %{?jobs:-j%jobs}
make install DESTDIR=$RPM_BUILD_DIR/gc_install
unset CFLAGS
popd
autoreconf -f -i
intltoolize --force
export CXXFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
# We're building without perl support for now...
%configure\
--enable-db2html\
--enable-gnome\
--with-python\
--without-perl\
--with-gnome-print\
--enable-inkboard\
--with-gc=$RPM_BUILD_DIR/gc_install/usr
make %{?jobs:-j%jobs}
%install
make DESTDIR=$RPM_BUILD_ROOT install
rm -rf $RPM_BUILD_ROOT/%{_datadir}/locale/en_US@piglatin
%suse_update_desktop_file -N "Inkscape" -G "SVG Vector Illustrator" inkscape Office FlowChart
%find_lang %{name}
mkdir -p $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions-optional
cp $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions/dia.inx $RPM_BUILD_ROOT%{_datadir}/inkscape/extensions-optional
%fdupes $RPM_BUILD_ROOT
%triggerin -- dia
ln -f usr/share/inkscape/extensions-optional/dia.inx usr/share/inkscape/extensions/dia.inx
%triggerpostun -- dia
if [ ! -x usr/bin/dia ] ; then
rm usr/share/inkscape/extensions/dia.inx
fi
%clean
rm -rf $RPM_BUILD_ROOT
%files
%defattr(-,root,root)
%doc AUTHORS COPYING COPYING.LIB ChangeLog HACKING* INSTALL NEWS README* TRANSLATORS
%{_bindir}/*
%{_datadir}/applications/inkscape.desktop
%dir %{_datadir}/inkscape
%{_datadir}/inkscape/[a-df-z]*
%{_datadir}/inkscape/exa*
%{_datadir}/inkscape/extensions-optional
%dir %{_datadir}/inkscape/extensions
%{_datadir}/inkscape/extensions/[a-ce-zA-Z]*
%{_datadir}/inkscape/extensions/dia2*
%{_datadir}/inkscape/extensions/dimension.*
%{_datadir}/inkscape/extensions/dots*
%{_datadir}/inkscape/extensions/dx*
%ghost %{_datadir}/inkscape/extensions/dia.inx
%{_datadir}/pixmaps/inkscape.png
%doc %{_mandir}/man?/*.*
%doc %{_mandir}/??/man?/*.*
# FIXME
%dir %{_mandir}/fr
%dir %{_mandir}/fr/man1
%files lang -f %{name}.lang
%changelog
* Sat Jun 28 2008 maw@suse.de
- Add inkscape-gtk-clist.patch, to enable building against
recent versions of gtk+.
* Thu May 15 2008 maw@suse.de
- Recommend python-lxml (bnc#370334).
* Wed May 07 2008 maw@suse.de
- Respin inkscape-warnings.patch.
* Thu Apr 03 2008 maw@suse.de
- Buildrequire libpoppler-glib-devel, thereby enabling pdf import support
(bnc#376752).
* Sat Mar 29 2008 maw@suse.de
- Update to version 0.46:
+ Many new features and bugfeatures
+ For a detailed account of what's new, see the NEWS file
- Remove stale patches: inkscape-invalid-conversion.patch,
inkscape-0.45.1-gcc43.patch, inkscape-g_assert.patch
- Respin inkscape-bug-189159.patch
- Add inkscape-warnings.patch
- Rename sr@latin to sr@Latn.
* Thu Mar 06 2008 maw@suse.de
- Fix the build when against newer versions of intltool.
* Tue Feb 05 2008 maw@suse.de
- Disable perl support for now.
* Tue Jan 29 2008 maw@suse.de
- Add inkscape-g_assert.patch.
* Fri Jan 11 2008 coolo@suse.de
- take more gcc43 patches from SVN
* Sat Nov 10 2007 mauro@suse.de
- Added inkscape-0.45.1-gcc43.patch
+ Fixes issues with gcc 4.3.
* Wed Aug 08 2007 maw@suse.de
- Use %%fdupes
- Split off a -lang subpackage.
* Thu May 10 2007 prusnak@suse.cz
- recommends pyxml [#271758]
* Wed Apr 18 2007 aj@suse.de
- Fix spec list so that package builds again.
* Thu Mar 29 2007 maw@suse.de
- Update to version 0.45
- Remove upstreamed inkscape-siox-max.patch
- Remove now-unnecessary inkscape-session-manager-strcmp.patch and
inkscape-enable-perl.patch
- Add inkscape-buffer-overrun.patch
* Wed Jan 31 2007 sbrabec@suse.cz
- Removed remaining references to /opt/gnome (#240571).
* Tue Jan 23 2007 prusnak@suse.cz
- fixed build errors
* polyutil-newpoly.patch - uninitialized structure
* session-manager-strcmp.patch - comparing char* w/ string literal
* Mon Jan 22 2007 sbrabec@suse.cz
- Prefix changed to /usr.
- Spec file cleanup.
* Thu Jan 04 2007 prusnak@suse.cz
- fixed illegal comparison (siox-max.patch) [#231224]
* Mon Nov 06 2006 jhargadon@suse.de
- applied a patch that fixes a problem where the package would not
compile with the --with-perl option.
* Sat Oct 21 2006 schwab@suse.de
- Don't use obsolete macro.
* Sat Oct 14 2006 danw@suse.de
- Remove dead patches
* Thu Oct 05 2006 jhargadon@suse.de
- added --datadir=%%prefix/share as a configuration option. This
is a work around for bug #204719
* Sat Sep 30 2006 jhargadon@suse.de
- update to version 0.44.1
- Layers dialog
- Outline mode, many performance improvements
- Native PDF export with transparency
- Clipping and masking support
- Configurable keyboard shortcuts
- Docked color palette in the editing window
- Interactive indicator of the style of selection in the statusbar
- Innovative "node sculpting" and other improvements in Node tool
- Better SVG support: <switch> element, ICC color profiles for images
- Persistent rotation centers, Paste Size command
- many bug fixes
- removed the --with-perl option from configuration in the specfile
* Sat Sep 09 2006 meissner@suse.de
- use RPM_OPT_FLAGS.
* Wed Aug 16 2006 cthiel@suse.de
- buildrequire python-gtk-devel instead of python-gtk
* Sat Jul 08 2006 jpr@suse.de
- add patch to not use freetype2 internals
* Sat Feb 18 2006 stbinner@suse.de
- fix typo .desktop file
* Sat Feb 18 2006 gekker@suse.de
- fixup .desktop file for UI team
* Tue Jan 31 2006 ro@suse.de
- take fix from swig to swig-generated source file
* Wed Jan 25 2006 mls@suse.de
- converted neededforbuild to BuildRequires
* Wed Nov 23 2005 sbrabec@suse.cz
- Updated to version 0.43 (#134655).
- Enabled Inkboard Collaborative Editing.
* Mon Nov 07 2005 sbrabec@suse.cz
- Fixed qualification and type conversion errors.
* Thu Aug 25 2005 nadvornik@suse.cz
- updated to bugfix release 0.42.2 [#112918]
* Mon Aug 01 2005 ro@suse.de
- added dir to filelist /usr/share/man/fr/man1
* Fri Jul 29 2005 sbrabec@suse.cz
- Updated to version 0.42.
* Tue May 31 2005 schwab@suse.de
- Fix more invalid casts.
* Wed May 18 2005 ro@suse.de
- fix build with current pkgconfig
* Thu Apr 28 2005 sbrabec@suse.cz
- Build boehm-gc with -fPIC and -fno-strict-aliasing.
* Wed Apr 27 2005 ro@suse.de
- remove boehm-gc from nfb (dropped)
- use private copy of gc6.4
* Tue Apr 26 2005 sbrabec@suse.cz
- Install missing translation files.
* Mon Apr 11 2005 sbrabec@suse.cz
- Fixed invalid casts.
* Mon Mar 21 2005 sbrabec@suse.cz
- Bi-arch fix (#66780).
- Require skencil needed for PS/EPS input (#66780).
* Mon Feb 28 2005 sbrabec@suse.cz
- Added needed Requires and triggers for optional extensions
(#66780).
- Turned on perl, python and gnome-print support.
* Mon Feb 21 2005 sbrabec@suse.cz
- Updated to version 0.41.
- Worked around problems with boehm-gc detection.
* Fri Feb 11 2005 sbrabec@suse.cz
- Updated to version 0.40.
* Fri Feb 11 2005 ro@suse.de
- change to libsigc++12 in neededforbuild
* Tue Nov 02 2004 mmj@suse.de
- Locale rename: no -> nb
* Thu Aug 12 2004 hhetter@suse.de
- Obsolete and Provide sodipodi
* Mon Aug 02 2004 hhetter@suse.de
- initial SuSE package