keepass/keepass.spec
Matthias Bach 1677c6b686 - Update to 2.58
* New Features:
    - When no entry is selected in the entry list of the main window, the details view now displays information of the current group (name, expiry time, tags, notes).
    - Added option 'Unhide empty data' (in 'Tools' → 'Options' → tab 'Advanced', turned off by default).
    - On the 'Preview'/'Generate' tab page of the password generator dialog, the average estimated quality of the generated passwords is now displayed.
    - Added Ctrl+H keyboard shortcut for the 'Show/hide password using asterisks' option in report dialogs.
    - Added 'User-Agent' header for HTTP/HTTPS/WebDAV web requests.
    - If Microsoft Edge has been uninstalled, it now no longer appears in the 'URL(s)' menu.
    - Added 'More Commands' item in the group and entry context menus (it shows the corresponding full menu).
    - Added 'Status' column in the triggers dialog.
    - Added support for comments in INI files.
    - Enhanced CodeWallet TXT import module.
    - Fatal error messages are now more detailed when running KeePass with the '-debug' command line option.
    - Added filter for duplicate MRU items (caused by an MRU item with an unsuitable database file path in an enforced configuration file).
    - Added filter for duplicate key source associations (caused by a key source association with an unsuitable database file path in an enforced configuration file).
    - Added workaround for Mono's tree view right-click and context menu handling.
  * Improvements:
    - When clicking on a group in the group tree of the main window, all entries are deselected now.
    - If the currently selected entry does not have parameters for generating time-based one-time passwords, the Ctrl+T and Ctrl+Shift+T keyboard shortcuts are now ignored.
    - Improved icon handling in certain entry lists (significantly faster creation of such a list when there are many entries with custom icons, reduced memory usage, reduced number of GDI objects, ...).
    - In the master key prompt dialog, toggling the hiding of the password now does not change the state of the password check box anymore.
    - When generating passwords for the 'Preview'/'Generate' tab page of the password generator dialog takes too long, it is now aborted.
    - Replaced status indicators on the 'Preview'/'Generate' tab page of the password generator dialog.
    - Increased the number of preview passwords to 50.
    - UI improvements in the trigger editing dialog.
    - After showing a command/placeholder confirmation dialog (cmd:// URI, {CMD:...} placeholder, {REF:P@...} placeholder), KeePass now focuses the previously focused window.
    - Renamed 'entry view' to 'details view' (because it can now also display details of a group).
    - Removed the group/entry duplication commands from the context menus (they continue to be available in the main menu).
    - Various improvements in some import modules.
    - Improved UUID zero tests.

OBS-URL: https://build.opensuse.org/package/show/Mono/keepass?expand=0&rev=60
2025-03-04 18:55:30 +00:00

110 lines
3.5 KiB
RPMSpec

#
# spec file for package keepass
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define _name KeePass
Name: keepass
Version: 2.58
Release: 0
Summary: Password Manager
License: GPL-2.0-or-later
Group: Productivity/Other
URL: https://keepass.info/
Source0: https://netcologne.dl.sourceforge.net/project/keepass/KeePass%202.x/%{version}/KeePass-%{version}-Source.zip
Source1: https://keepass.info/integrity/v2/KeePass-%{version}-Source.zip.asc
# http://keepass.info/integrity/Dominik_Reichl.asc
Source2: keepass.keyring
BuildRequires: dos2unix
BuildRequires: mono-devel
BuildRequires: unzip
BuildRequires: xdotool-devel
BuildRequires: xorg-x11-fonts-core
BuildRequires: xsel
Recommends: libargon2-1
Recommends: libgcrypt20
Recommends: xdotool
BuildArch: noarch
%description
KeePass is a password manager, which helps you to manage your
passwords. You can put all your passwords in one database, which is
locked with one master key or a key file, so that you only have to
remember one single master password or select the key file to unlock
the whole database. The databases are encrypted using AES and
Twofish.
%prep
%setup -q -c %{name}-%{version}
dos2unix Docs/License.txt Docs/History.txt
sed -i '1s/ 10.00/ 11.00/' KeePass.sln
find . -name "*.csproj" -exec sed -i '1s/"3.5"/"4.0"/' {} +
pushd Build &>/dev/null
bash PrepMonoDev.sh
sh PrepMonoDev.sh
popd &>/dev/null
%build
xbuild /target:KeePass /property:Configuration=Release KeePass.sln
%install
install -d %{buildroot}%{_prefix}/lib/%{name}
install -d %{buildroot}%{_prefix}/lib/%{name}/XSL
install -m 644 Build/%{_name}Lib_Distrib/%{_name}Lib.dll %{buildroot}%{_prefix}/lib/%{name}/
install -m 644 Build/%{_name}/Release/%{_name}.exe* %{buildroot}%{_prefix}/lib/%{name}/
install -m 644 Ext/%{_name}.config.xml %{buildroot}%{_prefix}/lib/%{name}/
install -m 644 Ext/%{_name}.exe.config %{buildroot}%{_prefix}/lib/%{name}/
install -m 644 Ext/XSL/* %{buildroot}%{_prefix}/lib/%{name}/XSL
# Bin wrapper
install -d %{buildroot}%{_bindir}
cat << EOF > %{buildroot}%{_bindir}/%{name}
#!/bin/sh
exec mono %{_prefix}/lib/%{name}/%{_name}.exe "\$@"
EOF
# Desktop file
install -d %{buildroot}%{_datadir}/applications
cat << EOF > %{buildroot}%{_datadir}/applications/%{name}.desktop
[Desktop Entry]
Type=Application
Name=%{_name}
GenericName=Password Manager
Comment=Secure Password Management System
Icon=keepass
TryExec=%{_bindir}/keepass
Exec=keepass
Terminal=false
Categories=Utility;Security;
X-SuSE-translate=false
EOF
# Icon
install -d %{buildroot}%{_datadir}/pixmaps
install -m 644 Ext/Icons_04_CB/Finals/plock-blu.png %{buildroot}%{_datadir}/pixmaps/%{name}.png
%files
%license Docs/License.txt
%doc Docs/History.txt
%attr(755,root,root) %{_bindir}/%{name}
%{_datadir}/applications/%{name}.desktop
%{_datadir}/pixmaps/%{name}.png
%{_prefix}/lib/keepass
%changelog