libeconf/libeconf.spec
Stefan Schubert a395cec6a2 Accepting request 1179642 from home:schubi2:branches:devel:microos
- Update to version 0.7.1:
* Improved error handling while parsing values with the wrong format.
  Added new return value ECONF_VALUE_CONVERSION_ERROR.
* Setting parsing options via econf_file struct.
  see econf_newKeyFile_with_options. These options will be used by
  econf_readConfig and econf_readConfigWithCallback.
  Following options are supported:
   JOIN_SAME_ENTRIES  (default 0)
     Parsed entries with the same name will not be replaces but
     will be joined to one entry.
   PYTHON_STYLE  (default 0)
     E.G. Identations will be handled like multiline entries.
   PARSING_DIRS (default /usr/etc/:/run:/etc)
     List of directories from which the configuration files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g.: "PARSING_DIRS=/usr/etc/:/run:/etc"
   CONFIG_DIRS (default <empty>)
     List of directory structures (with order) which describes the directories
     in which the files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g. with the given list: "CONFIG_DIRS=.conf.d:.d" files in
     following directories will be parsed:
            "<default_dirs>/<config_name>.conf.d/"
            "<default_dirs>/<config_name>.d/"
            "<default_dirs>/<config_name>/"
* CAUTION: From now on every econf_file element MUST be intialized if
           econf_readConfig and econf_readConfigWithCallback is used.
  Either with NULL or:
   econf_file *key_file = NULL;
   if (error = econf_newKeyFile_with_options(&key_file, "PYTHON_STYLE=1"))
   {
      fprintf (stderr, "ERROR: couldn't create new key file: %s\n",
               econf_errString(error));
      return 1;
   }
   error = econf_readConfig (&key_file,
                             "foo",
                             "/usr/lib",
                             "example",
                             "conf",
                             "=", "#");
- Update to version 0.7.1:
* Improved error handling while parsing values with the wrong format.
  Added new return value ECONF_VALUE_CONVERSION_ERROR.
* Setting parsing options via econf_file struct.
  see econf_newKeyFile_with_options. These options will be used by
  econf_readConfig and econf_readConfigWithCallback.
  Following options are supported:
   JOIN_SAME_ENTRIES  (default 0)
     Parsed entries with the same name will not be replaces but
     will be joined to one entry.
   PYTHON_STYLE  (default 0)
     E.G. Identations will be handled like multiline entries.
   PARSING_DIRS (default /usr/etc/:/run:/etc)
     List of directories from which the configuration files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g.: "PARSING_DIRS=/usr/etc/:/run:/etc"
   CONFIG_DIRS (default <empty>)
     List of directory structures (with order) which describes the directories
     in which the files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g. with the given list: "CONFIG_DIRS=.conf.d:.d" files in
     following directories will be parsed:
            "<default_dirs>/<config_name>.conf.d/"
            "<default_dirs>/<config_name>.d/"
            "<default_dirs>/<config_name>/"
* CAUTION: From now on every econf_file element MUST be intialized if
           econf_readConfig and econf_readConfigWithCallback is used.
  Either with NULL or:
   econf_file *key_file = NULL;
   if (error = econf_newKeyFile_with_options(&key_file, "PYTHON_STYLE=1"))
   {
      fprintf (stderr, "ERROR: couldn't create new key file: %s\n",
               econf_errString(error));
      return 1;
   }
   error = econf_readConfig (&key_file,
                             "foo",
                             "/usr/lib",
                             "example",
                             "conf",
                             "=", "#");

OBS-URL: https://build.opensuse.org/request/show/1179642
OBS-URL: https://build.opensuse.org/package/show/devel:microos/libeconf?expand=0&rev=28
2024-06-10 08:10:26 +00:00

106 lines
2.7 KiB
RPMSpec

#
# spec file for package libeconf
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname libeconf0
Name: libeconf
Version: 0.7.1
Release: 0
Summary: Enhanced config file parser ala systemd
License: LGPL-2.1-or-later
Group: Development/Libraries/C and C++
URL: https://github.com/openSUSE/libeconf
Source: libeconf-%{version}.tar.xz
Source2: baselibs.conf
BuildRequires: meson
# for /usr/lib/rpm/pkgconfigdeps.sh
BuildRequires: pkgconfig
%description
Enhanced config file parser, which merges config files placed
in several locations into one.
%package -n %{lname}
Summary: Enhanced config file parser ala systemd
Group: Development/Libraries/C and C++
%description -n %{lname}
Enhanced config file parser, which merges config files placed
in several locations into one.
%package devel
Summary: Development files for libeconf
Group: Development/Libraries/C and C++
Requires: %{lname} = %{version}
%description devel
This package contains all necessary include files and libraries needed
to develop applications that needs to read configuration files from
different locations.
%package devel-static
Summary: Static library for libeconf
Group: Development/Libraries/C and C++
Requires: libeconf-devel = %{version}
%description devel-static
This package contains libeconf.a static library.
%package utils
Summary: Command line interface for libeconf
Group: System/Base
Requires: %{lname} = %{version}
%description utils
This package contains tools for handling configuration files in e.g. /usr/etc
and /etc.
%prep
%setup -q
%build
%meson
%meson_build
%install
%meson_install
%check
%meson_test
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%files -n %{lname}
%license LICENSE
%{_libdir}/libeconf.so.*
%files devel-static
%{_libdir}/libeconf.a
%files devel
%{_includedir}/*.h
%{_libdir}/libeconf.so
%{_libdir}/pkgconfig/libeconf.pc
%{_mandir}/man3/libeconf.3%{?ext_man}
%files utils
%{_bindir}/econftool
%{_mandir}/man8/econftool.8%{?ext_man}
%changelog