libeconf/python-libeconf.spec
Stefan Schubert a395cec6a2 Accepting request 1179642 from home:schubi2:branches:devel:microos
- Update to version 0.7.1:
* Improved error handling while parsing values with the wrong format.
  Added new return value ECONF_VALUE_CONVERSION_ERROR.
* Setting parsing options via econf_file struct.
  see econf_newKeyFile_with_options. These options will be used by
  econf_readConfig and econf_readConfigWithCallback.
  Following options are supported:
   JOIN_SAME_ENTRIES  (default 0)
     Parsed entries with the same name will not be replaces but
     will be joined to one entry.
   PYTHON_STYLE  (default 0)
     E.G. Identations will be handled like multiline entries.
   PARSING_DIRS (default /usr/etc/:/run:/etc)
     List of directories from which the configuration files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g.: "PARSING_DIRS=/usr/etc/:/run:/etc"
   CONFIG_DIRS (default <empty>)
     List of directory structures (with order) which describes the directories
     in which the files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g. with the given list: "CONFIG_DIRS=.conf.d:.d" files in
     following directories will be parsed:
            "<default_dirs>/<config_name>.conf.d/"
            "<default_dirs>/<config_name>.d/"
            "<default_dirs>/<config_name>/"
* CAUTION: From now on every econf_file element MUST be intialized if
           econf_readConfig and econf_readConfigWithCallback is used.
  Either with NULL or:
   econf_file *key_file = NULL;
   if (error = econf_newKeyFile_with_options(&key_file, "PYTHON_STYLE=1"))
   {
      fprintf (stderr, "ERROR: couldn't create new key file: %s\n",
               econf_errString(error));
      return 1;
   }
   error = econf_readConfig (&key_file,
                             "foo",
                             "/usr/lib",
                             "example",
                             "conf",
                             "=", "#");
- Update to version 0.7.1:
* Improved error handling while parsing values with the wrong format.
  Added new return value ECONF_VALUE_CONVERSION_ERROR.
* Setting parsing options via econf_file struct.
  see econf_newKeyFile_with_options. These options will be used by
  econf_readConfig and econf_readConfigWithCallback.
  Following options are supported:
   JOIN_SAME_ENTRIES  (default 0)
     Parsed entries with the same name will not be replaces but
     will be joined to one entry.
   PYTHON_STYLE  (default 0)
     E.G. Identations will be handled like multiline entries.
   PARSING_DIRS (default /usr/etc/:/run:/etc)
     List of directories from which the configuration files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g.: "PARSING_DIRS=/usr/etc/:/run:/etc"
   CONFIG_DIRS (default <empty>)
     List of directory structures (with order) which describes the directories
     in which the files have to be parsed.
     The list is a string, divides by ":". The last entry has the highest
     priority. E.g. with the given list: "CONFIG_DIRS=.conf.d:.d" files in
     following directories will be parsed:
            "<default_dirs>/<config_name>.conf.d/"
            "<default_dirs>/<config_name>.d/"
            "<default_dirs>/<config_name>/"
* CAUTION: From now on every econf_file element MUST be intialized if
           econf_readConfig and econf_readConfigWithCallback is used.
  Either with NULL or:
   econf_file *key_file = NULL;
   if (error = econf_newKeyFile_with_options(&key_file, "PYTHON_STYLE=1"))
   {
      fprintf (stderr, "ERROR: couldn't create new key file: %s\n",
               econf_errString(error));
      return 1;
   }
   error = econf_readConfig (&key_file,
                             "foo",
                             "/usr/lib",
                             "example",
                             "conf",
                             "=", "#");

OBS-URL: https://build.opensuse.org/request/show/1179642
OBS-URL: https://build.opensuse.org/package/show/devel:microos/libeconf?expand=0&rev=28
2024-06-10 08:10:26 +00:00

69 lines
1.9 KiB
RPMSpec

#
# spec file for package python-libeconf
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?sle15_python_module_pythons}
%define skip_python39 1
Name: python-libeconf
Version: 0.7.1
Release: 0
Summary: Python bindings for libeconf
License: LGPL-2.1-or-later
Group: Development/Languages/Python
URL: https://github.com/openSUSE/libeconf
Source: libeconf-%{version}.tar.xz
BuildArch: noarch
BuildRequires: %{python_module pip}
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wheel}
BuildRequires: python-rpm-macros
Requires: libeconf0 = %{version}
Suggests: python-libeconf-doc = %{version}
%python_subpackages
%description
Python bindings for libeconf
%package -n python-libeconf-doc
Summary: Man page for python-libeconf
%description -n python-libeconf-doc
Man page for python-lineconf
%prep
%autosetup -n libeconf-%{version}/bindings/python3
%build
%pyproject_wheel
%install
%pyproject_install
mkdir -p %{buildroot}/usr/share/man/man3
cp docs/python-libeconf.3 %{buildroot}%{_mandir}/man3/
%files %python_files
%{python_sitelib}
# The cache is not always present
#pycache_only %{python_sitelib}/__pycache__
%files -n python-libeconf-doc
%defattr(-,root,root)
%{_mandir}/man3/*python-libeconf*
%changelog