libfabric/fabtests.spec
Nicolas Morey 779fd8ecd7 Accepting request 1164368 from home:NMorey:branches:science:HPC
- Enable ucx and new efa provider on 64b architectures.
- Use a single changes file for libfabric and fabtests.
- Update to 1.21.0
  - Core
    - Various update and fixed in man pages
    - Fix xpmem memory corruption
    - Extend FI_PROVIDER_PATH to allow setting preferred DL provider
    - Add a SECURITY.md file
    - Document preferred threading model for scalable endpoints
    - Move FI_PRIORITY to internal flag
    - Remove FI_PROV_SPECIFIC
    - Remove unimplemented or unused features
    - Support cntr byte counting
    - configure: Do not check for xpmem if disabled
    - Add FI_PROGRESS_CONTROL_UNIFIED
    - hmem/cuda: Get multiple attributes at once in cuda_is_addr_valid
    - configure: Add -pipe by default to CFLAGS
    - Selectively generate warnings on failed loading of DL providers
    - hmem: introduce ofi_dev_reg_copy_*_iov ops
    - Print provider path on fabric creation
    - Introduce FI_OPT_SHARED_MEMORY_PERMITTED
    - README.md: Add badge for openssf scorecard
    - man: Regulate the fi_setopt call sequence.
    - man: Clarify the usage of FI_RMOTE_CQ_DATA flag
    - man: Add ucx provider to the fi_provider man page
    - configure.ac: add extra check for 128 bit atomic support
    - include/osd: align atomic complex definitions
    - hmem/synapseai: Refine the error handling and warning
    - Specify C11 standard for Visual Studio builds
    - configure: Do not check for xpmem if disabled

OBS-URL: https://build.opensuse.org/request/show/1164368
OBS-URL: https://build.opensuse.org/package/show/science:HPC/libfabric?expand=0&rev=101
2024-04-03 15:32:26 +00:00

65 lines
1.7 KiB
RPMSpec

#
# spec file for package fabtests
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define git_ver .0.f67fad269327
Name: fabtests
Version: 1.21.0
Release: 0
Summary: Test suite for libfabric API
License: BSD-2-Clause OR GPL-2.0-only
Group: Development/Tools/Other
URL: http://www.github.com/ofiwg/libfabric
Source: libfabric-%{version}%{git_ver}.tar.bz2
Source1: fabtests-rpmlintrc
Patch0: libfabric-libtool.patch
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libfabric-devel = %{version}
BuildRequires: libtool
BuildRoot: %{_tmppath}/%{name}-%{version}-build
%description
Fabtests provides a set of examples that uses libfabric, a fabric software library.
%prep
%autosetup -p1 -n libfabric-%{version}%{git_ver}
%build
cd fabtests
./autogen.sh
%configure %{?_with_libfabric}
%make_build
%install
%make_install -C fabtests
%files
%defattr(-,root,root)
%dir %{_datadir}/fabtests/
%{_bindir}/*
%{_mandir}/man1/*
%{_mandir}/man7/*
%{_datadir}/fabtests/*
%doc AUTHORS README NEWS.md
%license COPYING
%changelog