libspiro/libspiro.spec
Petr Gajdos 884c663fb3 Accepting request 1060006 from home:dirkmueller:Factory
- update to 20221101:
  * Bugfix - removed forgotten if-then code used with scaling tests.
    Majority of users won't notice a difference since most FontForge
    fonts are created in the +x,+y quadrant. Users that might see a
    change/difference are users drawing only in the -x, -y quadrant.
  * Enhanced libspiro to allow closed-loop spiros starting with '['
    or 'a' by seeking the first available 'v', 'c', or 'o' as start,
    which may be found later in the spiro curve. This was the least
    modification needed to allow call-test10 or call-test11 to pass.
  * Due to confusion created when ppedit was also re-licensed as MIT
    APACHE and GPL2+, it's necessary to re-clarify libspiro is GPL3+.
    In summary, GPL can include MIT code, MIT code cannot accept GPL.
    Please note code not in ppedit like libspiro's java is GNU GPL2+.
    Please note that libspiro's improvements or patches are also GPL.
  * Thanks to orbea for bugfixes concerning linking and linker flags,
    and removing .libs from linker path (some linkers don't like it).
  * Added more commenting in spiroentrypoints.h to clarify functions.
  * Reconfigured code to avoid exporting bezctx_intf.h since this is
    supposed to be internal to libspiro and not for external calling.
  * Also added https://gcc.gnu.org/wiki/Visibility to reduce exports.
  * SPIRO_INTERNAL_BEZCTX and call-test21.c added for simpler method
    of accessing libspiro for programs that only need the end result.
  * Test added for 'a','h' to ensure points don't overlap, else exit.

OBS-URL: https://build.opensuse.org/request/show/1060006
OBS-URL: https://build.opensuse.org/package/show/devel:libraries:c_c++/libspiro?expand=0&rev=16
2023-01-23 08:07:14 +00:00

85 lines
2.4 KiB
RPMSpec

#
# spec file for package libspiro
#
# Copyright (c) 2022 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define sonum 1
Name: libspiro
Version: 20221101
Release: 0
Summary: A clothoid to bezier spline converter
License: GPL-3.0-or-later
Group: System/Libraries
URL: https://github.com/fontforge/libspiro
Source0: https://github.com/fontforge/libspiro/archive/%{version}.tar.gz
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: gcc-c++
BuildRequires: libtool
BuildRequires: pkgconfig
%description
libspiro contains routines which will convert an array of clothoid
spline control points into an equivalent set of bezier control points.
%package -n %{name}%{sonum}
Summary: A clothoid to bezier spline converter
Group: System/Libraries
%description -n %{name}%{sonum}
libspiro contains routines which will convert an array of clothoid
spline control points into an equivalent set of bezier control points.
%package devel
Summary: Development Files for %{name}
Group: Development/Libraries/C and C++
Requires: %{name}1 = %{version}
Requires: glibc-devel
%description devel
This package contains all necessary include files and libraries needed
to compile and develop applications that use %{name}.
%prep
%setup -q
%build
autoreconf -i
automake --foreign -Wall
%configure --with-pic\
--disable-static
%make_build
%install
%make_install
find %{buildroot} -type f -name "*.la" -delete -print
%post -n %{name}%{sonum} -p /sbin/ldconfig
%postun -n %{name}%{sonum} -p /sbin/ldconfig
%files -n %{name}%{sonum}
%license COPYING
%doc ChangeLog README*
%{_libdir}/lib*.so.*
%files devel
%{_includedir}/*
%{_libdir}/*.so
%{_mandir}/man3/libspiro.3%{?ext_man}
%{_libdir}/pkgconfig/*.pc
%changelog