liburing/liburing.spec
David Disseldorp 5e644df226 Accepting request 1164309 from home:jirislaby:branches:devel:libraries:c_c++
- Update to 2.5:
  * Add support for io_uring_prep_cmd_sock()
  * Add support for application allocated ring memory, for placing rings
    in huge mem. Available through io_uring_queue_init_mem().
  * Add support for registered ring fds
  * Various documentation updates
  * Various fixes
- Remove (they are upstream)
  * test-io_uring_register-fix-errno-confusion-and-new-e.patch
  * tests-don-t-expect-multishot-recv-overflow-backloggi.patch
- Add
  * test-recv-multishot-wait-for-the-right-amount-of-CQE.patch (to fix test
    errors on the 6.8.2 kernel)
  * test-no-mmap-inval-0-return-is-fine-too.patch (fix the test)

OBS-URL: https://build.opensuse.org/request/show/1164309
OBS-URL: https://build.opensuse.org/package/show/devel:libraries:c_c++/liburing?expand=0&rev=42
2024-04-03 09:35:44 +00:00

123 lines
3.7 KiB
RPMSpec

#
# spec file for package liburing
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define lname liburing2
Name: liburing
Version: 2.5
Release: 0
Summary: Linux-native io_uring I/O access library
License: (GPL-2.0-only AND LGPL-2.1-or-later) OR MIT
Group: Development/Libraries/C and C++
URL: https://git.kernel.dk/cgit/liburing
Source: https://git.kernel.dk/cgit/liburing/snapshot/%{name}-%{version}.tar.bz2
Patch0: test-recv-multishot-wait-for-the-right-amount-of-CQE.patch
Patch1: test-no-mmap-inval-0-return-is-fine-too.patch
BuildRequires: gcc-c++
BuildRequires: pkgconfig
BuildRequires: procps
# Kernel part has landed in 5.1
Conflicts: kernel < 5.1
%description
Provides native async IO for the Linux kernel, in a fast and efficient
manner, for both buffered and O_DIRECT.
%package -n %{lname}
Summary: Linux-native io_uring I/O access library
Group: Development/Libraries/C and C++
%description -n %{lname}
Provides native async IO for the Linux kernel, in a fast and efficient
manner, for both buffered and O_DIRECT.
%package -n liburing-ffi2
Summary: io_uring I/O access library for non-C/C++ languages
Group: Development/Libraries/C and C++
%description -n liburing-ffi2
Foreign function interface for liburing, offering non-C/C++ language
integration.
%package devel
Summary: Development files for Linux-native io_uring I/O access library
Group: Development/Libraries/C and C++
# SLE/Leap 15.4+ retain liburing-devel for the inherited 0.6 API. The v2 API is:
Provides: %{lname}-devel = %{version}
Requires: %{lname} = %{version}
Requires: pkgconfig
%description devel
This package provides header files to include and libraries to link with
for the Linux-native io_uring.
%prep
%autosetup -p1
%build
# not autotools, so configure macro doesn't work
%set_build_flags
%ifarch %{ix86}
# Otherwise 32-bit x86 fails with: undefined reference to `__stack_chk_fail_local'
export CFLAGS="%{optflags} -fno-stack-protector"
export CPPFLAGS="%{optflags} -fno-stack-protector"
%endif
sh ./configure --prefix=%{_prefix} \
--includedir=%{_includedir} \
--libdir=/%{_libdir} \
--libdevdir=/%{_libdir} \
--mandir=%{_mandir} \
--datadir=%{_datadir}
%make_build -C src
%check
# io_uring syscalls not supported as of qemu 7.0.0 and would test the host
# kernel anyway not the target kernel..
%if !0%{?qemu_user_space_build}
/usr/bin/make %{?_smp_mflags} runtests
%endif
%install
%make_install
rm -v %{buildroot}%{_libdir}/%{name}*.a
%post -n %{lname} -p /sbin/ldconfig
%postun -n %{lname} -p /sbin/ldconfig
%post -n liburing-ffi2 -p /sbin/ldconfig
%postun -n liburing-ffi2 -p /sbin/ldconfig
%files -n %{lname}
%{_libdir}/liburing.so.*
%license COPYING COPYING.GPL LICENSE
%files -n liburing-ffi2
%{_libdir}/liburing-ffi.so.*
%files devel
%doc README
%{_includedir}/liburing/
%{_includedir}/liburing.h
%{_libdir}/liburing.so
%{_libdir}/liburing-ffi.so
%{_libdir}/pkgconfig/*
%{_mandir}/man2/*
%{_mandir}/man3/*
%{_mandir}/man7/*
%changelog