linuxptp/linuxptp.spec
Martin Pluskal d0543b4006 Accepting request 1110590 from home:jbohac:branches:network:time
- Update to version 4.1:
  * Version 4.1
  * phc2sys: Fix -n option with -w.
  * phc2sys: Avoid segfault with default UDS address.
  * phc2sys: Improve logging with single domain.
  * ptp4l man: Add description for setting kthreads priorities
  * sk: don't report random errno on timeout
  * phc_ctl: explicitly check for adjust_phase definition
  * raw: Fix PRP trailer detection
  * remove C99 style loop variable declarations
  * phc2sys: Add multi-domain synchronization.
  * phc2sys: Shallow do_loop().
  * phc2sys: Create pmc agent after processing options.
  * phc2sys: Rename phc2sys_private to domain.
  * Use the 802.1AS peer delay computation when transportSpecific is 1
  * Resolve false hybrid_e2e warning
  * Fix SERVO_LOCKED_STABLE behavior.
  * Version 4.0
  * clock: Fix summary interval in free-running mode.
  * Avoid switching PHC when phc_index is negative
  * ts2phc: Fix memory leak on initial error path.
  * power profile: Fix regression in the default configuration file.
  * msg: append TLV onto all PTP event messages
  * Fix detection of VLAN over bond support in case the driver does not support SIOCGHWTSTAMP ioctl.
  * Clear pending errors on sockets.
  * ntpshm: Invalidate SHM data before releasing the servo
  * lstab: Update leapfile validity
  * port: Don't switch to PHC with SW timestamping.
  * ts2phc: Fix potential null-pointer dereference
  * ts2phc: Prevent reporting poll error when received termination signal

OBS-URL: https://build.opensuse.org/request/show/1110590
OBS-URL: https://build.opensuse.org/package/show/network:time/linuxptp?expand=0&rev=23
2023-09-13 08:26:59 +00:00

112 lines
3.2 KiB
RPMSpec

#
# spec file for package linuxptp
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
#Compat macro for new _fillupdir macro introduced in Nov 2017
%if ! %{defined _fillupdir}
%define _fillupdir %{_localstatedir}/adm/fillup-templates
%endif
Name: linuxptp
Version: 4.1
Release: 0
Summary: Precision Time Protocol v2 daemon
License: GPL-2.0-or-later
Group: Productivity/Networking/Other
URL: http://linuxptp.sourceforge.net/
Source0: %{name}-%{version}.tar.xz
Source1: ptp4l.service
Source2: sysconfig.ptp4l
Source4: linuxptp-howto.txt
Source5: phc2sys.service
Source6: sysconfig.phc2sys
BuildRequires: kernel-devel
BuildRequires: systemd-rpm-macros
Requires(pre): %fillup_prereq
Provides: ptp-timekeeping
%{?systemd_requires}
%description
This software is an implementation of the Precision Time Protocol (PTP)
according to the IEEE1588 standard for Linux.
%prep
%setup -q
%build
export EXTRA_CFLAGS="%{optflags} -Iusr/include"
make %{?_smp_mflags}
cp %{SOURCE4} .
%install
make prefix=%{buildroot}%{_prefix} mandir=%{buildroot}/%{_mandir} install
install -Dpm 644 %{SOURCE1} %{buildroot}/%{_unitdir}/ptp4l.service
install -Dpm 644 %{SOURCE5} %{buildroot}/%{_unitdir}/phc2sys.service
ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rcptp4l
ln -s %{_sbindir}/service %{buildroot}%{_sbindir}/rcphc2sys
install -Dpm 644 configs/default.cfg %{buildroot}/%{_sysconfdir}/ptp4l.conf
install -Dpm 644 %{SOURCE2} %{buildroot}%{_fillupdir}/sysconfig.ptp4l
install -Dpm 644 %{SOURCE6} %{buildroot}%{_fillupdir}/sysconfig.phc2sys
%pre
%service_add_pre ptp4l.service phc2sys.service
%post
%{fillup_only -n ptp4l}
%{fillup_only -n phc2sys}
%service_add_post ptp4l.service phc2sys.service
%preun
%service_del_preun ptp4l.service phc2sys.service
%postun
%service_del_postun ptp4l.service phc2sys.service
%files
%license COPYING
%doc README.org linuxptp-howto.txt configs
%{_unitdir}/ptp4l.service
%{_unitdir}/phc2sys.service
%{_sbindir}/rcptp4l
%{_sbindir}/rcphc2sys
%config %{_sysconfdir}/ptp4l.conf
%{_sbindir}/hwstamp_ctl
%{_sbindir}/phc2sys
%{_sbindir}/phc_ctl
%{_sbindir}/pmc
%{_sbindir}/ptp4l
%{_sbindir}/nsm
%{_sbindir}/timemaster
%{_sbindir}/ts2phc
%{_sbindir}/tz2alt
%{_mandir}/man8/hwstamp_ctl.8%{?ext_man}
%{_mandir}/man8/nsm.8%{?ext_man}
%{_mandir}/man8/phc2sys.8%{?ext_man}
%{_mandir}/man8/phc_ctl.8%{?ext_man}
%{_mandir}/man8/pmc.8%{?ext_man}
%{_mandir}/man8/ptp4l.8%{?ext_man}
%{_mandir}/man8/timemaster.8%{?ext_man}
%{_mandir}/man8/ts2phc.8%{?ext_man}
%{_mandir}/man8/tz2alt.8%{?ext_man}
%{_fillupdir}/sysconfig.ptp4l
%{_fillupdir}/sysconfig.phc2sys
%changelog