maven-archiver/maven-archiver.spec

94 lines
2.6 KiB
RPMSpec

#
# spec file for package maven-archiver
#
# Copyright (c) 2023 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%bcond_with tests
Name: maven-archiver
Version: 3.6.1
Release: 0
Summary: Maven Archiver
License: Apache-2.0
Group: Development/Libraries/Java
URL: https://maven.apache.org/shared/maven-archiver/
Source0: https://repo1.maven.org/maven2/org/apache/maven/%{name}/%{version}/%{name}-%{version}-source-release.zip
Source1: %{name}-build.xml
BuildRequires: ant
BuildRequires: fdupes
BuildRequires: javapackages-local
BuildRequires: maven-lib
BuildRequires: maven-shared-utils
BuildRequires: plexus-archiver >= 4.2.0
BuildRequires: plexus-interpolation >= 1.25
BuildRequires: plexus-utils >= 3.3.0
BuildRequires: sisu-plexus
BuildRequires: unzip
BuildArch: noarch
%description
The Maven Archiver is used by other Maven plugins
to handle packaging
%package javadoc
Summary: Javadoc for %{name}
Group: Documentation/HTML
%description javadoc
Javadoc for %{name}.
%prep
%setup -q
cp %{SOURCE1} build.xml
%pom_xpath_remove pom:project/pom:parent/pom:relativePath
%build
mkdir -p lib
build-jar-repository -s lib \
org.eclipse.sisu.plexus \
maven-shared-utils/maven-shared-utils \
maven/maven-artifact maven/maven-core \
maven/maven-model \
plexus/interpolation \
plexus/archiver
%{ant} \
jar javadoc
%install
# jar
install -dm 0755 %{buildroot}%{_javadir}/%{name}
install -pm 0644 target/%{name}-%{version}.jar %{buildroot}%{_javadir}/%{name}/%{name}.jar
# pom
install -dm 0755 %{buildroot}%{_mavenpomdir}/%{name}
%{mvn_install_pom} pom.xml %{buildroot}%{_mavenpomdir}/%{name}/%{name}.pom
%add_maven_depmap %{name}/%{name}.pom %{name}/%{name}.jar
# javadoc
install -dm 0755 %{buildroot}%{_javadocdir}/%{name}
cp -pr target/site/apidocs/* %{buildroot}%{_javadocdir}/%{name}/
%fdupes -s %{buildroot}%{_javadocdir}
%files -f .mfiles
%license LICENSE
%doc NOTICE
%files javadoc
%{_javadocdir}/%{name}
%license LICENSE
%doc NOTICE
%changelog