mbox-importer/mbox-importer.spec

77 lines
2.4 KiB
RPMSpec

#
# spec file for package mbox-importer
#
# Copyright (c) 2024 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define kf6_version 6.3.0
%define qt6_version 6.6.0
%define kpim6_version 6.2.1
%bcond_without released
Name: mbox-importer
Version: 24.08.1
Release: 0
Summary: Tool for importing mbox archives into akonadi
License: GPL-2.0-or-later AND LGPL-2.1-or-later
URL: https://www.kde.org
Source0: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz
%if %{with released}
Source1: https://download.kde.org/stable/release-service/%{version}/src/%{name}-%{version}.tar.xz.sig
Source2: applications.keyring
%endif
BuildRequires: kf6-extra-cmake-modules >= %{kf6_version}
BuildRequires: cmake(KF6Config) >= %{kf6_version}
BuildRequires: cmake(KF6Crash) >= %{kf6_version}
BuildRequires: cmake(KF6KIO) >= %{kf6_version}
BuildRequires: cmake(KF6IconThemes) >= %{kf6_version}
BuildRequires: cmake(KF6Service) >= %{kf6_version}
BuildRequires: cmake(KPim6Akonadi) >= %{kpim6_version}
BuildRequires: cmake(KPim6IdentityManagementCore) >= %{kpim6_version}
BuildRequires: cmake(KPim6MailCommon) >= %{kpim6_version}
BuildRequires: cmake(KPim6MailImporterAkonadi) >= %{kpim6_version}
BuildRequires: cmake(Qt6Gui) >= %{qt6_version}
BuildRequires: cmake(Qt6Widgets) >= %{qt6_version}
# It can only build on the same platforms as Qt Webengine
ExclusiveArch: x86_64 %{x86_64} aarch64 riscv64
%description
This package contains a tool that can be used to import mbox archives
into akonadi.
%lang_package
%prep
%autosetup -p1
%build
%cmake_kf6
%kf6_build
%install
%kf6_install
%find_lang %{name} --all-name
%files
%license LICENSES/*
%{_kf6_applicationsdir}/org.kde.mboximporter.desktop
%{_kf6_bindir}/mboximporter
%files lang -f %{name}.lang
%changelog