neatvnc/neatvnc.spec
Michael Vetter 1a598e9a51 - Update to 0.9.2:
* This patch release adds missing bounds checks.
    Two buffer overflow vulnerabilities were reported by Frederik
    Reiter who also provided patches to fix them.
    There are potential security implications, but only authenticated
    clients would be able to exploit these vulnerabilities, if at all.
    Nevertheless, it is prudent to update as soon as possible.

- Update to 0.9.1:
  * Fix a data type mismatch in the clipboard code that caused the
    build to fail for 32 bit architectures.

- Update to 0.9.0:
  Highlights:
  * A v4l2m2m based H.264 encoder that works on Raspberry Pi 1 to 4,
    sponsored by Raspberry Pi Ltd.
  * Extended clipboard for UTF-8 text was implemented by Attila Fidan.
  * Listening on a pre-bound file descriptor, implemented by Attila Fidan.
  * The continuous updates extension was implemented by Philipp Zabel.
  * We now have simple bandwidth estimation and improved frame pacing.
  * Methods for rating pixel formats and modifiers have according to Neat VNC's
    preferences have been added.
  * The Qemu/VMWare LED state extensions have been implemented.
  * H.264 encoders will now encode the correct colour space into the elementary
    stream.
  Bug fixes:
  * Some memory leaks and reference counting errors have been eradicated.
  * A race between resizing events and framebuffer updates that would cause a
    buffer with the previous size to be sent after a resize event has been fixed.
  * Buffers with 24 bits per pixel will now result in 32 bpp being reported to

OBS-URL: https://build.opensuse.org/package/show/X11:Wayland/neatvnc?expand=0&rev=31
2025-01-07 10:56:20 +00:00

86 lines
2.1 KiB
RPMSpec

#
# spec file for package neatvnc
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%define libsoname libneatvnc0
Name: neatvnc
Version: 0.9.2
Release: 0
Summary: A VNC server library
License: ISC
Group: System/GUI/Other
URL: https://github.com/any1/neatvnc
Source0: %{name}-%{version}.tar.xz
Patch0: fix-build-in-15.6.patch
BuildRequires: meson
BuildRequires: pkgconfig
BuildRequires: pkgconfig(aml) >= 0.3.0
BuildRequires: pkgconfig(gbm)
BuildRequires: pkgconfig(gnutls)
BuildRequires: pkgconfig(libavcodec)
BuildRequires: pkgconfig(libavfilter)
BuildRequires: pkgconfig(libavutil)
BuildRequires: pkgconfig(libdrm)
BuildRequires: pkgconfig(libturbojpeg)
BuildRequires: pkgconfig(pixman-1)
BuildRequires: pkgconfig(zlib)
%description
This is a VNC server library.
%package devel
Summary: Development files for %{name}
Group: Development/Libraries/C and C++
Requires: %libsoname = %{version}
%description devel
Development files and headers for %{name}.
%package -n %libsoname
Summary: A VNC server library
Group: System/Libraries
%description -n %libsoname
A VNC server library.
%prep
%autosetup -p1
%build
%meson
%meson_build
%install
%meson_install
%ldconfig_scriptlets -n %libsoname
%files devel
%license COPYING
%doc README.md
%{_includedir}/neatvnc.h
%{_libdir}/libneatvnc.so
%{_libdir}/pkgconfig/neatvnc.pc
%files -n %libsoname
%{_libdir}/libneatvnc.so.*
%changelog