7d95763414
Split up the ubuntu patch OBS-URL: https://build.opensuse.org/request/show/197181 OBS-URL: https://build.opensuse.org/package/show/network:utilities/netcat-openbsd?expand=0&rev=12
424 lines
17 KiB
Diff
424 lines
17 KiB
Diff
--- netcat-openbsd-1.89.orig/debian/rules
|
|
+++ netcat-openbsd-1.89/debian/rules
|
|
@@ -0,0 +1,64 @@
|
|
+#!/usr/bin/make -f
|
|
+#export DH_VERBOSE=1
|
|
+
|
|
+DEB_CFLAGS = -g -Wall
|
|
+ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
|
|
+DEB_CFLAGS += -O0
|
|
+else
|
|
+DEB_CFLAGS += -O2
|
|
+endif
|
|
+ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
|
|
+INSTALL_PROG = install -m 0755
|
|
+else
|
|
+INSTALL_PROG = install -s -m 0755
|
|
+endif
|
|
+DEB_VER = $(shell dpkg-parsechangelog | sed -n 's/^Version: //p')
|
|
+
|
|
+patch: patch-stamp
|
|
+patch-stamp:
|
|
+ QUILT_PATCHES=debian/patches quilt push -a || test $$? = 2
|
|
+ touch patch-stamp
|
|
+
|
|
+unpatch:
|
|
+ QUILT_PATCHES=debian/patches quilt pop -a -R || test $$? = 2
|
|
+ rm -rf .pc patch-stamp
|
|
+
|
|
+build: build-stamp
|
|
+build-stamp: patch-stamp
|
|
+
|
|
+ $(MAKE) CFLAGS='$(DEB_CFLAGS) -DDEBIAN_VERSION=\"$(DEB_VER)\"'
|
|
+ touch build-stamp
|
|
+
|
|
+clean: unpatch
|
|
+ dh_testdir
|
|
+ dh_clean patch-stamp build-stamp
|
|
+ $(MAKE) clean
|
|
+
|
|
+install:
|
|
+ dh_testdir
|
|
+ dh_testroot
|
|
+ dh_clean -k
|
|
+ dh_installdirs
|
|
+
|
|
+ $(INSTALL_PROG) nc $(CURDIR)/debian/netcat-openbsd/bin/nc.openbsd
|
|
+ cp nc.1 $(CURDIR)/debian/netcat-openbsd/usr/share/man/man1/nc_openbsd.1
|
|
+
|
|
+binary-indep: build install
|
|
+
|
|
+binary-arch: build install
|
|
+ dh_testdir
|
|
+ dh_testroot
|
|
+ dh_installchangelogs
|
|
+ dh_installdocs
|
|
+ dh_installexamples debian/examples/*
|
|
+ dh_link
|
|
+ dh_strip
|
|
+ dh_compress -Xexamples
|
|
+ dh_fixperms
|
|
+ dh_installdeb
|
|
+ dh_shlibdeps
|
|
+ dh_gencontrol
|
|
+ dh_md5sums
|
|
+ dh_builddeb
|
|
+
|
|
+binary: binary-indep binary-arch
|
|
--- netcat-openbsd-1.89.orig/debian/netcat-openbsd.prerm
|
|
+++ netcat-openbsd-1.89/debian/netcat-openbsd.prerm
|
|
@@ -0,0 +1,7 @@
|
|
+#!/bin/sh -e
|
|
+
|
|
+if [ "$1" = "remove" ]; then
|
|
+ update-alternatives --remove nc /bin/nc.openbsd
|
|
+fi
|
|
+
|
|
+#DEBHELPER#
|
|
--- netcat-openbsd-1.89.orig/debian/netcat-openbsd.postinst
|
|
+++ netcat-openbsd-1.89/debian/netcat-openbsd.postinst
|
|
@@ -0,0 +1,13 @@
|
|
+#!/bin/sh -e
|
|
+
|
|
+if [ "$1" = "configure" ]; then
|
|
+ update-alternatives \
|
|
+ --install /bin/nc nc /bin/nc.openbsd 50 \
|
|
+ --slave /bin/netcat netcat /bin/nc.openbsd \
|
|
+ --slave /usr/share/man/man1/nc.1.gz nc.1.gz \
|
|
+ /usr/share/man/man1/nc_openbsd.1.gz \
|
|
+ --slave /usr/share/man/man1/netcat.1.gz netcat.1.gz \
|
|
+ /usr/share/man/man1/nc_openbsd.1.gz
|
|
+fi
|
|
+
|
|
+#DEBHELPER#
|
|
--- netcat-openbsd-1.89.orig/debian/netcat-openbsd.dirs
|
|
+++ netcat-openbsd-1.89/debian/netcat-openbsd.dirs
|
|
@@ -0,0 +1,2 @@
|
|
+bin
|
|
+usr/share/man/man1
|
|
--- netcat-openbsd-1.89.orig/debian/netcat-openbsd.README.Debian
|
|
+++ netcat-openbsd-1.89/debian/netcat-openbsd.README.Debian
|
|
@@ -0,0 +1,41 @@
|
|
+OpenBSD netcat for Debian
|
|
+-------------------------
|
|
+
|
|
+This package has been rebased on OpenBSD's implementation of netcat. The
|
|
+code has been massively cleaned up, and important functionality has been
|
|
+added.
|
|
+
|
|
+ -- Soren Hansen <soren@ubuntu.com> Tue, 15 Jan 2008 10:38:34 +0100
|
|
+
|
|
+The OpenBSD implementation has been split from netcat-traditional for
|
|
+two reasons (not counting sentimental value):
|
|
+
|
|
+ 1. Netcat should be part of the base system; OpenBSD netcat uses
|
|
+ strlcpy. While there is already a perfectly good implementation of
|
|
+ strlcpy in Debian, it is part of glib, which is not included in base.
|
|
+ 2. Packages should not be replaced under users' feet; a transitional
|
|
+ package will be provided for lenny so that users can note the new
|
|
+ package and switch if they wish.
|
|
+
|
|
+You may install this package alongside netcat-traditional; they both
|
|
+use the alternatives system for nc(1) as well as the deprecated alias
|
|
+netcat(1). Other implementations of netcat with compatible command line
|
|
+options are encouraged to also do so and provide the virtual package
|
|
+"netcat".
|
|
+
|
|
+The following features from netcat-traditional will not be added to this
|
|
+package:
|
|
+
|
|
+ * The -e and -c options (This should be done by redirecting the
|
|
+ appropriate file descriptors, not within netcat. How to do so should
|
|
+ be better documented.)
|
|
+ * Printing "connection refused" messages when -v is not specified
|
|
+ (because there is only one level of verbosity in this netcat, and
|
|
+ that message is primarily what the option is for.)
|
|
+
|
|
+Anything else that netcat-traditional does that this package doesn't
|
|
+is a bug. Wherever possible, command-line compatibility with the BSDs
|
|
+and Fedora is desired, but it should be easy to use netcat-openbsd as a
|
|
+"drop-in" replacement for netcat-traditional as well.
|
|
+
|
|
+ -- Decklin Foster <decklin@red-bean.com> Tue, 22 Jan 2008 18:50:08 -0500
|
|
--- netcat-openbsd-1.89.orig/debian/copyright
|
|
+++ netcat-openbsd-1.89/debian/copyright
|
|
@@ -0,0 +1,130 @@
|
|
+The netcat-openbsd Debian package was created by Soren Hansen
|
|
+<soren@ubuntu.com> and by Decklin Foster <decklin@red-bean.com>, based
|
|
+loosely on the original netcat package. The code itself was rewritten
|
|
+by the OpenBSD project, from the original implementation by Hobbit
|
|
+<hobbit@atstake.com>.
|
|
+
|
|
+Sources can be found at:
|
|
+
|
|
+ http://www.openbsd.org/cgi-bin/cvsweb/src/usr.bin/nc/
|
|
+
|
|
+Copyright and license of netcat.c:
|
|
+
|
|
+ Copyright (c) 2001 Eric Jackson <ericj@monkey.org>
|
|
+
|
|
+ Redistribution and use in source and binary forms, with or without
|
|
+ modification, are permitted provided that the following conditions
|
|
+ are met:
|
|
+
|
|
+ 1. Redistributions of source code must retain the above copyright
|
|
+ notice, this list of conditions and the following disclaimer.
|
|
+ 2. Redistributions in binary form must reproduce the above copyright
|
|
+ notice, this list of conditions and the following disclaimer in the
|
|
+ documentation and/or other materials provided with the distribution.
|
|
+ 3. The name of the author may not be used to endorse or promote products
|
|
+ derived from this software without specific prior written permission.
|
|
+
|
|
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
|
|
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
|
|
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
|
|
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
|
|
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
|
|
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
|
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
|
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
|
|
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+
|
|
+Copyright and license of atomicio.c:
|
|
+
|
|
+ Copyright (c) 2005 Anil Madhavapeddy. All rights served.
|
|
+ Copyright (c) 1995,1999 Theo de Raadt. All rights reserved.
|
|
+ All rights reserved.
|
|
+
|
|
+ Redistribution and use in source and binary forms, with or without
|
|
+ modification, are permitted provided that the following conditions
|
|
+ are met:
|
|
+ 1. Redistributions of source code must retain the above copyright
|
|
+ notice, this list of conditions and the following disclaimer.
|
|
+ 2. Redistributions in binary form must reproduce the above copyright
|
|
+ notice, this list of conditions and the following disclaimer in the
|
|
+ documentation and/or other materials provided with the distribution.
|
|
+
|
|
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
|
|
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
|
|
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
|
|
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
|
|
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
|
|
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
|
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
|
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
|
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
|
|
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
|
+
|
|
+ Copyright (c) 2005 Anil Madhavapeddy. All rights served.
|
|
+ Copyright (c) 1995,1999 Theo de Raadt. All rights reserved.
|
|
+
|
|
+Copyright of socks.c (license is identical to that of atomicio.c):
|
|
+
|
|
+ Copyright (c) 1999 Niklas Hallqvist. All rights reserved.
|
|
+ Copyright (c) 2004, 2005 Damien Miller. All rights reserved.
|
|
+
|
|
+Copyright and license of readpassphrase.c:
|
|
+
|
|
+ Copyright (c) 2000-2002, 2007 Todd C. Miller <Todd.Miller@courtesan.com>
|
|
+
|
|
+ Permission to use, copy, modify, and distribute this software for any
|
|
+ purpose with or without fee is hereby granted, provided that the above
|
|
+ copyright notice and this permission notice appear in all copies.
|
|
+
|
|
+ THE SOFTWARE IS PROVIDED "AS IS" AND THE AUTHOR DISCLAIMS ALL WARRANTIES
|
|
+ WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES OF
|
|
+ MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR
|
|
+ ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES
|
|
+ WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN AN
|
|
+ ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ARISING OUT OF
|
|
+ OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE.
|
|
+
|
|
+ Sponsored in part by the Defense Advanced Research Projects
|
|
+ Agency (DARPA) and Air Force Research Laboratory, Air Force
|
|
+ Materiel Command, USAF, under agreement number F39502-99-1-0512.
|
|
+
|
|
+Copyright and license of base64.c:
|
|
+
|
|
+ Copyright (c) 1996 by Internet Software Consortium.
|
|
+
|
|
+ Permission to use, copy, modify, and distribute this software for any
|
|
+ purpose with or without fee is hereby granted, provided that the above
|
|
+ copyright notice and this permission notice appear in all copies.
|
|
+
|
|
+ THE SOFTWARE IS PROVIDED "AS IS" AND INTERNET SOFTWARE CONSORTIUM DISCLAIMS
|
|
+ ALL WARRANTIES WITH REGARD TO THIS SOFTWARE INCLUDING ALL IMPLIED WARRANTIES
|
|
+ OF MERCHANTABILITY AND FITNESS. IN NO EVENT SHALL INTERNET SOFTWARE
|
|
+ CONSORTIUM BE LIABLE FOR ANY SPECIAL, DIRECT, INDIRECT, OR CONSEQUENTIAL
|
|
+ DAMAGES OR ANY DAMAGES WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR
|
|
+ PROFITS, WHETHER IN AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS
|
|
+ ACTION, ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS
|
|
+ SOFTWARE.
|
|
+
|
|
+ Portions Copyright (c) 1995 by International Business Machines, Inc.
|
|
+
|
|
+ International Business Machines, Inc. (hereinafter called IBM) grants
|
|
+ permission under its copyrights to use, copy, modify, and distribute this
|
|
+ Software with or without fee, provided that the above copyright notice and
|
|
+ all paragraphs of this notice appear in all copies, and that the name of IBM
|
|
+ not be used in connection with the marketing of any product incorporating
|
|
+ the Software or modifications thereof, without specific, written prior
|
|
+ permission.
|
|
+
|
|
+ To the extent it has a right to do so, IBM grants an immunity from suit
|
|
+ under its patents, if any, for the use, sale or manufacture of products to
|
|
+ the extent that such products are used for performing Domain Name System
|
|
+ dynamic updates in TCP/IP networks by means of the Software. No immunity is
|
|
+ granted for any product per se or for any other function of any product.
|
|
+
|
|
+ THE SOFTWARE IS PROVIDED "AS IS", AND IBM DISCLAIMS ALL WARRANTIES,
|
|
+ INCLUDING ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
|
|
+ PARTICULAR PURPOSE. IN NO EVENT SHALL IBM BE LIABLE FOR ANY SPECIAL,
|
|
+ DIRECT, INDIRECT, OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES WHATSOEVER ARISING
|
|
+ OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THIS SOFTWARE, EVEN
|
|
+ IF IBM IS APPRISED OF THE POSSIBILITY OF SUCH DAMAGES.
|
|
--- netcat-openbsd-1.89.orig/debian/control
|
|
+++ netcat-openbsd-1.89/debian/control
|
|
@@ -0,0 +1,25 @@
|
|
+Source: netcat-openbsd
|
|
+Section: net
|
|
+Priority: optional
|
|
+Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
|
|
+XSBC-Original-Maintainer: Decklin Foster <decklin@red-bean.com>
|
|
+Standards-Version: 3.7.3
|
|
+Build-Depends: quilt, debhelper (>= 4.0.0), libglib2.0-dev
|
|
+
|
|
+Package: netcat-openbsd
|
|
+Architecture: any
|
|
+Depends: ${shlibs:Depends}
|
|
+Provides: netcat
|
|
+Conflicts: netcat (<< 1.10-35)
|
|
+Replaces: netcat (<< 1.10-35)
|
|
+Description: TCP/IP swiss army knife
|
|
+ A simple Unix utility which reads and writes data across network
|
|
+ connections using TCP or UDP protocol. It is designed to be a reliable
|
|
+ "back-end" tool that can be used directly or easily driven by other
|
|
+ programs and scripts. At the same time it is a feature-rich network
|
|
+ debugging and exploration tool, since it can create almost any kind of
|
|
+ connection you would need and has several interesting built-in
|
|
+ capabilities.
|
|
+ .
|
|
+ This package contains the OpenBSD rewrite of netcat, including support
|
|
+ for IPv6, proxies, and Unix sockets.
|
|
--- netcat-openbsd-1.89.orig/debian/compat
|
|
+++ netcat-openbsd-1.89/debian/compat
|
|
@@ -0,0 +1 @@
|
|
+4
|
|
--- netcat-openbsd-1.89.orig/debian/changelog
|
|
+++ netcat-openbsd-1.89/debian/changelog
|
|
@@ -0,0 +1,113 @@
|
|
+netcat-openbsd (1.89-4ubuntu1) oneiric; urgency=low
|
|
+
|
|
+ * Merge from Debian unstable (LP: #803856). Remaining changes:
|
|
+ - debian/patches/dccp.patch: Added support for dccp
|
|
+ - debian/patches/netcat-info.patch: Add info about netcat-traditional
|
|
+ if you are looking for an option when it is not available.
|
|
+ (LP: #590925)
|
|
+ - debian/patches/verbose-message-to-stderr.patch: Log "Connection to ..."
|
|
+ messages to stderr (LP: #519210)
|
|
+ - Modify Maintainer value to match the DebianMaintainerField
|
|
+ specification.
|
|
+ - Fix build failure with --as-needed.
|
|
+
|
|
+ -- Adam Gandelman <adamg@canonical.com> Fri, 01 Jul 2011 23:34:38 +0200
|
|
+
|
|
+netcat-openbsd (1.89-4) unstable; urgency=low
|
|
+
|
|
+ * Quit immediately after EOF if -q is not given (i.e. make the default
|
|
+ equivalent to -q 0). This is the standard upstream behavior and what
|
|
+ other Linux distributions use. It is different from netcat-traditional,
|
|
+ but compatibility with other versions of OpenBSD netcat is more
|
|
+ important. (Closes: #502188)
|
|
+
|
|
+ -- Decklin Foster <decklin@red-bean.com> Sun, 18 Apr 2010 20:05:08 -0400
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu6) oneiric; urgency=low
|
|
+
|
|
+ * debian/patches/dccp.patch: Added support for dccp
|
|
+
|
|
+ -- Michael Gendelman <genged@gmail.com> Sat, 11 Jun 2011 01:09:57 +0300
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu5) natty; urgency=low
|
|
+
|
|
+ * debian/patches/quit-timer.patch: Re-enabled, but set default to 0 to match
|
|
+ current behavior.
|
|
+ * debian/patches/netcat-info.patch: Add info about netcat-traditional
|
|
+ if you are looking for an option when it is not available.
|
|
+ (LP: #590925)
|
|
+
|
|
+ -- Chuck Short <zulcss@ubuntu.com> Tue, 04 Jan 2011 14:31:12 -0500
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu4) natty; urgency=low
|
|
+
|
|
+ * debian/patches/quit-timer.patch: Drop quit-time.patch as per disccussion on
|
|
+ ubuntu-server. (LP: #590925)
|
|
+
|
|
+ -- Chuck Short <zulcss@ubuntu.com> Mon, 03 Jan 2011 10:08:24 -0500
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu3) natty; urgency=low
|
|
+
|
|
+ * Fix build failure with --as-needed.
|
|
+
|
|
+ -- Matthias Klose <doko@ubuntu.com> Fri, 19 Nov 2010 14:40:32 +0100
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu2) lucid; urgency=low
|
|
+
|
|
+ * Log "Connection to ..." messages to stderr (LP: #519210)
|
|
+
|
|
+ -- Stefan Haller <haliner@googlemail.com> Tue, 09 Feb 2010 10:42:03 +0100
|
|
+
|
|
+netcat-openbsd (1.89-3ubuntu1) intrepid; urgency=low
|
|
+
|
|
+ * Merge from debian unstable.
|
|
+ * Reinsert quit-timer, but set default to 0 to match current behaviour.
|
|
+ (LP: #242350)
|
|
+
|
|
+ -- Soren Hansen <soren@ubuntu.com> Wed, 25 Jun 2008 18:47:47 +0200
|
|
+
|
|
+netcat-openbsd (1.89-3) unstable; urgency=low
|
|
+
|
|
+ * Silence -z flag, for compatibility with netcat-traditional (Closes:
|
|
+ #464564)
|
|
+ * Move stray line in socks.c to quilt patch series (Closes: #485160)
|
|
+ * Add missing documentation for -q option to man page.
|
|
+
|
|
+ -- Decklin Foster <decklin@red-bean.com> Thu, 19 Jun 2008 16:20:01 -0400
|
|
+
|
|
+netcat-openbsd (1.89-2ubuntu1) hardy; urgency=low
|
|
+
|
|
+ * Remove quit-timer.patch. It added a bad, bad default behaviour of keeping
|
|
+ connections open even though the client had closed the connection. (LP:
|
|
+ #201340)
|
|
+ * Modify Maintainer value to match the DebianMaintainerField
|
|
+ specification.
|
|
+
|
|
+ -- Soren Hansen <soren@ubuntu.com> Wed, 12 Mar 2008 11:49:28 +0100
|
|
+
|
|
+netcat-openbsd (1.89-2) unstable; urgency=low
|
|
+
|
|
+ * Replace references to "netcat-base" with "netcat-traditional" (future
|
|
+ name of the old netcat package).
|
|
+
|
|
+ -- Decklin Foster <decklin@red-bean.com> Wed, 30 Jan 2008 18:24:46 -0500
|
|
+
|
|
+netcat-openbsd (1.89-1) unstable; urgency=low
|
|
+
|
|
+ * Initial release. (Closes: #145798)
|
|
+ * Includes support for:
|
|
+ - IPv6 (Closes: #461317)
|
|
+ - Unix domain sockets (Closes: #348564)
|
|
+ - SOCKS (Closes: #142898)
|
|
+ * Conflict with netcat versions older than netcat-traditional, so that we
|
|
+ can use alternatives.
|
|
+ * Port some features over from netcat-traditional:
|
|
+ - Exit successfully when printing help text (-h), and include the Debian
|
|
+ revision.
|
|
+ - Add the -q (quit on standard input EOF) flag.
|
|
+ - Add support for specifying ports by name (/etc/services). Unlike the
|
|
+ old hack for this, nc will first try to find a named service, then fall
|
|
+ back to numeric parsing, so no escaping is needed.
|
|
+
|
|
+ -- Decklin Foster <decklin@red-bean.com> Mon, 21 Jan 2008 18:41:37 -0500
|
|
+
|