python-Deprecated/python-Deprecated.spec
Dirk Mueller 8143745a4a - update to 1.2.18:
* Fix #78: Fix configuration for Packit 1.0.0
  * Fix #79: Fix the configuration for the intersphinx mapping in
    the Sphinx documentation. See How to link to other
    documentation projects with Intersphinx.
  * Drop support for Python older than 3.7 in GitHub Actions.
  * Resolve Python 2.7 support issue introduced in v1.2.14 in
    sphinx.py.
  * Fix #69: Add extra_stacklevel argument for interoperating
    with other wrapper functions (refer to #68 for a concrete use
    case).
  * Fix #73: Update class method deprecation warnings for Python
    3.13.
  * Fix #75: Update GitHub workflows and fix development
    dependencies for Python 3.12.
  * Fix #66: discontinue TravisCI and AppVeyor due to end of free
    support.
  * Fix #60: return a correctly dedented docstring when long
    docstring are using the D212 or D213 format.
  * Add support for Python 3.11.
  * Drop support for Python older than 3.7 in build systems like
    pytest and tox, while ensuring the library remains
    production-compatible.
  * Update GitHub workflow to run in recent Python versions.
  * Fix #45: Change the signature of the
    :func:`~deprecated.sphinx.deprecated` decorator to reflect
    the valid use cases.
  * Fix #48: Fix versionadded and versionchanged decorators: do
    not return a decorator factory, but a Wrapt adapter.
  * Fix configuration for AppVeyor: simplify the test scripts and

OBS-URL: https://build.opensuse.org/package/show/devel:languages:python/python-Deprecated?expand=0&rev=26
2025-02-03 13:20:01 +00:00

68 lines
2.0 KiB
RPMSpec

#
# spec file for package python-Deprecated
#
# Copyright (c) 2025 SUSE LLC
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via https://bugs.opensuse.org/
#
%{?!python_module:%define python_module() python-%{**} python3-%{**}}
%{?sle15_python_module_pythons}
Name: python-Deprecated
Version: 1.2.18
Release: 0
Summary: Python @deprecated decorator
License: MIT
Group: Development/Languages/Python
URL: https://github.com/tantale/deprecated
Source: https://files.pythonhosted.org/packages/source/d/deprecated/deprecated-%{version}.tar.gz
BuildRequires: %{python_module pytest}
BuildRequires: %{python_module setuptools}
BuildRequires: %{python_module wrapt >= 1.10}
BuildRequires: fdupes
BuildRequires: python-rpm-macros
Requires: python-wrapt >= 1.10
BuildArch: noarch
Provides: python-deprecated = %{version}-%{release}
%python_subpackages
%description
If you need to mark a function or a method as deprecated,
you can use the ``@deprecated`` decorator.
%prep
%setup -q -n deprecated-%{version}
%build
%python_build
%install
%python_install
# Fix python-bytecode-inconsistent-mtime
pushd %{buildroot}%{python_sitelib}
find . -name '*.pyc' -exec rm -f '{}' ';'
python%python_bin_suffix -m compileall *.py ';'
popd
%python_expand %fdupes %{buildroot}%{$python_sitelib}
%check
%pytest
%files %{python_files}
%doc CHANGELOG.rst README.md
%license LICENSE.rst
%{python_sitelib}/deprecated
%{python_sitelib}/Deprecated-%{version}*-info
%changelog